Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 1st June 2008, 20:15
hvrossum hvrossum is offline
Member
 
Join Date: Dec 2007
Posts: 66
Thanks: 8
Thanked 0 Times in 0 Posts
Default

research on errors learns me this
/var/spool/mqueue is not owned by user 108 !

user 108 does not exist. the dir is owned by user root en group root

Could not read directory /var/lock/subsys/MailScanner
This directory does not exist (in subsys I only have bastille-firewall as a sub dir) and I can;t add the directory ,even though I did the su command
__________________
I am stil a Linux amateur, never thought that a sales person would like fiddling around with Linux.

Setup:
Dell Power Edge SC440
Ubuntu 8.04
ISPConfig
Webmin 1.420
Reply With Quote
Sponsored Links
  #12  
Old 1st June 2008, 20:23
hvrossum hvrossum is offline
Member
 
Join Date: Dec 2007
Posts: 66
Thanks: 8
Thanked 0 Times in 0 Posts
Default

Last error is /var/spool/mqueue is not owned by user 108

I changed the conf file so that the other error is gone as the directory it was point to did not exists.

In webmin I can look at Mailscanner but it says it is not running, when trying to start it it doesnot change.

strange!!
__________________
I am stil a Linux amateur, never thought that a sales person would like fiddling around with Linux.

Setup:
Dell Power Edge SC440
Ubuntu 8.04
ISPConfig
Webmin 1.420
Reply With Quote
  #13  
Old 1st June 2008, 23:03
hvrossum hvrossum is offline
Member
 
Join Date: Dec 2007
Posts: 66
Thanks: 8
Thanked 0 Times in 0 Posts
Default

I changed the owner and grp of the mentioned queue to postfix

(stop mailscanner before you try this)

Now I get the error

Could not test file ownership abilities on /var/lock/subsys/MailScanner.ownertest.18545, please delete the file

The file can't be found in this dir. hmmm??
__________________
I am stil a Linux amateur, never thought that a sales person would like fiddling around with Linux.

Setup:
Dell Power Edge SC440
Ubuntu 8.04
ISPConfig
Webmin 1.420
Reply With Quote
  #14  
Old 2nd June 2008, 13:52
Rocky Rocky is offline
Senior Member
 
Join Date: Oct 2005
Posts: 553
Thanks: 14
Thanked 49 Times in 48 Posts
Default

Harry,

Have you disabled apparmor? Also, do the following and your system should create the missing directories at boot up with the proper permissions.

Edit /etc/rc.local and add the following before the exit line:

Code:
 
mkdir /var/run/MailScanner
mkdir /var/lock/subsys
mkdir /var/lock/subsys/MailScanner
chown -R postfix:postfix /var/run/MailScanner
chown -R postfix:postfix /var/lock/subsys/MailScanner
/etc/init.d/postfix restart
/etc/init.d/mailscanner restart
After you've done that, reboot your system and see what happens. If you're still getting errors, please post them here.
__________________
Home of the SpamSnake
Reply With Quote
  #15  
Old 2nd June 2008, 14:08
hvrossum hvrossum is offline
Member
 
Join Date: Dec 2007
Posts: 66
Thanks: 8
Thanked 0 Times in 0 Posts
Default

Hi Rocky

I did both disables apprmor and put the lins in the etc/rc.local file.

Reboot

Jun 2 14:01:47 ubuntu freshclam[6723]: See the FAQ at http://www.clamav.net/support/faq for an explanation.
Jun 2 14:01:47 ubuntu freshclam[6723]: Your ClamAV installation is OUTDATED!
Jun 2 14:01:47 ubuntu freshclam[6723]: Local version: 0.91.2 Recommended version: 0.93
Jun 2 14:01:47 ubuntu freshclam[6723]: DON'T PANIC! Read http://www.clamav.net/support/faq
Jun 2 14:01:47 ubuntu freshclam[6723]: main.inc is up to date (version: 46, sigs: 231834, f-level: 26, builder: sven)
Jun 2 14:01:47 ubuntu freshclam[6723]: daily.inc is up to date (version: 7321, sigs: 75070, f-level: 26, builder: ccordes)
Jun 2 14:01:47 ubuntu freshclam[6723]: --------------------------------------


All error messages seem to have solved.

Now I still need to get Imap back up, can't connect. And telnet is also still disconnecting
__________________
I am stil a Linux amateur, never thought that a sales person would like fiddling around with Linux.

Setup:
Dell Power Edge SC440
Ubuntu 8.04
ISPConfig
Webmin 1.420
Reply With Quote
  #16  
Old 2nd June 2008, 14:13
Rocky Rocky is offline
Senior Member
 
Join Date: Oct 2005
Posts: 553
Thanks: 14
Thanked 49 Times in 48 Posts
Default

Ok, so is postfix working or are you still getting errors in your mail.log? Don't worry about the clamav messages.
__________________
Home of the SpamSnake
Reply With Quote
The Following User Says Thank You to Rocky For This Useful Post:
hvrossum (2nd June 2008)
  #17  
Old 2nd June 2008, 23:51
mdumdei mdumdei is offline
Junior Member
 
Join Date: Mar 2008
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I had that problem trying to load it on an 8.04 jeos setup. I didn't comment out the 1st and 4th check_dir lines and instead changed the user and group to 'postfix' and 'www-data' and the set the MailScanner.conf 'Run as Group' to 'www-data' as well. That fixed the missing /var/lock/subsys/MailScanner problem and both MailScanner and postfix start without errors now. I'm not completely finished with the rest of Rocky's setup so not totally sure I didn't break something else with the Run As Group change but don't think so. Rocky would probably know. I also edited the init.d version of mailscanner rather than going at it through the S20 link under /etc/rc2.d -- same difference. So far that's the only snag I hit -- good instructions!
Reply With Quote
  #18  
Old 3rd June 2008, 00:59
Rocky Rocky is offline
Senior Member
 
Join Date: Oct 2005
Posts: 553
Thanks: 14
Thanked 49 Times in 48 Posts
Default

Glad to hear!

The Run As Group was left as postfix for those users who opt not to install MailWatch. It should not be a problem at all to change it to www-data.

mdumdei, I'm assuming you didn't have to do certain steps, but can you fill me in? I'll update the guide with them to save people some time when installing.

Rocky
__________________
Home of the SpamSnake
Reply With Quote
  #19  
Old 4th June 2008, 02:33
mdumdei mdumdei is offline
Junior Member
 
Join Date: Mar 2008
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

jeos doesn't load apparmor so I didn't have to take that out. Other than that, I think it I followed everything else as written for 8.04 server -- other than the modifying the check_dirs instead of commenting them. That eliminated the need to load anything into rc.local.

I have a question now though. I'm working on the do_message_ops.php code and hit the line:

if ($quarantined=quarantine_list_items($id,RPC_ONLY)) {
...

Is that a single '=' there like the if is evaluating for a non-zero value from quarantine_list_items (how it is now) or a double == for a compare?? I looked around in the forum and saw no complaints so am assuming it is correct as is.
Reply With Quote
  #20  
Old 4th June 2008, 03:18
Rocky Rocky is offline
Senior Member
 
Join Date: Oct 2005
Posts: 553
Thanks: 14
Thanked 49 Times in 48 Posts
 
Default

This is exactly what I have:
Code:
 if($quarantined = quarantine_list_items($id,RPC_ONLY)) {
__________________
Home of the SpamSnake
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Perfect Server Ubuntu 8.04 page 4 bind problem? navop Installation/Configuration 4 3rd July 2008 23:02
Ubuntu 8.04 - Postfix SSL|TLS The Perfect Server make-fun Installation/Configuration 4 27th May 2008 22:36
The Perfect Server UBUNTU 8.04 stuck step 8 Samir-12 Installation/Configuration 8 25th May 2008 13:47
ISPconfig problem - The perfect server Ubuntu 8.04 charles HOWTO-Related Questions 5 20th May 2008 23:54
The Perfect Server - Ubuntu Hardy Heron (Ubuntu 8.04 LTS Server) - Page4-DNS Server Linocks Installation/Configuration 3 13th May 2008 12:24


All times are GMT +2. The time now is 11:31.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.