Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 2nd November 2011, 17:56
dgmufasa dgmufasa is offline
Member
 
Join Date: Oct 2011
Posts: 86
Thanks: 5
Thanked 1 Time in 1 Post
Default ispconfig API change -> http server down

I made some changes to an ispconfig API. I changed the number of clients that could be created from 5 (resller) to 0 (no reseller).

Now, when starting the httpd, I get this error:
httpd: bad user name web88

Can you please provide steps that I can troubleshoot this problem?
Joomla is not accessible.
Myphpadmin is also down because of this.

Regards.
Reply With Quote
Sponsored Links
  #2  
Old 2nd November 2011, 18:00
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,034
Thanks: 826
Thanked 5,383 Times in 4,230 Posts
Default

Seems as if the user web88 is missing in /etc/passwd and /etc/shadow. There should be backups of these files with ~ appended to the name, if you find the line for the missing user in there, then readd them to passwd and shadow file and try to start apache again.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 2nd November 2011, 18:14
dgmufasa dgmufasa is offline
Member
 
Join Date: Oct 2011
Posts: 86
Thanks: 5
Thanked 1 Time in 1 Post
Default

Hello,

If I manually add web88 should this work? I went to to the directory:
/etc and did a "grep web88 *" and it did not list anything.

Regards.
Reply With Quote
  #4  
Old 2nd November 2011, 18:16
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,034
Thanks: 826
Thanked 5,383 Times in 4,230 Posts
Default

Yes, this should work too. But you must give that user the correct userid. If you go to the web88 dierctory and execute a ls -la, then the files should show up to be owned by a numeric number and not the user web88 anymore, this numeric number is the original userid of the web88 user and you should use that userid for the new user.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 2nd November 2011, 18:22
dgmufasa dgmufasa is offline
Member
 
Join Date: Oct 2011
Posts: 86
Thanks: 5
Thanked 1 Time in 1 Post
Default

I added a user manually but the system still will not come up.

it says: http not running, trying to start

Are there some instructions I can follow to just remove all pieces of the zone I tried to change (web, DB, users, mail) of it from ISPConfig?
Reply With Quote
  #6  
Old 2nd November 2011, 18:48
dgmufasa dgmufasa is offline
Member
 
Join Date: Oct 2011
Posts: 86
Thanks: 5
Thanked 1 Time in 1 Post
 
Default

Through some miracle, the system has come back up again.

If I do "ps -ef | grep httpd", I see processes.

But I am a bit apprehensive about trying this again...

Will see what happens.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Sending email issue lezelf Installation/Configuration 15 9th August 2011 11:20
PHP warnings after upgrade to ISP config 3.03 stevegjacobs Installation/Configuration 5 30th October 2010 14:31
amavis & ispconfig 3 yalex2000 Installation/Configuration 20 18th February 2010 17:02
ISPConfig3 Mail Warn Errors reason8 General 3 25th November 2009 13:58
The Perfect Setup - Debian Etch (Debian 4.0) some trouble daniel80 HOWTO-Related Questions 26 1st February 2008 16:30


All times are GMT +2. The time now is 06:00.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.