Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 4th February 2006, 17:42
mzo mzo is offline
Junior Member
 
Join Date: Jan 2006
Posts: 20
Thanks: 0
Thanked 1 Time in 1 Post
Red face Can't receive email

Hi ,

I'm very new to ispconfig. Currently I having problem when receiving new email. After look thru your previous thread, I notice there might be something wrong with my setting. After I restart the server I notice something strange in my /var/log/maillog that is :

Feb 5 00:27:08 server postfix/postfix-script: starting the Postfix mail system
Feb 5 00:27:08 server postfix/master[2171]: daemon started -- version 2.2.2, configuration /etc/postfix
Feb 5 00:27:08 server postfix/qmgr[2180]: 1329A2EE785: from=<aloksss@puspakom.net.ms>, size=1009, nrcpt=5 (queue active)
Feb 5 00:27:08 server postfix/trivial-rewrite[2181]: warning: database /etc/postfix/virtusertable.db is older than source file /etc/postfix/virtusertable
Feb 5 00:27:08 server postfix/qmgr[2180]: 619802EE789: from=<o_zm@puspakom.net.ms>, size=1009, nrcpt=4 (queue active)
Feb 5 00:27:21 server postfix/postfix-script: stopping the Postfix mail system
Feb 5 00:27:21 server postfix/master[2171]: terminating on signal 15
Feb 5 00:27:22 server postfix/postfix-script: starting the Postfix mail system
Feb 5 00:27:22 server postfix/master[2537]: daemon started -- version 2.2.2, configuration /etc/postfix
Feb 5 00:27:22 server postfix/qmgr[2549]: 1329A2EE785: from=<aloksss@puspakom.net.ms>, size=1009, nrcpt=5 (queue active)
Feb 5 00:27:22 server postfix/trivial-rewrite[2552]: warning: database /etc/postfix/virtusertable.db is older than source file /etc/postfix/virtusertable
Feb 5 00:27:22 server postfix/qmgr[2549]: 619802EE789: from=<o_zm@puspakom.net.ms>, size=1009, nrcpt=4 (queue active)
Feb 5 00:27:52 server postfix/smtp[2558]: connect to puspakom.net.ms[213.239.203.47]: Connection timed out (port 25)
Feb 5 00:27:52 server postfix/smtp[2568]: connect to puspakom.net.ms[213.239.203.47]: Connection timed out (port 25)
Feb 5 00:27:52 server postfix/smtp[2558]: 1329A2EE785: to=<aloksss@puspakom.net.ms>, relay=none, delay=5628, status=deferred (connect to puspakom.net.ms[213.239.203.47]: Connection timed out)
Feb 5 00:27:52 server postfix/smtp[2568]: 619802EE789: to=<aloksss@puspakom.net.ms>, relay=none, delay=1432, status=deferred (connect to puspakom.net.ms[213.239.203.47]: Connection timed out)
Feb 5 00:27:52 server postfix/smtp[2558]: 1329A2EE785: to=<axlanz@puspakom.net.ms>, relay=none, delay=5628, status=deferred (connect to puspakom.net.ms[213.239.203.47]: Connection timed out)
Feb 5 00:27:52 server postfix/smtp[2568]: 619802EE789: to=<axlanz@puspakom.net.ms>, relay=none, delay=1432, status=deferred (connect to puspakom.net.ms[213.239.203.47]: Connection timed out)
Feb 5 00:27:52 server postfix/smtp[2558]: 1329A2EE785: to=<mz_o@puspakom.net.ms>, relay=none, delay=5628, status=deferred (connect to puspakom.net.ms[213.239.203.47]: Connection timed out)
Feb 5 00:27:52 server postfix/smtp[2568]: 619802EE789: to=<mz_o@puspakom.net.ms>, relay=none, delay=1432, status=deferred (connect to puspakom.net.ms[213.239.203.47]: Connection timed out)
Feb 5 00:27:52 server postfix/smtp[2568]: 619802EE789: to=<o_zm@puspakom.net.ms>, relay=none, delay=1432, status=deferred (connect to puspakom.net.ms[213.239.203.47]: Connection timed out)
[root@server log]#

can anybody help me ?Tq.
Reply With Quote
Sponsored Links
  #2  
Old 4th February 2006, 19:04
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Quote:
Originally Posted by mzo
Feb 5 00:27:08 server postfix/trivial-rewrite[2181]: warning: database /etc/postfix/virtusertable.db is older than source file /etc/postfix/virtusertable
Did you manually edit /etc/postfix/virtusertable?
Please run
Code:
postmap /etc/postfix/virtusertable
to create /etc/postfix/virtusertable.db from /etc/postfix/virtusertable and restart Postfix afterwards.
Quote:
Originally Posted by mzo
Feb 5 00:27:52 server postfix/smtp[2568]: 619802EE789: to=<o_zm@puspakom.net.ms>, relay=none, delay=1432, status=deferred (connect to puspakom.net.ms[213.239.203.47]: Connection timed out)
[root@server log]#
Is puspakom.net.ms your server? Please post the output of
Code:
netstat -tap
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 5th February 2006, 03:37
mzo mzo is offline
Junior Member
 
Join Date: Jan 2006
Posts: 20
Thanks: 0
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by falko
Did you manually edit /etc/postfix/virtusertable?
MZO : Yes, I changes the domain from puspakom.it.tt to puspakom.net.ms

Please run
Code:
postmap /etc/postfix/virtusertable
to create /etc/postfix/virtusertable.db from /etc/postfix/virtusertable and restart Postfix afterwards.
MZO: Done.No error.

Is puspakom.net.ms your server? Please post the output of
Code:
netstat -tap
MZO : My server name is server.puspakom.net.ms.Nestat -tap result is as below.Thank you.

[root@server ~]# netstat -tap
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 *:imaps *:* LISTEN 1969/xinetd
tcp 0 0 *:32769 *:* LISTEN 1622/rpc.statd
tcp 0 0 *op3s *:* LISTEN 1969/xinetd
tcp 0 0 *:mysql *:* LISTEN 2063/mysqld
tcp 0 0 *op3 *:* LISTEN 1969/xinetd
tcp 0 0 *:imap *:* LISTEN 1969/xinetd
tcp 0 0 *:sunrpc *:* LISTEN 1604/portmap
tcp 0 0 *:81 *:* LISTEN 2436/ispconfig_http
tcp 0 0 *:ftp *:* LISTEN 2589/proftpd: (acce
tcp 0 0 server.puspakom.net.ms:ipp *:* LISTEN 4328/cupsd
tcp 0 0 server.puspakom.net.ms:5335 *:* LISTEN 1907/mDNSResponder
tcp 0 0 *:smtp *:* LISTEN 2537/master
tcp 0 0 *:http *:* LISTEN 2466/httpd
tcp 0 0 *:ssh *:* LISTEN 1960/sshd
tcp 0 0 *:https *:* LISTEN 2466/httpd
tcp 0 2040 puspakom.net.ms:ssh ::ffff:210.186.3.85:1102 ESTABLISHED 6598/1
[root@server ~]#

MZO: I don't understand, where ip 210.186.3.85:1102 come from because that is not my server ip. Do you have any idea?
Reply With Quote
  #4  
Old 5th February 2006, 11:01
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Both server.puspakom.net.ms and puspakom.net.ms point to the IP address 213.239.203.47. Is this your public IP address?
Is the server behind a router, or is it connected directly to the internet? If it is behind a router, did you forward port 25 from your router to your server?

Quote:
Originally Posted by mzo
tcp 0 2040 puspakom.net.ms:ssh ::ffff:210.186.3.85:1102 ESTABLISHED 6598/1
[root@server ~]#

MZO: I don't understand, where ip 210.186.3.85:1102 come from because that is not my server ip. Do you have any idea?
210.186.3.85 is the IP address with which you connected to your server.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 5th February 2006, 13:17
mzo mzo is offline
Junior Member
 
Join Date: Jan 2006
Posts: 20
Thanks: 0
Thanked 1 Time in 1 Post
Question

Quote:
Originally Posted by falko
Both server.puspakom.net.ms and puspakom.net.ms point to the IP address 213.239.203.47. Is this your public IP address?
Is the server behind a router, or is it connected directly to the internet? If it is behind a router, did you forward port 25 from your router to your server?

210.186.3.85 is the IP address with which you connected to your server.
MZO :213.239.203.47 IS not my public ip. At first place I can receive mail but later probably I wrongly do something that lead to this problem. Where can I change it(files) to my public IP? Currently my server is behind network-box server but all port is allow from net to dmz. I still get warning in /var/log/maillog even though after I do postmap /etc/postfix/virtusertable and reboot the server, the error log is :

Feb 5 19:00:09 server postfix/trivial-rewrite[14517]: warning: database /etc/postfix/virtusertable.db is older than source file /etc/postfix/virtusertable

Very need your expertise. Tq.
Reply With Quote
  #6  
Old 5th February 2006, 20:24
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Quote:
Originally Posted by mzo
MZO :213.239.203.47 IS not my public ip. At first place I can receive mail but later probably I wrongly do something that lead to this problem. Where can I change it(files) to my public IP?
First you must make sure that your domains and subdomains point to the correct IP address. Therefore you must change the DNS records. The responsible nameservers for puspakom.net.ms are ns5.idnscan.net, ns6.idnscan.net, ns1.idnscan.net, and ns2.idnscan.net.

Quote:
Originally Posted by mzo
Feb 5 19:00:09 server postfix/trivial-rewrite[14517]: warning: database /etc/postfix/virtusertable.db is older than source file /etc/postfix/virtusertable

Very need your expertise. Tq.
Please post the output of
Code:
ls -la /etc/postfix/
Do you get any error messages when you run
Code:
postmap /etc/postfix/virtusertable
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 6th February 2006, 03:02
mzo mzo is offline
Junior Member
 
Join Date: Jan 2006
Posts: 20
Thanks: 0
Thanked 1 Time in 1 Post
Smile

Quote:
Originally Posted by falko
First you must make sure that your domains and subdomains point to the correct IP address. Therefore you must change the DNS records. The responsible nameservers for puspakom.net.ms are ns5.idnscan.net, ns6.idnscan.net, ns1.idnscan.net, and ns2.idnscan.net.

MZO : I put ns1.idnscan.net and ns2.idnscan.net for my default ns1 and ns2. ns5.idnscan.net and ns6.idnscan as my nameserver1 and nameserver2 in dns manager --> dns entry --> options. Is this correct ?

Please post the output of
Code:
ls -la /etc/postfix/
MZO : Please refer below :

[root@server ~]# ls -la /etc/postfix/
total 300
drwxr-xr-x 3 root root 4096 Feb 4 17:25 .
drwxr-xr-x 94 root root 12288 Feb 6 09:55 ..
-rw-r--r-- 1 root root 15444 Apr 20 2005 access
-rw-r--r-- 1 root root 10947 Apr 20 2005 canonical
-rw-r--r-- 1 root root 9622 Apr 20 2005 generic
-rw-r--r-- 1 root root 16393 Apr 20 2005 header_checks
-rw-r--r-- 1 root root 11942 Apr 20 2005 LICENSE
-rw-r--r-- 1 root root 322 Feb 6 09:55 local-host-names
-rw-r--r-- 1 root root 322 Feb 6 09:55 local-host-names~
-rw-r--r-- 1 root root 26447 Jan 16 17:43 main.cf
-rw-r--r-- 1 root root 14293 Apr 20 2005 main.cf.default
-rw-r--r-- 1 root root 26447 Feb 3 10:10 main.cf.orig
-rw-r--r-- 1 root root 934 Apr 20 2005 makedefs.out
-rw-r--r-- 1 root root 4186 Apr 20 2005 master.cf
-rw-r--r-- 1 root root 17266 Apr 20 2005 postfix-files
-rwxr-xr-x 1 root root 6366 Apr 20 2005 postfix-script
-rwxr-xr-x 1 root root 22471 Apr 20 2005 post-install
-rw------- 1 root root 1024 Feb 6 09:56 prng_exch
-rw-r--r-- 1 root root 6523 Apr 20 2005 relocated
drwxr-xr-x 2 root root 4096 Jan 16 16:02 ssl
-rw-r--r-- 1 root root 1629 Apr 20 2005 TLS_LICENSE
-rw-r--r-- 1 root root 11033 Apr 20 2005 transport
-rw-r--r-- 1 root root 11732 Apr 20 2005 virtual
-rw-r--r-- 1 root root 372 Feb 6 09:55 virtusertable
-rw-r--r-- 1 root root 372 Feb 6 09:55 virtusertable~
-rw-r--r-- 1 root root 12288 Feb 6 09:55 virtusertable.db
[root@server ~]#

Do you get any error messages when you run
Code:
postmap /etc/postfix/virtusertable
?
MZO : I didn't have any error when run this command. Please see below :

[root@server ~]#
[root@server ~]# postmap /etc/postfix/virtusertable
[root@server ~]#
[root@server ~]#
Reply With Quote
  #8  
Old 6th February 2006, 09:31
mzo mzo is offline
Junior Member
 
Join Date: Jan 2006
Posts: 20
Thanks: 0
Thanked 1 Time in 1 Post
Default

[QUOTE=falko]First you must make sure that your domains and subdomains point to the correct IP address. Therefore you must change the DNS records. The responsible nameservers for puspakom.net.ms are ns5.idnscan.net, ns6.idnscan.net, ns1.idnscan.net, and ns2.idnscan.net.

MZO : Falko, I think I know how the error occour:

Feb 5 00:27:52 server postfix/smtp[2568]: 619802EE789: to=<o_zm@puspakom.net.ms>, relay=none, delay=1432, status=deferred (connect to puspakom.net.ms[213.239.203.47]: Connection timed out)
[root@server log]#

MZO : I register puspakom.net.ms to joynic.com, that why my postfix/smtp point to 213.239.203.47. Which file do I need to edit if I want to change my postfix/smtp setting from puspakom.net.ms to my public IP? I think the problem will solve after I change puspakom.net.ms to my public ip in smtp/postfix.Tq.
Reply With Quote
  #9  
Old 6th February 2006, 09:48
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

You must change the DNS records for puspakom.net.ms so that they point to the correct IP address.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #10  
Old 6th February 2006, 10:40
mzo mzo is offline
Junior Member
 
Join Date: Jan 2006
Posts: 20
Thanks: 0
Thanked 1 Time in 1 Post
 
Thumbs up

Quote:
Originally Posted by falko
You must change the DNS records for puspakom.net.ms so that they point to the correct IP address.
MZO : Which part do I need to change it, in the cydots.com (puspakom.net.ms setting) or in ispconfig? So far I already point www.puspakom.net.ms to my public ip. You can test it when type www.puspakom.net.ms in the browser. I think Joynic.com is free domain provider so most probably that why it will go to their 213.239.203.47. So this happend because my postfix/smtp search for puspakom.net.ms. Can I change postfix/smtp setting so it will go my public ip<x.x.x.x> instead of puspakom.net.ms?tq.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Email aliases problem rosa hsiao General 12 21st September 2006 16:01
can't receive email mwebb Installation/Configuration 2 15th January 2006 19:29
Recreate email Felipe General 3 13th December 2005 21:45
90% perfect (can't receive mail) CorrosionX General 2 7th November 2005 17:40
UebiMiau webmail adding @localhostname to email address except first address. Kamran Shah Installation/Configuration 5 11th October 2005 17:01


All times are GMT +2. The time now is 23:48.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.