Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 9th June 2008, 17:19
RdeWilde RdeWilde is offline
Junior Member
 
Join Date: May 2008
Posts: 17
Thanks: 11
Thanked 0 Times in 0 Posts
Default

No, I'm running it on the external server. Is there any documentation about where this message come from? It checks my outgoing recipents on the local MySQL table, but it should just send it away (as that is why it's there :S). Hope it's possible to solve.
Reply With Quote
Sponsored Links
  #12  
Old 10th June 2008, 14:28
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

I'm not sure what the problem is, but you should compare all your configuration files with the ones from the tutorial again to rule out typos, etc.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
RdeWilde (11th June 2008)
  #13  
Old 11th June 2008, 14:47
RdeWilde RdeWilde is offline
Junior Member
 
Join Date: May 2008
Posts: 17
Thanks: 11
Thanked 0 Times in 0 Posts
Default

I didn't do a tutorial, just installed it by 'yum' and configured it by hand.

Looks like it's looking in the table for incoming e-mail, when sending e-mail. What settings could influence this? Is there any way that auth could fail and cause this problem?
Reply With Quote
  #14  
Old 12th June 2008, 14:37
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

What's in /etc/postfix/mysql_mailbox_domains.cf and
/etc/postfix/mysql_mailbox_maps.cf?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
RdeWilde (12th June 2008)
  #15  
Old 12th June 2008, 14:50
RdeWilde RdeWilde is offline
Junior Member
 
Join Date: May 2008
Posts: 17
Thanks: 11
Thanked 0 Times in 0 Posts
Default

mysql_mailbox_domains.cf:
Quote:
user = [MYUSER]
password = [MYPASS]
hosts = localhost
dbname = mail
query = SELECT domain FROM users
users contains a column called domain which holds the domain.tld for the email.

mysql_mailbox_maps.cf
Quote:
user = [MYUSER]
password = [MYPASS]
hosts = localhost
dbname = mail
query = SELECT CONCAT(domain,'/mail/',username,'/') FROM users WHERE username='%u' AND domain='%d'
Correct path (when prepending the base path)
Reply With Quote
  #16  
Old 17th June 2008, 15:55
RdeWilde RdeWilde is offline
Junior Member
 
Join Date: May 2008
Posts: 17
Thanks: 11
Thanked 0 Times in 0 Posts
Default

Anyone who has an asnwer?
Reply With Quote
  #17  
Old 18th June 2008, 16:36
RdeWilde RdeWilde is offline
Junior Member
 
Join Date: May 2008
Posts: 17
Thanks: 11
Thanked 0 Times in 0 Posts
Default

I think i've found a part of the problem. The outgoing port is 587 (submission) and I think that has to be routed somewhere to port 25? But it isn't anywhere? Shouldn't it be in master.cf?
Reply With Quote
  #18  
Old 18th June 2008, 18:25
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

What's the output of
Code:
netstat -tap
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #19  
Old 18th June 2008, 19:12
RdeWilde RdeWilde is offline
Junior Member
 
Join Date: May 2008
Posts: 17
Thanks: 11
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko View Post
What's the output of
Code:
netstat -tap
?
Here's the output:
Quote:
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 *:mysql *:* LISTEN 3134/mysqld
tcp 0 0 *:submission *:* LISTEN 1571/master
tcp 0 0 *:sunrpc *:* LISTEN 1203/portmap
tcp 0 0 *:8176 *:* LISTEN 1727/perl
tcp 0 0 *:ftp *:* LISTEN 1582/proftpd: (acce
tcp 0 0 dewildevds2.jronline:domain *:* LISTEN 1183/named
tcp 0 0 localhost.localdomai:domain *:* LISTEN 1183/named
tcp 0 0 localhost.localdomain:ipp *:* LISTEN 1385/cupsd
tcp 0 0 *:984 *:* LISTEN 1226/rpc.statd
tcp 0 0 *:smtp *:* LISTEN 1571/master
tcp 0 0 localhost.localdomain:rndc *:* LISTEN 1183/named
tcp 0 0 *op3 *:* LISTEN 1519/dovecot
tcp 0 0 *:imap *:* LISTEN 1519/dovecot
tcp 0 0 *:http *:* LISTEN 9533/httpd
tcp 0 0 *:ssh *:* LISTEN 1377/sshd
tcp 0 0 localhost6.localdomain:rndc *:* LISTEN 1183/named
tcp 0 0 *:https *:* LISTEN 9533/httpd
tcp 0 0 dewildevds2.jronline.n:http ip51ccc296.s:spw-dnspreload TIME_WAIT -
tcp 0 2668 dewildevds2.jronline.nl:ssh ::ffff:195.222.119.34ipes ESTABLISHED 8506/0
tcp 0 0 dewildevds2.jronline.n:http 84-104-81-142.cable.q:64005 TIME_WAIT -
Reply With Quote
  #20  
Old 19th June 2008, 16:27
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
 
Default

Looks ok. I don't think that port 587 is a problem for outgoing emails...
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
RdeWilde (19th June 2008)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Statistic not working mzo Installation/Configuration 49 20th April 2011 12:19
Recipient address rejected: User unknown in local recipent table. adrenalinic Installation/Configuration 15 25th April 2006 16:26
Another Problem: Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP bluegrass Installation/Configuration 24 8th March 2006 01:41
Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, SpamAs pontifex HOWTO-Related Questions 2 26th October 2005 17:54
postfix config jmroth Installation/Configuration 6 18th September 2005 15:58


All times are GMT +2. The time now is 14:18.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.