Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 30th May 2008, 12:17
nakalskit nakalskit is offline
Junior Member
 
Join Date: May 2008
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
 
Question sending mail problem - ubuntu 8.04 - ispconfig 2.x.x - postfix

Hi all,

i follow step by step guid in this howtoForge on installing ubuntu 8.04 server succesfully with no errors occurs during installation. i also managed to get ISPconfig install n running.

so, i've create a site called smsdssb and a users nazri@smsdssb.com.my, info@smsdssb.com.my. i configure my outlook express to send and received mail thru the new server at 192.168.1.100. i can send/received email from and to both account.

my problem is when i tried to send email to the internet. i can not send email to gmail / hotmail / yahoo mail or any other mailserver. outlook express gave me this following error msg

"The message could not be sent because one of the recipients was rejected by the server. The rejected e-mail address was 'nazrisms@gmail.com'. Subject 'test internal to external mail', Account: '192.168.1.100', Server: '192.168.1.100', Protocol: SMTP, Server Response: '554 5.7.1 <nazrisms@gmail.com>: Relay access denied', Port: 25, Secure(SSL): No, Server Error: 554, Error Number: 0x800CCC79"

here is my postfix/main.cf file looks like

# See /usr/share/postfix/main.cf.dist for a commented, more complete version


# Debian specific: Specifying a file name will cause the first
# line of that file to be used as the name. The Debian default
# is /etc/mailname.
#myorigin = /etc/mailname

smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

readme_directory = no

# TLS parameters
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_use_tls = yes
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache

# See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
# information on enabling SSL in the smtp client.

myhostname = smssvr.smsdssb.com.my
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
#mydestination = smssvr.smsdssb.com.my, localhost.smsdssb.com.my, localhost.localdomain, localhost
relayhost = smtp-proxy.tm.net.my:587
mynetworks = 127.0.0.0/8
mailbox_command = procmail -a "$EXTENSION"
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
inet_protocols = all
smtpd_sasl_local_domain =
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_client = yes
smtpd_sasl_authenticated_header = yes
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject _unauth_destination
smtpd_tls_auth_only = no
smtp_use_tls = yes
smtp_tls_note_starttls_offer = yes
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom

virtual_maps = hash:/etc/postfix/virtusertable

mydestination = /etc/postfix/local-host-names

---- end of main.cf -----

so please someone help me with this.

as additional info, my windows mail server running the same smtp-relay with the same tcp port number works. i want to switch to linux.

thank you in advance.

I AM SORRY EVERYBODY, i forgot to mark on 'my server requires authentication' and also 'log on using Secure Pasword Authentication'. now everything works fine!

Last edited by nakalskit; 30th May 2008 at 12:24. Reason: my stupid mistake
Reply With Quote
Sponsored Links
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem installing ISPconfig on Ubuntu 6.06 LTS ennodj Installation/Configuration 6 4th May 2008 18:12
Postfix sending mail from webpage problem ACDII Installation/Configuration 4 23rd December 2007 05:47
Postfix problem: lost connection after CONNECT from unknown fernando_torrez Server Operation 5 30th November 2007 14:17
postfix ISPconfig problem matehortua Installation/Configuration 8 3rd September 2006 17:03
Problem with retrieving mail after using ISPConfig sw33t Installation/Configuration 8 14th May 2006 16:38


All times are GMT +2. The time now is 19:54.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.