Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 28th May 2008, 23:26
Rocky Rocky is offline
Senior Member
 
Join Date: Oct 2005
Posts: 553
Thanks: 14
Thanked 49 Times in 48 Posts
Default

Hmm, very interesting problem. I did notice that you have postfix as the group for a few subfolders in /var/spool/MailScanner.

drwxr-x--- 2 postfix postfix 4096 2008-04-04 21:00 archive
drwxr-x--- 39 postfix postfix 4096 2008-05-28 15:02 incoming
drwxr-x--- 4 postfix www-data 4096 2008-05-28 00:00 quarantine
drwxr-xr-x 2 postfix postfix 4096 2008-05-27 09:05 spamassassin

Try running the following, restart MailScanner and test MailWatch:

Code:
chown -R postfix:www-data /var/spool/MailScanner
chmod -R ug+rwx /var/spool/MailScanner
Does that fix it?

Rocky
__________________
Home of the SpamSnake
Reply With Quote
Sponsored Links
  #12  
Old 28th May 2008, 23:30
lctn lctn is offline
Junior Member
 
Join Date: May 2008
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Default solved

Thank you very much!!

I am not sure when/how I did that, but changing it fixed things.
Reply With Quote
  #13  
Old 29th May 2008, 02:02
Rocky Rocky is offline
Senior Member
 
Join Date: Oct 2005
Posts: 553
Thanks: 14
Thanked 49 Times in 48 Posts
Default

Raymond,

You're welcome. I knew it had to be a permission issue.

Rocky
__________________
Home of the SpamSnake
Reply With Quote
  #14  
Old 29th May 2008, 03:58
lctn lctn is offline
Junior Member
 
Join Date: May 2008
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Default Run As Group

In the instructions it instructs the "Run As Group" be "Postfix". If I change it to www-data, everything works as expected. Changing back to Postfix breaks things.
Reply With Quote
  #15  
Old 29th May 2008, 04:09
Rocky Rocky is offline
Senior Member
 
Join Date: Oct 2005
Posts: 553
Thanks: 14
Thanked 49 Times in 48 Posts
Default

Raymond,

That should work and I do have that in my notes. I haven't tested it without MailWatch to see if MailScanner would still function without any problems. I'll make sure to give it a test run using www-data as the Run As User without MailWatch.

Rocky
__________________
Home of the SpamSnake
Reply With Quote
  #16  
Old 11th June 2008, 09:35
skruven2006 skruven2006 is offline
Junior Member
 
Join Date: May 2008
Posts: 8
Thanks: 2
Thanked 0 Times in 0 Posts
Default

I've been following this thread to the bitter end, but no luck for me.
I have more or less the same problem, ie. I can't se the release-function in the mails.
Even more, I can't even see the mails that are in the Quarantine tab, I get the errormessage (?) 'No Rows Retrieved'.

Any help is appreciated

//David
Reply With Quote
  #17  
Old 11th June 2008, 14:30
Rocky Rocky is offline
Senior Member
 
Join Date: Oct 2005
Posts: 553
Thanks: 14
Thanked 49 Times in 48 Posts
Default

David,

Make sure you have the following set in /etc/MailScanner/MailScanner.conf:
  • Run As Group = www-data
  • Quarantine User = root
  • Quarantine Group = www-data
  • Quarantine Permissions = 0660
  • Quarantine Whole Message = yes
  • Always Looked Up Last = &MailWatchLogging
  • Quarantine Whole Message As Queue Files = no
  • Detailed Spam Report = yes
  • Include Scores In SpamAssassin Report = yes
Repeat these steps:

chown -R postfix:www-data /var/spool/MailScanner
chown -R postfix:www-data /var/lib/MailScanner
chown -R postfix:www-data /var/run/MailScanner
chown -R postfix:www-data /var/lock/subsys/MailScanner
chown -R postfix:www-data /var/spool/postfix/hold
chmod -R ug+rwx /var/spool/postfix/hold
chmod -R ug+rwx /var/spool/MailScanner

Finally restart MailScanner, log into your MailWatch interface and test it.
/etc/init.d/mailscanner restart

Let me know if that worked.

Rocky
__________________
Home of the SpamSnake
Reply With Quote
  #18  
Old 11th June 2008, 14:39
skruven2006 skruven2006 is offline
Junior Member
 
Join Date: May 2008
Posts: 8
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Thanx Rocky, but... been there done that (did it again now for the.... say 5th time).
Still the same.

Other suggestions?

//David
Reply With Quote
  #19  
Old 11th June 2008, 14:42
Rocky Rocky is offline
Senior Member
 
Join Date: Oct 2005
Posts: 553
Thanks: 14
Thanked 49 Times in 48 Posts
Default

Try this:

Code:
chmod -R u+rwx,g+rx /var/spool/MailScanner/quarantine
Let me know if that worked.
__________________
Home of the SpamSnake
Reply With Quote
  #20  
Old 11th June 2008, 14:59
skruven2006 skruven2006 is offline
Junior Member
 
Join Date: May 2008
Posts: 8
Thanks: 2
Thanked 0 Times in 0 Posts
 
Default

Sorry, didn't work either

//David
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
IPtables rule to let PPTP access LAN brianwebb01 Installation/Configuration 0 1st May 2008 22:23
mydomain.com fetches to my router's web interface kreya Installation/Configuration 5 13th June 2007 17:13
ispconfig and enable quarantine of poisoned messages ancile General 1 22nd March 2007 12:07
Problems with the virtual email system with postfix, courier,mysql Greg Parker HOWTO-Related Questions 3 3rd January 2007 18:59
get thousands of "Mailsize" mails from own server torusturtle Installation/Configuration 20 24th December 2006 15:51


All times are GMT +2. The time now is 23:10.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.