Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 11th October 2007, 23:28
plathw plathw is offline
Junior Member
 
Join Date: Oct 2007
Posts: 17
Thanks: 0
Thanked 1 Time in 1 Post
Default mail from server not sending because main domain is not hosted by ispconfig

We have several different websites. Our main website (www.site.com) is hosted on another box but several other sub domains (site1.site.com, site2.site.com, etc) are hosted on an ispconfig box.

We noticed that we were not getting mail sent by forms on the sub domain sites hosted on our ispconfig box. We checked the error log and saw that it was looking for the main domain, and since it is not hosted on that box, it would just give an error and not send.

To fix this we removed "site.com" from etc/postfix/local-host-names and then mail was being sent fine. But, every time you interact with the admin panel, it adds "site.com" back into the local-host-names file. Any ideas how to stop this?
Reply With Quote
Sponsored Links
  #2  
Old 12th October 2007, 01:33
dysolve dysolve is offline
Junior Member
 
Join Date: Oct 2007
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I had a similar problem, so I changed the smtp server to my ISP's one and it was all good..
Reply With Quote
  #3  
Old 12th October 2007, 11:52
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,652 Times in 4,461 Posts
Default

The solution is to set "site.com" to external mailserver under options in the co-domian settings in ISPConfig.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
tensor (21st January 2008)
  #4  
Old 12th September 2008, 00:14
bigbeat bigbeat is offline
Junior Member
 
Join Date: Sep 2008
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default ispconfig box with remotely hosted MX... not able to receive mail

Hello,

I'm having the same problem mentioned above. I took the action described and set both the domain and sub-domain to "external mailserver." Still not receiving mail.

Any help would be greatly appreciated.
Reply With Quote
  #5  
Old 12th September 2008, 19:15
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
Default

Is the domain/hostname in question still listed in /etc/postfix/local-host-names?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 13th September 2008, 07:17
bigbeat bigbeat is offline
Junior Member
 
Join Date: Sep 2008
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

falko,

Thank you very much for your reply. No, I removed the domain in question from the local-host-names file right from the beginning. I have a couple of other servers and whenever I point MX records for a domain to a remote location, I always remove the domain entry in the local-host-names file, and the server ceases trying to deliver mail locally. But it doesn't appear to work the same way with the ispconfig server.

Any other suggestions?

In ISP Manager > sites > domainname, I have the "Create DNS-MX" unchecked. Is that the way it should be?

There are no MX records setup for the domain in "DNS Manager." Is that the way it should be?

Thank you again for your willingness to help. This forum is a great resource and very appreciated.
Reply With Quote
  #7  
Old 13th September 2008, 11:56
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,652 Times in 4,461 Posts
Default

Quote:
I removed the domain in question from the local-host-names file right from the beginning.
This is useless, as ISPConfig will add it again.

What you missed is to to set the domain and co-domain to external mailserver in ispconfig. If you enable o diable MX has no influence on this. MX is for DNS only.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #8  
Old 13th September 2008, 23:00
bigbeat bigbeat is offline
Junior Member
 
Join Date: Sep 2008
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till View Post
This is useless, as ISPConfig will add it again.

What you missed is to to set the domain and co-domain to external mailserver in ispconfig. If you enable o diable MX has no influence on this. MX is for DNS only.
till, in my first post above, I mentioned that I have already done this...

I took the action described and set both the domain and sub-domain to "external mailserver." Still not receiving mail.

Any other ideas?

Thanks
Reply With Quote
  #9  
Old 14th September 2008, 14:08
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,652 Times in 4,461 Posts
Default

Ok, you set the domain and co-domain to external mailserver and the domain is still listed in the file /etc/postfix/local-host-names ?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #10  
Old 15th September 2008, 08:03
bigbeat bigbeat is offline
Junior Member
 
Join Date: Sep 2008
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

The domain has been set to external mail server, but the domain name is no longer listed in the local-host-names file. I removed it from there. Should I not have removed it?

Thank you
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
php Apps email not going through palkat General 8 21st September 2011 06:35
Running ISPConfig without the mail server piers Installation/Configuration 5 6th June 2007 17:31
best way to migrate from old mail server to new mail server w/ ispconfig. istep Installation/Configuration 1 20th March 2007 09:55
Postfix reject connections gabrix Server Operation 27 25th January 2007 09:37
Setting up a backup mail server setup with two installations of ISPConfig zitch Tips/Tricks/Mods 7 30th December 2006 11:07


All times are GMT +2. The time now is 06:56.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.