Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #61  
Old 15th November 2008, 23:27
burnclouds burnclouds is offline
Junior Member
 
Join Date: Aug 2008
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default Spamdam

Does anyone know how to get spamdam to work with this setup?
Or is there another (squirrelmail?) user interface to allow users to add there own aliases (disposable e-mail address)?

Spamdam:
http://sourceforge.net/projects/spamdam/
Reply With Quote
Sponsored Links
  #62  
Old 16th November 2008, 13:28
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

I've never tried SpamDam...
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #63  
Old 24th November 2008, 13:18
Nehalem Nehalem is offline
Junior Member
 
Join Date: Nov 2008
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default setup problem

Hi

First of all, thank you for your great tutorial. It really saved me a lot of time.
I have one problem though. I cannot send emails via Outlook.

This IS working

- i can send emails via squirrel
- i can receive emails via squirrel
- i can receive emails via outlook

but i cannot send emails via outlook

-outlook is configured to use the same username and password as for receiving emails
-Port in use for smtp is 25

cat /var/log/mail.log:

Code:
Nov 24 13:09:36 NbI20841-01 postfix/smtpd[19830]: warning: XXXX: SASL LOGIN authentication failed: authentication failure
Nov 24 13:09:36 YYYYY postfix/smtpd[19830]: lost connection after AUTH from XXXXXX
Nov 24 13:09:36 YYYYYY postfix/smtpd[19830]: disconnect from XXXXX.
I've restarted all auth daemons mentioned in the tutorial, but the problems seems to persist.

cat /etc/pam.d/smtp:

Code:
auth    required   pam_mysql.so user=mail_admin passwd=mail_admin_password host=127.0.0.1 db=mail table=users usercolumn=email passwdcolumn=password crypt=1
account sufficient pam_mysql.so user=mail_admin passwd=mail_admin_password host=127.0.0.1 db=mail table=users usercolumn=email passwdcolumn=password crypt=1
cat /etc/default/saslauthd
Code:
#
# Settings for saslauthd daemon
# Please read /usr/share/doc/sasl2-bin/README.Debian for details.
#

# Should saslauthd run automatically on startup? (default: no)
START=yes

# Description of this saslauthd instance. Recommended.
# (suggestion: SASL Authentication Daemon)
DESC="SASL Authentication Daemon"

# Short name of this saslauthd instance. Strongly recommended.
# (suggestion: saslauthd)
NAME="saslauthd"

# Which authentication mechanisms should saslauthd use? (default: pam)
#
# Available options in this Debian package:
# getpwent  -- use the getpwent() library function
# kerberos5 -- use Kerberos 5
# pam       -- use PAM
# rimap     -- use a remote IMAP server
# shadow    -- use the local shadow password file
# sasldb    -- use the local sasldb database file
# ldap      -- use LDAP (configuration is in /etc/saslauthd.conf)
#
# Only one option may be used at a time. See the saslauthd man page
# for more information.
#
# Example: MECHANISMS="pam"
MECHANISMS="pam"

# Additional options for this mechanism. (default: none)
# See the saslauthd man page for information about mech-specific options.
MECH_OPTIONS=""

# How many saslauthd processes should we run? (default: 5)
# A value of 0 will fork a new process for each connection.
THREADS=5

# Other options (default: -c -m /var/run/saslauthd)
# Note: You MUST specify the -m option or saslauthd won't run!
#
# See /usr/share/doc/sasl2-bin/README.Debian for Debian-specific information.
# See the saslauthd man page for general information about these options.
#
# Example for postfix users: "-c -m /var/spool/postfix/var/run/saslauthd"
#OPTIONS="-c -m /var/run/saslauthd"
OPTIONS="-c -m /var/spool/postfix/var/run/saslauthd -r"
cat /etc/postfix/sasl/smtpd.conf

Code:
pwcheck_method: saslauthd
mech_list: plain login
allow_plaintext: true
auxprop_plugin: mysql
sql_hostnames: 127.0.0.1
sql_user: mail_admin
sql_passwd: mail_admin_password
sql_database: mail
sql_select: select password from users where email = '%u'
netstat -tpa
Code:
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 *:https                 *:*                     LISTEN      31857/apache2
tcp        0      0 *:51234                 *:*                     LISTEN      24366/server_linux
tcp        0      0 *:14534                 *:*                     LISTEN      24366/server_linux
tcp        0      0 localhost.localdo:10024 *:*                     LISTEN      7573/amavisd (maste
tcp        0      0 localhost.localdo:10025 *:*                     LISTEN      18141/master
tcp        0      0 localhost.localdo:mysql *:*                     LISTEN      21638/mysqld
tcp        0      0 *:www                   *:*                     LISTEN      31857/apache2
tcp        0      0 *:smtp                  *:*                     LISTEN      18141/master
tcp6       0      0 [::]:imaps              [::]:*                  LISTEN      18409/couriertcpd
tcp6       0      0 [::]:pop3s              [::]:*                  LISTEN      19502/couriertcpd
tcp6       0      0 [::]:pop3               [::]:*                  LISTEN      19465/couriertcpd
tcp6       0      0 [::]:imap2              [::]:*                  LISTEN      18372/couriertcpd
tcp6       0      0 [::]:ftp                [::]:*                  LISTEN      25846/proftpd: (acc
tcp6       0      0 [::]:ssh                [::]:*                  LISTEN      14038/sshd
tcp6       0      0 [::]:smtp               [::]:*                  LISTEN      18141/master
Thanks for your help in advance

N.

Last edited by Nehalem; 24th November 2008 at 14:13.
Reply With Quote
  #64  
Old 25th November 2008, 16:40
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Did you disable AppArmor?

Did you run this command?
Code:
adduser postfix sasl
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #65  
Old 25th November 2008, 20:49
Nehalem Nehalem is offline
Junior Member
 
Join Date: Nov 2008
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Code:
adduser postfix sasl
results in The user `postfix' is already a member of `sasl'.

I have disabled, apparmor. Yes.
Reply With Quote
  #66  
Old 26th November 2008, 16:15
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

What's the output of
Code:
ps aux|grep saslauthd
?
What's in /etc/postfix/main.cf?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #67  
Old 26th November 2008, 17:26
Nehalem Nehalem is offline
Junior Member
 
Join Date: Nov 2008
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

ps aux | grep saslauthd

Code:
root@NbI20841-01:~# ps aux | grep saslauthd
root      5211  0.0  0.0   1700   504 pts/1    S+   17:24   0:00 grep saslauthd
root      9266  0.0  0.1   7776  1068 ?        Ss   Nov25   0:00 /usr/sbin/saslauthd -a pam -c -m /var/spool/postfix/var/run/saslauthd -r -n 5
root      9267  0.0  0.1   7776  1040 ?        S    Nov25   0:00 /usr/sbin/saslauthd -a pam -c -m /var/spool/postfix/var/run/saslauthd -r -n 5
root      9268  0.0  0.0   7776   356 ?        S    Nov25   0:00 /usr/sbin/saslauthd -a pam -c -m /var/spool/postfix/var/run/saslauthd -r -n 5
root      9269  0.0  0.0   7776   356 ?        S    Nov25   0:00 /usr/sbin/saslauthd -a pam -c -m /var/spool/postfix/var/run/saslauthd -r -n 5
root      9270  0.0  0.0   7776   356 ?        S    Nov25   0:00 /usr/sbin/saslauthd -a pam -c -m /var/spool/postfix/var/run/saslauthd -r -n 5
cat /etc/postfix/main.cf

Code:
root@NbI20841-01:~# cat /etc/postfix/main.cf
# See /usr/share/postfix/main.cf.dist for a commented, more complete version


# Debian specific:  Specifying a file name will cause the first
# line of that file to be used as the name.  The Debian default
# is /etc/mailname.
#myorigin = /etc/mailname

smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

readme_directory = no

# TLS parameters
smtpd_tls_cert_file = /etc/postfix/smtpd.cert
smtpd_tls_key_file = /etc/postfix/smtpd.key
smtpd_use_tls = yes
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache

# See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
# information on enabling SSL in the smtp client.

myhostname = NbI20841-01.NbIServ.de
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
mydestination = NbI20841-01.NbIServ.de, localhost, localhost.localdomain
relayhost =
mynetworks = 127.0.0.0/8
mailbox_command =
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
inet_protocols = all
smtpd_sasl_local_domain =
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_sasl_authenticated_header = yes
smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination
smtpd_tls_auth_only = no
smtp_use_tls = yes
smtp_tls_note_starttls_offer = yes
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom
home_mailbox = Maildir/
virtual_alias_domains =
virtual_alias_maps = proxy:mysql:/etc/postfix/mysql-virtual_forwardings.cf, mysql:/etc/postfix/mysql-virtual_email2email.cf
virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql-virtual_domains.cf
virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailboxes.cf
virtual_mailbox_base = /home/vmail
virtual_uid_maps = static:5000
virtual_gid_maps = static:5000
transport_maps = proxy:mysql:/etc/postfix/mysql-virtual_transports.cf
virtual_create_maildirsize = yes
virtual_mailbox_extended = yes
virtual_mailbox_limit_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailbox_limit_maps.cf
virtual_mailbox_limit_override = yes
virtual_maildir_limit_message = "The user you are trying to reach is over quota."
virtual_overquota_bounce = yes
proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps $mynetworks $virtual_mailbox_limit_maps
content_filter = amavis:[127.0.0.1]:10024
receive_override_options = no_address_mappings
Reply With Quote
  #68  
Old 27th November 2008, 17:19
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Looks ok. Did you double-check your Outlook settings?

Are there any other errors in your mail log?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #69  
Old 27th November 2008, 18:07
Nehalem Nehalem is offline
Junior Member
 
Join Date: Nov 2008
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Looks ok. Did you double-check your Outlook settings?
I checked the "use same username / password " box. so I assume there is no typo, because I can receive emails without problems.
I use only the ip of my server for the server field in the options.
pop3 port is 110; smtp: 25

If I do not enter login details, then I receive a relay access denied mail.

Quote:
Are there any other errors in your mail log?
Would you suggest some string to grep for ? Beside the login failure i cannot find any obvious entries


-------------
full entry of mail.log after unsuccessfully trying to send:

Code:
Nov 27 18:11:26 NbI20841-01 postfix/smtpd[22493]: warning: unknown[<IP>]: SASL LOGIN authentication failed: authentication failure
Nov 27 18:11:26 NbI20841-01 postfix/smtpd[22493]: lost connection after AUTH from unknown[<IP>]
Nov 27 18:11:26 NbI20841-01 postfix/smtpd[22493]: disconnect from unknown[<IP>]

Last edited by Nehalem; 27th November 2008 at 18:13.
Reply With Quote
  #70  
Old 28th November 2008, 12:48
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
 
Default

I'm not sure what's wrong. I'd compare your configuration files with the ones from the tutorial again - maybe you made a typo somewhere?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail (Ubuntu 8.04) canardwc HOWTO-Related Questions 12 29th May 2008 18:29
Virtual Users And Domains With Postfix, Courier And MySQL (Ubuntu 7.10) ShadyB HOWTO-Related Questions 1 1st April 2008 18:00
Virtual Users And Domains W/ Postfix, Courier and MySql + Squirrelmail prob nsurge HOWTO-Related Questions 10 23rd October 2006 17:43
Virtual Users And Domains W/ Postfix, Courier and MySql + Squirrelmail prob kwinnuxbie HOWTO-Related Questions 7 22nd October 2006 19:26
Autoreply problem using Virtual Users And Domains With Postfix, Courier And MySQL triak HOWTO-Related Questions 1 19th May 2006 15:25


All times are GMT +2. The time now is 10:43.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.