Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 30th May 2008, 19:43
metal1633 metal1633 is offline
Junior Member
 
Join Date: May 2008
Posts: 8
Thanks: 2
Thanked 0 Times in 0 Posts
Send a message via AIM to metal1633 Send a message via Yahoo to metal1633
Default

Quote:
Originally Posted by falko View Post
You're using the wrong username and/or password in /etc/courier/authmysqlrc.
I am afraid you have lost me. I have read over the how-to again and every thing seems to be they way it should be. Did you leave something out? Something obvious? Something you may have expected the reader to already know? A common problem with many how-to's. Reality is most readers are NOT as smart as the author otherwise we would not be using a how-to.

This system is not critical. There are time constraints. I need a working mail server fairly soon.

As to the passwords. Right now, because I am the only user and I am testing there is only one. sql root, mail_admin, system admin account, my personal user account...All have the same password.

So no I did not use the wrong password.

Now I went through the sql database and found that the mail_admin had no privileges even though it should have had so I gave it SELECT, INSERT, UPDATE, DELETE using Webmin. I can login to phpmyadmin using mail_admin and the password. No Problem there so I am not sure what you want me to do with /etc/courier/authmysqlrc

EDIT>> Reading through the posts I saw that one of the posters who had the same problem found that he had "and forgot[en] to change few 'mail_admin_password' to actual password." Am I to understand that I am to put the Actual Password in a bunch of plain text files? >>>> Further reading....I get it now...The files are not readable. NOW I feel like a dumb ass.

They say the third time is the Charm. I will let you know how it goes.

Last edited by metal1633; 30th May 2008 at 19:56.
Reply With Quote
Sponsored Links
  #12  
Old 31st May 2008, 22:12
metal1633 metal1633 is offline
Junior Member
 
Join Date: May 2008
Posts: 8
Thanks: 2
Thanked 0 Times in 0 Posts
Send a message via AIM to metal1633 Send a message via Yahoo to metal1633
Default

Ok. Everything seems A-Okay now. But I am having trouble with pop clients (Evolution and Thunderbird) Everytime I try to send my password is rejected. I will search to seeif there is a thread on this issue. Unless someone here has a ready answer at hand on the proper way to set up pop clients.
Reply With Quote
  #13  
Old 1st June 2008, 11:33
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

What's the exact error message from the mail log?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #14  
Old 1st June 2008, 17:55
metal1633 metal1633 is offline
Junior Member
 
Join Date: May 2008
Posts: 8
Thanks: 2
Thanked 0 Times in 0 Posts
Send a message via AIM to metal1633 Send a message via Yahoo to metal1633
Default

Quote:
Originally Posted by falko View Post
What's the exact error message from the mail log?
Thanks for taking the time to do this. If you are half as busy as I am you have no time. I created the account in Evolution, accepted the Certificates and can receive without issue. When I send, as I said, it refuses to authenticate me. Here is the relevant portion of the log. I tried several times with different setting in the client account preferences dialog.

Jun 1 10:36:52 myhostname pop3d: Connection, ip=[::ffff:myexternalIP]
Jun 1 10:36:57 myhostname pop3d: LOGOUT, ip=[::ffff:myexternalIP]
Jun 1 10:36:57 myhostname pop3d: Disconnected, ip=[::ffff:myexternalIP]
Jun 1 10:37:21 myhostname postfix/smtpd[6303]: connect from [myexternalIP]
Jun 1 10:37:24 myhostname postfix/smtpd[6303]: disconnect from myIP.My.ISP.com[myexternalIP]
Jun 1 10:38:07 myhostname postfix/smtpd[6303]: connect from myIP.My.ISP.com[myexternalIP]
Jun 1 10:38:07 myhostname postfix/smtpd[6303]: warning: SASL authentication failure: Password verification failed
Jun 1 10:38:07 myhostname postfix/smtpd[6303]: warning: myIP.My.ISP.com[myexternalIP]: SASL PLAIN authentication failed: authentication failure
Jun 1 10:38:16 myhostname postfix/smtpd[6303]: warning: SASL authentication failure: Password verification failed
Jun 1 10:38:16 myhostname postfix/smtpd[6303]: warning: myIP.My.ISP.com[myexternalIP]: SASL PLAIN authentication failed: authentication failure
Jun 1 10:38:24 myhostname postfix/smtpd[6303]: warning: SASL authentication failure: Password verification failed
Jun 1 10:38:24 myhostname postfix/smtpd[6303]: warning: myIP.My.ISP.com[myexternalIP]: SASL PLAIN authentication failed: authentication failure
Jun 1 10:38:26 myhostname postfix/smtpd[6303]: disconnect from myIP.My.ISP.com[myexternalIP]
Jun 1 10:38:52 myhostname pop3d: Connection, ip=[::ffff:myexternalIP]
Jun 1 10:38:52 myhostname postfix/smtpd[6303]: connect from myIP.My.ISP.com[myexternalIP]
Jun 1 10:38:57 myhostname pop3d: LOGIN, user=username@domain.com, ip=[::ffff:myexternalIP], port=[60595]
Jun 1 10:39:01 myhostname postfix/smtpd[6303]: warning: SASL authentication failure: Password verification failed
Jun 1 10:39:01 myhostname postfix/smtpd[6303]: warning: myIP.My.ISP.com[myexternalIP]: SASL PLAIN authentication failed: authentication failure
Jun 1 10:39:05 myhostname postfix/smtpd[6303]: warning: SASL authentication failure: Password verification failed
Jun 1 10:39:05 myhostname postfix/smtpd[6303]: warning: myIP.My.ISP.com[myexternalIP]: SASL PLAIN authentication failed: authentication failure
Jun 1 10:39:07 myhostname postfix/smtpd[6303]: warning: SASL authentication failure: Password verification failed
Jun 1 10:39:07 myhostname postfix/smtpd[6303]: warning: myIP.My.ISP.com[myexternalIP]: SASL PLAIN authentication failed: authentication failure
Jun 1 10:39:08 myhostname postfix/smtpd[6303]: warning: SASL authentication failure: Password verification failed
Jun 1 10:39:08 myhostname postfix/smtpd[6303]: warning: myIP.My.ISP.com[myexternalIP]: SASL PLAIN authentication failed: authentication failure
Jun 1 10:39:09 myhostname postfix/smtpd[6303]: disconnect from myIP.My.ISP.com[myexternalIP]
Jun 1 10:39:13 myhostname pop3d: LOGOUT, user=username@domain.com, ip=[::ffff:myexternalIP], port=[60595], top=0, retr=7605, rcvd=56, sent=8188, time=16, stls=1
Jun 1 10:42:29 myhostname postfix/anvil[6306]: statistics: max connection rate 2/60s for (smtp:myexternalIP) at Jun 1 10:38:07
Jun 1 10:42:29 myhostname postfix/anvil[6306]: statistics: max connection count 1 for (smtp:myexternalIP) at Jun 1 10:37:21
Jun 1 10:42:29 myhostname postfix/anvil[6306]: statistics: max cache size 1 at Jun 1 10:37:21
Reply With Quote
  #15  
Old 2nd June 2008, 10:24
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

What's in your main.cf and /etc/pam.d/smtpd? Did you disable AppArmor?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
metal1633 (2nd June 2008)
  #16  
Old 2nd June 2008, 17:06
metal1633 metal1633 is offline
Junior Member
 
Join Date: May 2008
Posts: 8
Thanks: 2
Thanked 0 Times in 0 Posts
Send a message via AIM to metal1633 Send a message via Yahoo to metal1633
Default

Quote:
Originally Posted by falko View Post
What's in your main.cf and /etc/pam.d/smtpd? Did you disable AppArmor?
Apparmor is disabled and purged. It was an error in the /etc/pam.d/smtp file. That file is also readable by other users and I do not like that. By changing its permissions, making it readable to only 'owner' and 'group' will I break the system?

Ohh and its 'owner' is 'root' and its 'group' is also 'root'.

Last edited by metal1633; 2nd June 2008 at 17:10.
Reply With Quote
  #17  
Old 2nd June 2008, 22:23
lombardo lombardo is offline
Junior Member
 
Join Date: Jun 2008
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default ERROR: Connection dropped by IMAP server.

First of all I want to thank you for the tutorial. I am having a connection dropped by IMAP server.

Here is the mail log i outputted using tail.


Jun 2 20:09:36 Webhoster imapd: Connection, ip=[::ffff:127.0.0.1]
Jun 2 20:09:36 Webhoster imapd: authdaemon: s_connect() failed: Connection refused
Jun 2 20:09:36 Webhoster imapd: [Hint: perhaps authdaemond is not running?]
Jun 2 20:09:36 Webhoster imapd: LOGIN FAILED, user=, ip=[::ffff:127.0.0.1]
Jun 2 20:09:36 Webhoster imapd: authentication error: Connection refused
Jun 2 20:13:33 Webhoster imapd: Connection, ip=[::ffff:127.0.0.1]
Jun 2 20:13:33 Webhoster imapd: authdaemon: s_connect() failed: Connection refused
Jun 2 20:13:33 Webhoster imapd: [Hint: perhaps authdaemond is not running?]
Jun 2 20:13:33 Webhoster imapd: LOGIN FAILED, user=info@danielmessier.com, ip=[::ffff:127.0.0.1]
Jun 2 20:13:33 Webhoster imapd: authentication error: Connection refused
Jun 2 20:23:00 Webhoster imapd: Connection, ip=[::ffff:127.0.0.1]
Jun 2 20:23:00 Webhoster imapd: authdaemon: s_connect() failed: Connection refused
Jun 2 20:23:00 Webhoster imapd: [Hint: perhaps authdaemond is not running?]
Jun 2 20:23:00 Webhoster imapd: LOGIN FAILED, user=info@danielmessier.com, ip=[::ffff:127.0.0.1]
Jun 2 20:23:00 Webhoster imapd: authentication error: Connection refused


Thanks for helping me out.

Lombardo
Reply With Quote
  #18  
Old 3rd June 2008, 10:30
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

Quote:
Originally Posted by metal1633 View Post
By changing its permissions, making it readable to only 'owner' and 'group' will I break the system?
Not sure - I'd try it.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #19  
Old 3rd June 2008, 10:30
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

Quote:
Originally Posted by lombardo View Post
Jun 2 20:09:36 Webhoster imapd: [Hint: perhaps authdaemond is not running?]
Is the Courier authdaemon running?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #20  
Old 3rd June 2008, 15:17
lombardo lombardo is offline
Junior Member
 
Join Date: Jun 2008
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

How can I check if the Courier authdaemon is running ?

I am quite new at this and appreciate the efforts you are making towards helping me.

On a sidenote which book would you recommend to help me understand Ubuntu Server ? I need the book to have a chapter or two on mail setup.

Thanks
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail (Ubuntu 8.04) canardwc HOWTO-Related Questions 12 29th May 2008 18:29
Virtual Users And Domains With Postfix, Courier And MySQL (Ubuntu 7.10) ShadyB HOWTO-Related Questions 1 1st April 2008 18:00
Virtual Users And Domains W/ Postfix, Courier and MySql + Squirrelmail prob nsurge HOWTO-Related Questions 10 23rd October 2006 17:43
Virtual Users And Domains W/ Postfix, Courier and MySql + Squirrelmail prob kwinnuxbie HOWTO-Related Questions 7 22nd October 2006 19:26
Autoreply problem using Virtual Users And Domains With Postfix, Courier And MySQL triak HOWTO-Related Questions 1 19th May 2006 15:25


All times are GMT +2. The time now is 10:09.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.