Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 27th May 2008, 08:20
c4rdinal c4rdinal is offline
Member
 
Join Date: Mar 2008
Posts: 78
Thanks: 0
Thanked 0 Times in 0 Posts
Default Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail -Ubuntu 8.04

Hi,

I have a couple of problems encountered after installation hope you can help me.

Errors are as follows:

1. Logging in to Squirrelmail says:

Quote:
ERROR: Connection dropped by IMAP server.
root@mx-1:~# mutt -f imap://localhost

Logging in failed

2. Host or domain name not found error.

root@mx-1:~# tail -f /var/log/mail.log
May 28 14:31:39 mx-1 dccproc[5646]: no working DCC servers dcc1.dcc-servers.net dcc2.dcc-servers.net dcc3.dcc-servers.net ... at 127.0.0.1
May 28 14:31:40 mx-1 postfix/smtpd[5648]: connect from localhost[127.0.0.1]
May 28 14:31:40 mx-1 postfix/smtpd[5648]: E88E53444D: client=localhost[127.0.0.1]
May 28 14:31:40 mx-1 postfix/cleanup[5639]: E88E53444D: message-id=<20080528063134.0219334450@mx-1.domain.com>
May 28 14:31:40 mx-1 postfix/qmgr[5398]: E88E53444D: from=<root@mx-1.domain.com>, size=767, nrcpt=1 (queue active)
May 28 14:31:40 mx-1 postfix/smtpd[5648]: disconnect from localhost[127.0.0.1]
May 28 14:31:40 mx-1 amavis[4627]: (04627-02) Passed CLEAN, <root@mx-1.domain.com> -> <cherry@domain.com>, Message-ID: <20080528063134.0219334450@mx-1.domain.com>, mail_id: MB-ZuTTqLSZe, Hits: 1.449, size: 317, queued_as: E88E53444D, 6929 ms
May 28 14:31:40 mx-1 postfix/smtp[5642]: 0219334450: to=<cherry@domain.com>, relay=127.0.0.1[127.0.0.1]:10024, delay=7, delays=0.08/0.01/0.01/6.9, dsn=2.0.0, status=sent (250 2.0.0 Ok: queued as E88E53444D)
May 28 14:31:40 mx-1 postfix/qmgr[5398]: 0219334450: removed
May 28 14:32:01 mx-1 postfix/smtp[5652]: E88E53444D: to=<cherry@domain.com>, relay=none, delay=20, delays=0.02/0.02/20/0, dsn=4.4.3, status=deferred (Host or domain name not found. Name service error for name=mx-1.domain.com type=MX: Host not found, try again)

I made the following tests:

root@mx-1:~#hostname -f
mx-1.domain.com

root@mx-1:~#cat /etc/hosts

127.0.0.1 localhost
10.10.10.10 mx-1.domain.com mx-1

ping mx-1
PING mx-1.alsterph.com (10.10.10.10) 56(84) bytes of data.
64 bytes from mx-1.domain.com (10.10.10.10): icmp_seq=1 ttl=64 time=0.370 ms
64 bytes from mx-1.domain.com (10.10.10.10): icmp_seq=2 ttl=64 time=0.039 ms
64 bytes from mx-1.domain.com (10.10.10.10): icmp_seq=3 ttl=64 time=0.016 ms

root@mx-1:~# cat /etc/resolv.conf
search alsterph.com
nameserver 10.10.10.111 (this is my internal DNS)


root@mx-1:~# netstat -tap
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 localhost:10024 *:* LISTEN 4009/amavisd (maste
tcp 0 0 localhost:10025 *:* LISTEN 5395/master
tcp 0 0 localhost:mysql *:* LISTEN 4083/mysqld
tcp 0 0 *:www *:* LISTEN 4756/apache2
tcp 0 0 *:smtp *:* LISTEN 5395/master
tcp6 0 0 [::]:imaps [::]:* LISTEN 5556/couriertcpd
tcp6 0 0 [::]op3s [::]:* LISTEN 5624/couriertcpd
tcp6 0 0 [::]op3 [::]:* LISTEN 5587/couriertcpd
tcp6 0 0 [::]:imap2 [::]:* LISTEN 5519/couriertcpd
tcp6 0 0 [::]:ssh [::]:* LISTEN 3974/sshd
tcp6 0 0 mx-1.domain.com:ssh 10.10.10.77%8191:2134 ESTABLISHED 4803/1

root@mx-1:~# telnet localhost 25
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
220 mx-1.domain.com ESMTP Postfix (Ubuntu)
ehlo domain.com
250-mx-1.domain.com
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-STARTTLS
250-AUTH LOGIN PLAIN
250-AUTH=LOGIN PLAIN
250-ENHANCEDSTATUSCODES
250-8BITMIME
250 DSN
quit
221 2.0.0 Bye
Connection closed by foreign host.

I tried to recheck everything but I can't seem to see what I missed.

I hope you can help me.

Thanks alot and more power!

Last edited by c4rdinal; 28th May 2008 at 01:34.
Reply With Quote
Sponsored Links
  #2  
Old 27th May 2008, 19:48
matpaa matpaa is offline
Junior Member
 
Join Date: May 2008
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default This worked for me

I'm noob (and bit lazy) and that's why i crawl trougth guides.

I had similar problem and my problem was solved when i checked all files i needed to edit when following that guide.

There i found that i did too much copy - paste and forgot to change few 'mail_admin_password' to actual password.

Maybe this is worth to check ?
Reply With Quote
  #3  
Old 28th May 2008, 01:38
c4rdinal c4rdinal is offline
Member
 
Join Date: Mar 2008
Posts: 78
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by matpaa View Post
I'm noob (and bit lazy) and that's why i crawl trougth guides.

I had similar problem and my problem was solved when i checked all files i needed to edit when following that guide.

There i found that i did too much copy - paste and forgot to change few 'mail_admin_password' to actual password.

Maybe this is worth to check ?

Hi,

I already made a recheck on everything but I can't see where I missed.

root@mx-1:~# find /home/vmail/
/home/vmail/
/home/vmail/.bash_logout
/home/vmail/.profile
/home/vmail/.bashrc

Sending the user doesn't create directories either.
Reply With Quote
  #4  
Old 28th May 2008, 15:58
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

Please create an A record for mx-1.domain.com.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 28th May 2008, 19:14
matpaa matpaa is offline
Junior Member
 
Join Date: May 2008
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

It should not need server name to mail address.
... at least mine is working fine without that.

i assume that you done:
mailx cherry@domain.com

if you put something into transports or forwardings tables remove those entrys and try again.

... and other modifications also, so you have plain setup.
Reply With Quote
  #6  
Old 29th May 2008, 02:15
metal1633 metal1633 is offline
Junior Member
 
Join Date: May 2008
Posts: 8
Thanks: 2
Thanked 0 Times in 0 Posts
Send a message via AIM to metal1633 Send a message via Yahoo to metal1633
Default

I have been through the how-to twice and have the same error from Squirrelmail. And with the same mutt command it rejects my password with "temporary problem. please try again later" and "Login Failed."

EDIT. Falko...In the how-to you do not say to activate SpamAssassin. Should I also edit /etc/default/spamassassin and change ENABLED=no to ENABLED=yes? then start it?

Also I found that there is no mailbox under /home/vmail, though there is one under /home/administrator and /home/'username' and also under /root

Last edited by metal1633; 29th May 2008 at 05:53.
Reply With Quote
  #7  
Old 29th May 2008, 10:57
c4rdinal c4rdinal is offline
Member
 
Join Date: Mar 2008
Posts: 78
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Same here. I redo everything but same results. Cannot login via Squirrelmail.
Reply With Quote
  #8  
Old 29th May 2008, 18:40
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

Quote:
Originally Posted by metal1633 View Post
EDIT. Falko...In the how-to you do not say to activate SpamAssassin. Should I also edit /etc/default/spamassassin and change ENABLED=no to ENABLED=yes? then start it?
No, that's not necessary as amavisd calls the normal spamassassin binary, not the daemon.

What's in your mail log now?

IF the mailboxes are not created within /home/vmail, then there's something fundamentally wrong with your system...
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 29th May 2008, 21:15
metal1633 metal1633 is offline
Junior Member
 
Join Date: May 2008
Posts: 8
Thanks: 2
Thanked 0 Times in 0 Posts
Send a message via AIM to metal1633 Send a message via Yahoo to metal1633
Default

Quote:
Originally Posted by falko View Post
No, that's not necessary as amavisd calls the normal spamassassin binary, not the daemon.

What's in your mail log now?

IF the mailboxes are not created within /home/vmail, then there's something fundamentally wrong with your system...
Ok thanks for the intel on spamassassin. The how-to was unclear at that point. I knew the amavisd called Spamassassin but was unsure if it needed to be activated itself.

And yeah there must be something fundamentally wrong with my install. Something I did wrong twice. The First time, a fresh install, I typed out all the commands and edits. But I got the error. Being mildly dyslexic, I am ubber dependent on spell checkers and could very well have made an typing error. So the Second time I Copy/Pasted all your commands and edits (also a fresh install) But got the same issue.

SO. I rebooted and when the system came up I attempted to log into Squirrelmail from my desktop and got the error "ERROR: Connection dropped by IMAP server." And when I mutt as either admin or user I get the error ""temporary problem. please try again later" and "Login Failed." Below is the relevant portion of the mail.log file from reboot to attempting to access squirrelmail.

May 29 13:35:16 hostname spamd[5471]: spamd: server killed by SIGTERM, shutting down
May 29 13:35:31 hostname authdaemond: stopping authdaemond children
May 29 13:35:31 hostname postfix/master[5028]: terminating on signal 15
May 29 13:39:08 hostname amavis[4757]: starting. /usr/sbin/amavisd-new at hostname.domain.com amavisd-new-2.5.3 (20071212), Unicode aware
May 29 13:39:08 hostname amavis[4757]: Perl version 5.008008
May 29 13:39:11 hostname amavis[4762]: Module Amavis::Conf 2.093
May 29 13:39:11 hostname amavis[4762]: Module Archive::Zip 1.18
May 29 13:39:11 hostname amavis[4762]: Module BerkeleyDB 0.32
May 29 13:39:11 hostname amavis[4762]: Module Compress::Zlib 2.008
May 29 13:39:11 hostname amavis[4762]: Module Convert::TNEF 0.17
May 29 13:39:11 hostname amavis[4762]: Module Convert::UUlib 1.09
May 29 13:39:11 hostname amavis[4762]: Module DBD::mysql 4.005
May 29 13:39:11 hostname amavis[4762]: Module DBI 1.601
May 29 13:39:11 hostname amavis[4762]: Module DB_File 1.814
May 29 13:39:11 hostname amavis[4762]: Module Digest::MD5 2.36
May 29 13:39:11 hostname amavis[4762]: Module Digest::SHA1 2.11
May 29 13:39:11 hostname amavis[4762]: Module MIME::Entity 5.425
May 29 13:39:11 hostname amavis[4762]: Module MIME::Parser 5.425
May 29 13:39:11 hostname amavis[4762]: Module MIME::Tools 5.425
May 29 13:39:11 hostname amavis[4762]: Module Mail::Header 2.02
May 29 13:39:11 hostname amavis[4762]: Module Mail::Internet 2.02
May 29 13:39:11 hostname amavis[4762]: Module Mail::SPF v2.005
May 29 13:39:11 hostname amavis[4762]: Module Mail::SpamAssassin 3.002004
May 29 13:39:11 hostname amavis[4762]: Module Net::DNS 0.63
May 29 13:39:11 hostname amavis[4762]: Module Net::Server 0.97
May 29 13:39:11 hostname amavis[4762]: Module NetAddr::IP 4.007
May 29 13:39:11 hostname amavis[4762]: Module Razor2::Client::Version 2.84
May 29 13:39:11 hostname amavis[4762]: Module Time::HiRes 1.86
May 29 13:39:11 hostname amavis[4762]: Module URI 1.35
May 29 13:39:11 hostname amavis[4762]: Module Unix::Syslog 1.0
May 29 13:39:11 hostname amavis[4762]: Amavis::DB code loaded
May 29 13:39:11 hostname amavis[4762]: Amavis::Cache code loaded
May 29 13:39:11 hostname amavis[4762]: SQL base code NOT loaded
May 29 13:39:11 hostname amavis[4762]: SQL::Log code NOT loaded
May 29 13:39:11 hostname amavis[4762]: SQL::Quarantine NOT loaded
May 29 13:39:11 hostname amavis[4762]: Lookup::SQL code NOT loaded
May 29 13:39:11 hostname amavis[4762]: Lookup::LDAP code NOT loaded
May 29 13:39:11 hostname amavis[4762]: AM.PDP-in proto code loaded
May 29 13:39:11 hostname amavis[4762]: SMTP-in proto code loaded
May 29 13:39:11 hostname amavis[4762]: Courier proto code NOT loaded
May 29 13:39:11 hostname amavis[4762]: SMTP-out proto code loaded
May 29 13:39:11 hostname amavis[4762]: Pipe-out proto code NOT loaded
May 29 13:39:11 hostname amavis[4762]: BSMTP-out proto code NOT loaded
May 29 13:39:11 hostname amavis[4762]: Local-out proto code loaded
May 29 13:39:11 hostname amavis[4762]: OS_Fingerprint code NOT loaded
May 29 13:39:11 hostname amavis[4762]: ANTI-VIRUS code loaded
May 29 13:39:11 hostname amavis[4762]: ANTI-SPAM code loaded
May 29 13:39:11 hostname amavis[4762]: ANTI-SPAM-SA code loaded
May 29 13:39:11 hostname amavis[4762]: Unpackers code loaded
May 29 13:39:11 hostname amavis[4762]: Found $file at /usr/bin/file
May 29 13:39:11 hostname amavis[4762]: No $dspam, not using it
May 29 13:39:11 hostname amavis[4762]: No $altermime, not using it
May 29 13:39:11 hostname amavis[4762]: Internal decoder for .mail
May 29 13:39:11 hostname amavis[4762]: Internal decoder for .asc
May 29 13:39:11 hostname amavis[4762]: Internal decoder for .uue
May 29 13:39:11 hostname amavis[4762]: Internal decoder for .hqx
May 29 13:39:11 hostname amavis[4762]: Internal decoder for .ync
May 29 13:39:11 hostname amavis[4762]: No decoder for .F
May 29 13:39:11 hostname amavis[4762]: Found decoder for .Z at /bin/uncompress
May 29 13:39:11 hostname amavis[4762]: Internal decoder for .gz
May 29 13:39:11 hostname amavis[4762]: Found decoder for .bz2 at /bin/bzip2 -d
May 29 13:39:11 hostname amavis[4762]: Found decoder for .lzo at /usr/bin/lzop -d
May 29 13:39:11 hostname amavis[4762]: No decoder for .rpm tried: rpm2cpio.pl, rpm2cpio
May 29 13:39:11 hostname amavis[4762]: Found decoder for .cpio at /usr/bin/pax
May 29 13:39:11 hostname amavis[4762]: Found decoder for .tar at /usr/bin/pax
May 29 13:39:11 hostname amavis[4762]: Found decoder for .deb at /usr/bin/ar
May 29 13:39:11 hostname amavis[4762]: Internal decoder for .zip
May 29 13:39:11 hostname amavis[4762]: No decoder for .7z tried: 7zr, 7za, 7z
May 29 13:39:11 hostname amavis[4762]: No decoder for .rar
May 29 13:39:11 hostname amavis[4762]: No decoder for .arj tried: arj, unarj
May 29 13:39:11 hostname amavis[4762]: Found decoder for .arc at /usr/bin/nomarch
May 29 13:39:11 hostname amavis[4762]: Found decoder for .zoo at /usr/bin/zoo
May 29 13:39:11 hostname amavis[4762]: No decoder for .lha
May 29 13:39:11 hostname amavis[4762]: No decoder for .doc tried: ripole
May 29 13:39:11 hostname amavis[4762]: No decoder for .cab tried: cabextract
May 29 13:39:11 hostname amavis[4762]: No decoder for .tnef
May 29 13:39:11 hostname amavis[4762]: Internal decoder for .tnef
May 29 13:39:11 hostname amavis[4762]: No decoder for .exe tried: arj, unarj
May 29 13:39:11 hostname amavis[4762]: Using primary internal av scanner code for ClamAV-clamd
May 29 13:39:12 hostname amavis[4762]: Using primary internal av scanner code for check-jpeg
May 29 13:39:12 hostname amavis[4762]: Found secondary av scanner ClamAV-clamscan at /usr/bin/clamscan
May 29 13:39:12 hostname amavis[4762]: Creating db in /var/lib/amavis/db/; BerkeleyDB 0.32, libdb 4.6
May 29 13:39:16 hostname spamd[4893]: logger: removing stderr method
May 29 13:39:20 hostname authdaemond: modules="authmysql", daemons=5
May 29 13:39:20 hostname authdaemond: Installing libauthmysql
May 29 13:39:20 hostname authdaemond: Installation complete: authmysql
May 29 13:39:22 hostname spamd[4908]: spamd: server started on port 783/tcp (running version 3.2.4)
May 29 13:39:22 hostname spamd[4908]: spamd: server pid: 4908
May 29 13:39:22 hostname spamd[4908]: spamd: server successfully spawned child process, pid 5405
May 29 13:39:22 hostname spamd[4908]: spamd: server successfully spawned child process, pid 5406
May 29 13:39:22 hostname spamd[4908]: prefork: child states: II
May 29 13:39:23 hostname postfix/master[5407]: daemon started -- version 2.5.1, configuration /etc/postfix
May 29 13:52:18 hostname imapd: Connection, ip=[::ffff:127.0.0.1]
May 29 13:52:18 hostname authdaemond: failed to connect to mysql server (server=localhost, userid=mail_admin): Access denied for user 'mail_admin'@'localhost' (using password: YES)
May 29 13:52:18 hostname imapd: LOGIN FAILED, user=myusername@domain.com, ip=[::ffff:127.0.0.1]
May 29 13:52:18 hostname imapd: authentication error: Input/output error
May 29 13:55:17 hostname imapd: Connection, ip=[::ffff:127.0.0.1]
May 29 13:55:17 hostname authdaemond: failed to connect to mysql server (server=localhost, userid=mail_admin): Access denied for user 'mail_admin'@'localhost' (using password: YES)
May 29 13:55:17 hostname imapd: LOGIN FAILED, user=myusername, ip=[::ffff:127.0.0.1]
May 29 13:55:17 hostname imapd: authentication error: Input/output error

Last edited by metal1633; 29th May 2008 at 21:20.
Reply With Quote
  #10  
Old 30th May 2008, 13:57
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
 
Default

Quote:
Originally Posted by metal1633 View Post
May 29 13:52:18 hostname authdaemond: failed to connect to mysql server (server=localhost, userid=mail_admin): Access denied for user 'mail_admin'@'localhost' (using password: YES)
You're using the wrong username and/or password in /etc/courier/authmysqlrc.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
ajanesstivaovay7707 (24th August 2013)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail (Ubuntu 8.04) canardwc HOWTO-Related Questions 12 29th May 2008 18:29
Virtual Users And Domains With Postfix, Courier And MySQL (Ubuntu 7.10) ShadyB HOWTO-Related Questions 1 1st April 2008 18:00
Virtual Users And Domains W/ Postfix, Courier and MySql + Squirrelmail prob nsurge HOWTO-Related Questions 10 23rd October 2006 17:43
Virtual Users And Domains W/ Postfix, Courier and MySql + Squirrelmail prob kwinnuxbie HOWTO-Related Questions 7 22nd October 2006 19:26
Autoreply problem using Virtual Users And Domains With Postfix, Courier And MySQL triak HOWTO-Related Questions 1 19th May 2006 15:25


All times are GMT +2. The time now is 20:39.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.