Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 26th May 2008, 03:38
hanswid hanswid is offline
Junior Member
 
Join Date: Apr 2008
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Default same user name for different domain

by default, looks like ISPConfig wouldn't allow us to have 2 same user or email on different domain (correct me if i m wrong).

I have several domain my my machine, and let's say I have email hans@domain1.com and when i try to create different user hans@domain2.com, ISPConfig will refuses it and saying that user 'hans' exist. Is there any setting that we can set to enable 2 same user name on different domain?
Reply With Quote
Sponsored Links
  #2  
Old 26th May 2008, 10:00
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,500 Times in 4,329 Posts
Default

Quote:
ISPConfig will refuses it and saying that user 'hans' exist.
You mix up usernames and email addresses. You can have email addresses hans@domain1.com and when i try to create different user hans@domain2.com on the same server, thats why ISPConfig uses the username prefix. If ISPConfig complains about identical users, you might have disabled the username prefix.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 26th May 2008, 10:16
hanswid hanswid is offline
Junior Member
 
Join Date: Apr 2008
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Default

yes, i turned it off coz it's look funny to have email web1_hans@domain1.com, and FTP user like web1_hans. I dont want to have that prefix.
Reply With Quote
  #4  
Old 26th May 2008, 10:19
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,500 Times in 4,329 Posts
Default

Username != Email address. You have a separate field for the email address, so the email address is not web1_hans@domain1.com.

Quote:
I dont want to have that prefix.
Linux system user names are alwyas unique for the whole server, thats the way linux works and nothing special in ISPConfig.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 26th May 2008, 11:04
hanswid hanswid is offline
Junior Member
 
Join Date: Apr 2008
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Default

so in this case, it doesn't matter whether I use prefix or not, there is no way that i can have email hans@domain1.com and hans@domain2.com as the time? ISPConfig uses kind of /etc/passwd file? one user for one email address, got nothing to do with different domain?
Reply With Quote
  #6  
Old 26th May 2008, 11:11
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,500 Times in 4,329 Posts
Default

Please read my above posts again:

1) Username != email address.
2) You may have hans@domain1.com and hans@domain2.com for sure, I told you that above.

the steps are:

1) Activate the user prefix again, you should never deactivetd it.
2) Create the two email addresses hans@domain1.com and hans@domain2.com

You can have 200 sites on your server and every site has its own email address info@.... without problems.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 26th May 2008, 11:20
hanswid hanswid is offline
Junior Member
 
Join Date: Apr 2008
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Thumbs up

thx, sorry a newbie. I will try it now.
Reply With Quote
  #8  
Old 27th May 2008, 04:26
hanswid hanswid is offline
Junior Member
 
Join Date: Apr 2008
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Default

i tried and still failed. i activated prefix now. So in User & Email tab looks like this :

- Email address : hans@domain1.com
- Username : igi-hans <=== uses 'igi' as prefix
- Password : mypassword

I saved it, and tried it with Thunderbird. If i use hans as login, it will fail, but if i use igi-hans, login will OK. Meaning, that I have to use igi-hans@domain1.com instead of hans@domain1.com.

But i try using webmail, both hans and igi-hans can login without problem. But mail send to other like Yahoo always appears as igi-hans, not hans.

Is there any other setting that i missed??
Reply With Quote
  #9  
Old 27th May 2008, 08:12
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,421
Thanks: 834
Thanked 5,500 Times in 4,329 Posts
 
Default

This failed for sure. You have to restore the original prefix "web[WEBID]_" as it contains a variable.

Quote:
Meaning, that I have to use igi-hans@domain1.com instead of hans@domain1.com.
No, not at all. The third time: USERNAME != EMAIL ADDRESS

Quote:
But mail send to other like Yahoo always appears as igi-hans, not hans.
You must set the correct sender address in your mail client.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Statistic not working mzo Installation/Configuration 49 20th April 2011 12:19
Mail server using Postfix, Dovecot, Mysql... Postfix virtual maps doesn't work?? tarasbuljba HOWTO-Related Questions 33 28th May 2010 14:33
Mail System Error - Returned Mail tristanlee85 General 16 16th March 2008 09:40
Ruby / FastCGI Problem Chad Server Operation 1 8th March 2008 20:38
log files cruz Technical 3 15th May 2007 14:35


All times are GMT +2. The time now is 08:40.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.