#1  
Old 12th May 2008, 12:51
Mole Mole is offline
Member
 
Join Date: Apr 2008
Location: Latvia
Posts: 83
Thanks: 1
Thanked 0 Times in 0 Posts
Default Problems with mails

Hello!
Finally I've normally installed ispconfig.
I have created 4 sites - they works normally (also the wordpress based one).
I created e-mail users, for exemple, info@virtualdomain.lv.

When I send from webmail (Squiremail, Rouncube) for testing, then recieve mail from info@example.com. Of course, when I want to send to info@virtualdomain.lv, I got error mail:
<info@virtualdomain.lv>: host mail.virtualdomain.lv[myserverIP] said:
554<info@virtualdomain.lv>: recipient address rejected: Relay access denied (in reply to RCPT TO command)

Code:
myserver:/ # postconf -n
alias_maps = hash:/etc/aliases
biff = no
broken_sasl_auth_clients = yes
canonical_maps = hash:/etc/postfix/canonical
command_directory = /usr/sbin
config_directory = /etc/postfix
daemon_directory = /usr/lib/postfix
debug_peer_level = 2
defer_transports =
disable_dns_lookups = no
disable_mime_output_conversion = no
html_directory = /usr/share/doc/packages/postfix/html
inet_interfaces = all
inet_protocols = all
mail_owner = postfix
mail_spool_directory = /var/mail
mailbox_command =
mailbox_size_limit = 0
mailbox_transport =
mailq_path = /usr/bin/mailq
manpage_directory = /usr/share/man
masquerade_classes = envelope_sender, header_sender, header_recipient
masquerade_domains =
masquerade_exceptions = root
message_size_limit = 10240000
mydestination = /etc/postfix/local-host-names
mydomain = mydomain.lv
myhostname = myserver.$mydomain
mynetworks_style = subnet
newaliases_path = /usr/bin/newaliases
queue_directory = /var/spool/postfix
readme_directory = /usr/share/doc/packages/postfix/README_FILES
relayhost =
relocated_maps = hash:/etc/postfix/relocated
sample_directory = /usr/share/doc/packages/postfix/samples
sender_canonical_maps = hash:/etc/postfix/sender_canonical
sendmail_path = /usr/sbin/sendmail
setgid_group = maildrop
smtp_sasl_auth_enable = no
smtp_tls_note_starttls_offer = yes
smtp_use_tls = yes
smtpd_client_restrictions =
smtpd_helo_required = no
smtpd_helo_restrictions =
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,check_relay_domains
smtpd_sasl_auth_enable = yes
smtpd_sasl_local_domain =
smtpd_sasl_security_options = noanonymous
smtpd_sender_restrictions = hash:/etc/postfix/access
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_auth_only = no
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
smtpd_use_tls = yes
strict_8bitmime = no
strict_rfc821_envelopes = no
tls_random_source = dev:/dev/urandom
transport_maps = hash:/etc/postfix/transport
unknown_local_recipient_reject_code = 550
virtual_alias_domains = hash:/etc/postfix/virtual
Code:
myserver:/etc/postfix # edit main.cf
mynetworks_style = subnet
disable_dns_lookups = no
relayhost =
mailbox_command =
mailbox_transport =
strict_8bitmime = no
disable_mime_output_conversion = no
smtpd_sender_restrictions = hash:/etc/postfix/access
smtpd_client_restrictions =
smtpd_helo_required = no
smtpd_helo_restrictions =
strict_rfc821_envelopes = no
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,check_relay_domains
smtp_sasl_auth_enable = no
smtpd_sasl_auth_enable = yes
smtpd_use_tls = yes
smtp_use_tls = yes
alias_maps = hash:/etc/aliases
mailbox_size_limit = 0
message_size_limit = 10240000
mydomain = ardit.lv
smtpd_sasl_local_domain =
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_tls_auth_only = no
smtp_tls_note_starttls_offer = yes
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom

virtual_maps = hash:/etc/postfix/virtusertable

mydestination = /etc/postfix/local-host-names
Code:
myserver: /etc/postfix # edit mail.cf
#
# Postfix master process configuration file.  For details on the format
# of the file, see the Postfix master(5) manual page.
#
# ==========================================================================
# service type  private unpriv  chroot  wakeup  maxproc command + args
#               (yes)   (yes)   (yes)   (never) (100)
# ==========================================================================
smtp      inet  n       -       n       -       -       smtpd
#submission inet n      -       n       -       -       smtpd
#	-o smtpd_etrn_restrictions=reject
#	-o smtpd_client_restrictions=permit_sasl_authenticated,reject
#smtps    inet  n       -       n       -       -       smtpd
#  -o smtpd_tls_wrappermode=yes -o smtpd_sasl_auth_enable=yes
#submission   inet    n       -       n       -       -       smtpd
#  -o smtpd_etrn_restrictions=reject
#  -o smtpd_enforce_tls=yes -o smtpd_sasl_auth_enable=yes
#628      inet  n       -       n       -       -       qmqpd
pickup    fifo  n       -       n       60      1       pickup
cleanup   unix  n       -       n       -       0       cleanup
qmgr      fifo  n       -       n       300     1       qmgr
#qmgr     fifo  n       -       n       300     1       oqmgr
tlsmgr    unix  -       -       n       1000?   1       tlsmgr
rewrite   unix  -       -       n       -       -       trivial-rewrite
bounce    unix  -       -       n       -       0       bounce
defer     unix  -       -       n       -       0       bounce
trace     unix  -       -       n       -       0       bounce
verify    unix  -       -       n       -       1       verify
flush     unix  n       -       n       1000?   0       flush
proxymap  unix  -       -       n       -       -       proxymap
smtp      unix  -       -       n       -       -       smtp
# When relaying mail as backup MX, disable fallback_relay to avoid MX loops
relay     unix  -       -       n       -       -       smtp
	-o fallback_relay=
#       -o smtp_helo_timeout=5 -o smtp_connect_timeout=5
showq     unix  n       -       n       -       -       showq
error     unix  -       -       n       -       -       error
discard   unix  -       -       n       -       -       discard
local     unix  -       n       n       -       -       local
virtual   unix  -       n       n       -       -       virtual
lmtp      unix  -       -       n       -       -       lmtp
anvil     unix  -       -       n       -       1       anvil
#localhost:10025 inet	n	-	n	-	-	smtpd -o content_filter=
scache	  unix	-	-	n	-	1	scache
#
# ====================================================================
# Interfaces to non-Postfix software. Be sure to examine the manual
# pages of the non-Postfix software to find out what options it wants.
#
# Many of the following services use the Postfix pipe(8) delivery
# agent.  See the pipe(8) man page for information about ${recipient}
# and other message envelope options.
# ====================================================================
#
# maildrop. See the Postfix MAILDROP_README file for details.
# Also specify in main.cf: maildrop_destination_recipient_limit=1
#
maildrop  unix  -       n       n       -       -       pipe
  flags=DRhu user=vmail argv=/usr/local/bin/maildrop -d ${recipient}
cyrus	  unix	-	n	n	-	-	pipe
  user=cyrus argv=/usr/lib/cyrus/bin/deliver -e -r ${sender} -m ${extension} ${user}
uucp	  unix	-	n	n	-	-	pipe
  flags=Fqhu user=uucp argv=uux -r -n -z -a$sender - $nexthop!rmail ($recipient)
ifmail    unix  -       n       n       -       -       pipe
  flags=F user=ftn argv=/usr/lib/ifmail/ifmail -r $nexthop ($recipient)
bsmtp     unix  -       n       n       -       -       pipe
  flags=Fq. user=foo argv=/usr/local/sbin/bsmtp -f $sender $nexthop $recipient
procmail  unix  -       n       n       -       -       pipe
  flags=R user=nobody argv=/usr/bin/procmail -t -m /etc/procmailrc ${sender} ${recipient}
Code:
myserver: /etc/postfix # edit virtuserable
###################################
#
# ISPConfig virtusertable Configuration File
#         Version 1.0
#
###################################
[...]
www.virtualdomain.lv    VIRTUALDOMAIN
info@www.virtualdomain.lv    info
[...]
virtualdomain.lv    VIRTUALDOMAIN
info@virtualdomain.lv    info
[...]
#### MAKE MANUAL ENTRIES BELOW THIS LINE! ####
~
Code:
myserver:/ # telnet localhost 25
Trying 127.0.0.1...
Connected to localhost.
Escape character is '^]'.
220 myserver.mydomain.lv ESMTP Postfix
ehlo localhost
250-myserver.mydomain.lv
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-STARTTLS
250-AUTH PLAIN LOGIN
250-AUTH=PLAIN LOGIN
250 8BITMIME
quit
221 Bye
Connection closed by foreign host.
arditwbsrv:/etc #
What can be the problem?

Thank You!

POP3 and SMTP server is online (as it is said in ISP Server Status -> Services).

I have not installed courier-imap and courier-authlib because SUSE SLES 10.0 do not have such packages! I have cyrus-imap, fetchmail, popt, qpopper. I'm using postfix (not sendmail)!

Last edited by Mole; 12th May 2008 at 13:11.
Reply With Quote
Sponsored Links
  #2  
Old 12th May 2008, 19:22
catdude catdude is offline
Senior Member
 
Join Date: Jun 2007
Posts: 178
Thanks: 1
Thanked 12 Times in 11 Posts
Default

> mydestination = /etc/postfix/local-host-names

Is virtualdomain.lv in /etc/postfix/local_host_names?
Reply With Quote
  #3  
Old 12th May 2008, 19:27
Mole Mole is offline
Member
 
Join Date: Apr 2008
Location: Latvia
Posts: 83
Thanks: 1
Thanked 0 Times in 0 Posts
Default

No:
Code:
###################################
#
# ISPConfig local-host-names Configuration File
#         Version 1.0
#
###################################
localhost
myserver.mydomain.lv
localhost.myserver.mydomain.lv
localhost.mydomain.lv
#### MAKE MANUAL ENTRIES BELOW THIS LINE! ####
~
~
Should it be there? Then why ispconfig do not put it in?
Reply With Quote
  #4  
Old 12th May 2008, 19:51
catdude catdude is offline
Senior Member
 
Join Date: Jun 2007
Posts: 178
Thanks: 1
Thanked 12 Times in 11 Posts
Default

If virtualdomain.lv was created through the ISPConfig interface, then it should be there. Anyone have any suggestions as to why it might not be? I don't believe I've seen this behavior before myself.
Reply With Quote
  #5  
Old 12th May 2008, 20:31
Mole Mole is offline
Member
 
Join Date: Apr 2008
Location: Latvia
Posts: 83
Thanks: 1
Thanked 0 Times in 0 Posts
Default

it means, that for every site I've created (virtual domain, let's say, virtualdomain.lv, virtualdomain1.lv...virtualdomainx.lv), they should be in this file? Main domain is as You se - mydomain.lv, server = myserver.
Reply With Quote
  #6  
Old 12th May 2008, 20:43
catdude catdude is offline
Senior Member
 
Join Date: Jun 2007
Posts: 178
Thanks: 1
Thanked 12 Times in 11 Posts
Default

Let's say that your primary domain is, for example, mydomain.com. Let's also say that you have used the ISPConfig interface to create the domains custdomain1.com, secondcust.net, and mythirdcust.org.

Near the top of local-host-names you ought to see something like:
localhost
mydomain.com
localhost.localdomain
(possibly some other alternate names for your local host)
custdomain1.com
secondcust.net
mythirdcust.org

If you don't have those entries, I'm not sure what would be wrong. Perhaps Till or Falko can suggest where to look for the source of this problem.
Reply With Quote
  #7  
Old 12th May 2008, 22:05
Mole Mole is offline
Member
 
Join Date: Apr 2008
Location: Latvia
Posts: 83
Thanks: 1
Thanked 0 Times in 0 Posts
Default

it seems that it can be something wrong with ispconfig (I'm using v.2.2.23). Right now I discover that I can not allow MySQL DB to any site, ispconfig display's such error: You cannot assign MySQL databases to this website.

I'm using Suse SLES 10.1 64bit. I'm not using Novel Apparmor, SUEXEC for Apache (also in ispconfig SUEXEC is disabled) neither.
Reply With Quote
  #8  
Old 12th May 2008, 22:54
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,796
Thanks: 840
Thanked 5,612 Times in 4,423 Posts
Default

Please make sure that you allow enough mysql databases in the reseller settings and the website settings.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #9  
Old 12th May 2008, 23:23
Mole Mole is offline
Member
 
Join Date: Apr 2008
Location: Latvia
Posts: 83
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Thanks Till, it works - missed up allow Resseller create MySQL DB! ;-)

But error with e-mails remains...? ;-/
Reply With Quote
  #10  
Old 13th May 2008, 14:27
Mole Mole is offline
Member
 
Join Date: Apr 2008
Location: Latvia
Posts: 83
Thanks: 1
Thanked 0 Times in 0 Posts
 
Default

What can be the problem, that can not sent/receive e-mails from may e-mail users, defined in ispconfig?
Why in /etc/postfix/local-host-names there is only mywebserver and localhost, not other virtualdomains, as people said - they should be there?

in /home/admispconfig/ispconfig/lib/config.inc.php is defined:
Code:
$go_info["server"]["postfix_config"] = 2; // 1 = SENDMAIL-STYLE, 2 = POSTFIX-STYLE
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems with groups/grpconv linuxfast General 28 21st April 2008 10:35
Having Problems With Postfix ISPConfig - Sending & Receiving mails jeo_84 Installation/Configuration 1 4th March 2008 10:32
Management/system config/settings & /server/settings not working!! dactor Installation/Configuration 9 6th February 2008 10:11
SuSE + Postfix = some mails get lost v8hadas Installation/Configuration 4 29th November 2007 22:29
Empty Recycle Bin jon335 General 40 6th May 2006 12:56


All times are GMT +2. The time now is 03:37.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.