#31  
Old 3rd January 2009, 20:10
phreon phreon is offline
Junior Member
 
Join Date: Dec 2008
Posts: 16
Thanks: 2
Thanked 0 Times in 0 Posts
Default

netstat -tap

apache2: bad user name ${APACHE_RUN_USER}
al@ubuntuServer:~$ sudo netstat -tap
[sudo] password for al:
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 *:netbios-ssn *:* LISTEN 4432/smbd
tcp 0 0 ubuntuServer.Siesta:ipp *:* LISTEN 4162/cupsd
tcp 0 0 localhost:smtp *:* LISTEN 4415/exim4
tcp 0 0 *:microsoft-ds *:* LISTEN 4432/smbd
tcp6 0 0 [::]:ssh [::]:* LISTEN 4114/sshd
tcp6 0 0 ubuntuServer.Siesta:ssh 192.168.2.3%8191:60746 ESTABLISHED 4149/sshd: al [priv


apache2 -t

apache2: bad user name ${APACHE_RUN_USER}


Thanks
P
Reply With Quote
Sponsored Links
  #32  
Old 4th January 2009, 06:49
maksimu maksimu is offline
Junior Member
 
Join Date: Sep 2007
Posts: 5
Thanks: 0
Thanked 1 Time in 1 Post
Default

Yeah... same here..
i'm pretty sure that the problem is with Apache server... there is no user.

What is the right way of installing/configuring Apache server?
Reply With Quote
  #33  
Old 4th January 2009, 07:38
maksimu maksimu is offline
Junior Member
 
Join Date: Sep 2007
Posts: 5
Thanks: 0
Thanked 1 Time in 1 Post
Default

Also i think you should take out "$" from third line in (See below)

Quote:
Originally Posted by phreon View Post

Alias /backuppc /usr/share/backuppc/cgi-bin/

<Directory /usr/share/backuppc/cgi-bin/>
AllowOverride None $
Options ExecCGI FollowSymlinks
AddHandler cgi-script .cgi
DirectoryIndex index.cgi

AuthGroupFile /etc/backuppc/htgroup
AuthUserFile /etc/backuppc/htpasswd
AuthType basic
AuthName "BackupPC admin"
require valid-user

</Directory>


</VirtualHost>
Reply With Quote
  #34  
Old 4th January 2009, 07:56
maksimu maksimu is offline
Junior Member
 
Join Date: Sep 2007
Posts: 5
Thanks: 0
Thanked 1 Time in 1 Post
Default

Here is my third consecutive reply

I just made it working... I tried different things.. and I think this thing helped me to make it to work:

Code:
sudo APACHE_RUN_USER=www-data APACHE_RUN_GROUP=www-data apache2 -t
Found it HERE
Reply With Quote
  #35  
Old 4th January 2009, 12:32
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Does
Code:
sudo APACHE_RUN_USER=www-data APACHE_RUN_GROUP=www-data apache2 -t
show any errors?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
phreon (6th January 2009)
  #36  
Old 4th January 2009, 15:23
phreon phreon is offline
Junior Member
 
Join Date: Dec 2008
Posts: 16
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Hi Falko,

It Works !!

Using:

sudo APACHE_RUN_USER=www-data APACHE_RUN_GROUP=www-data apache2 -t

I got this error:

Syntax error on line 46 of /etc/apache2/sites-enabled/000-default:
Illegal override option $

So I used maksimu's suggestion from his post and removed the $ from the /etc/apache2/sites-available/default file.

I was able to get into BackupPC from my browser. It took my password and I can now continue to follow your tutorial. Seems funny that after all this time I am still on the beginning page!

The tutorial uses an older version of BackupPC. The current version appears to allow configuration through a browser GUI. Can the current backuppc version be set up through the GUI or does one need to edit the files as required in your tutorial?

Thanks so much for your help.
P

Last edited by phreon; 4th January 2009 at 16:10. Reason: Thought of a question
Reply With Quote
  #37  
Old 4th January 2009, 19:50
maksimu maksimu is offline
Junior Member
 
Join Date: Sep 2007
Posts: 5
Thanks: 0
Thanked 1 Time in 1 Post
Smile

Everything is fine with that tutorial.. just follow all instructions and it should work fine.

By the way, FYI, i had one small problem with smb connection, apparently there is a bug in newer versions of backuppc. The problem is backuppc connecting to Win Vista it's blocking connection. Just read THIS bug description and you will get the idea of that problem.

When I removed "-N" from $Conf{SmbClientFullCmd}, $Conf{SmbClientIncrCmd}, and $Conf{SmbClientRestoreCmd} it worked fine

Happy backuppc'ing
Reply With Quote
The Following User Says Thank You to maksimu For This Useful Post:
phreon (6th January 2009)
  #38  
Old 5th January 2009, 15:05
phreon phreon is offline
Junior Member
 
Join Date: Dec 2008
Posts: 16
Thanks: 2
Thanked 0 Times in 0 Posts
 
Default

My question really is that the latest backuppc seems to be configured through the browser GUI, and the version in the tutorial is configured by manually editing config files with a text editor?

Does the error you found effect Win XP?

Thanks
P
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Virtual Users And Domains With Ubuntu 8.04 mikeyr Suggest HOWTO 12 8th May 2009 15:47
On Ubuntu 8.04 LTS Server Setup chrisathowtoforge Technical 4 2nd June 2008 18:20
Problem on restart bind9 satimis Server Operation 6 30th October 2007 02:01
BackupPC Problem in Ubuntu - Feisty handband2 Installation/Configuration 1 10th May 2007 18:05
Log for Debugging jwan Installation/Configuration 5 27th October 2006 14:34


All times are GMT +2. The time now is 03:17.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.