Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 20th May 2008, 17:19
rtacconi rtacconi is offline
Junior Member
 
Join Date: Dec 2007
Posts: 23
Thanks: 0
Thanked 3 Times in 2 Posts
Default Backuppc Ubuntu 8.04

Hi,

I am following this tutorial http://www.howtoforge.com/linux_backuppc. I am trying to install backuppc on Ubuntu 8.04 desktop. I have tried this command: dpkg-reconfigure backuppc without any result. When I try to access http://host.domain.tld I get 404 not found. It seems to me that apache2 is not configured to use the backuppc directory.

Any help? Thanks.

Last edited by rtacconi; 21st May 2008 at 08:48. Reason: typo
Reply With Quote
Sponsored Links
  #2  
Old 21st May 2008, 11:54
rtacconi rtacconi is offline
Junior Member
 
Join Date: Dec 2007
Posts: 23
Thanks: 0
Thanked 3 Times in 2 Posts
Default apache2 site

I think I have to set the apache2 web server by hand :-) However the installer does not work.
__________________
PHP/Rails freelancer
Reply With Quote
  #3  
Old 21st May 2008, 13:02
rtacconi rtacconi is offline
Junior Member
 
Join Date: Dec 2007
Posts: 23
Thanks: 0
Thanked 3 Times in 2 Posts
Default The solution

This package was missing: libapache2-mod-perl2

Run:
Quote:
apt-get install libapache2-mod-perl2
Then:
Quote:
dpkg-reconfigure backuppc
Select "Apache2", "Ok" then if you want to change the password:
Quote:
htpasswd /etc/backuppc/htpasswd backuppc
Done!
__________________
PHP/Rails freelancer
Reply With Quote
The Following User Says Thank You to rtacconi For This Useful Post:
falko (21st May 2008)
  #4  
Old 23rd December 2008, 01:02
phreon phreon is offline
Junior Member
 
Join Date: Dec 2008
Posts: 16
Thanks: 2
Thanked 0 Times in 0 Posts
Default re: Ubuntu Server 8.04 Problem

Hi,
I downloaded the patch and then restarted backuppc. I still could not get to backuppc through the browser. I restarted backuppc and tried selecting apche2, apache-ssl, apache-perl, and apache from the menu. Nothing ... I then ps -aux to make sure backuppc was running. My browser window returns the error "The requested URL /backuppc/ was not found on this server."

Looks like I am getting to the server, but not to backuppc.
Any ideas what I can check?

Thanks
P

By the way I am about a month on Ubuntu Linux. Be gentle.
Reply With Quote
  #5  
Old 23rd December 2008, 15:02
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Is this still the default Apache configuration, or did you modify it?

Have you tried
Code:
dpkg-reconfigure backuppc
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 23rd December 2008, 20:06
phreon phreon is offline
Junior Member
 
Join Date: Dec 2008
Posts: 16
Thanks: 2
Thanked 0 Times in 0 Posts
Default Backuppc Ubuntu 8.04

Hi,
Thanks for the quick reply.

It looks like Apache2 is running. Yes I tried dpkg-reconfigure backuppc.
I have not done anything to Apache2. I wouldn't know what to do. I have only done exactly what the post suggested and I have only installed what the tutorial "www.howtoforge.com/linux_backuppc" suggested, i.e. "apt-get install backuppc rsync libfile-rsyncp-perl par2 smbfs".

I can get to my server from Firefox, but not to backuppc.

Is there something I can check?
Thanks
P
Reply With Quote
  #7  
Old 24th December 2008, 14:58
phreon phreon is offline
Junior Member
 
Join Date: Dec 2008
Posts: 16
Thanks: 2
Thanked 0 Times in 0 Posts
Default Backuppc Ubuntu 8.04

I reread my last post and it is not clear what I meant.

Apache2 is running on the Ubuntu 8.04 server. I have not tried to configure it.

Backuppc is running on the server. I did try, dpkg-reconfigure backuppc on the server.

From a Ubuntu client computer my I can get to the server by using its address. ie http://192.168.2.10.

I have not modified any config files but I did change my password through, htpasswd /etc/backuppc/htpasswd backuppc.

There is no windows or GUI installed on the server. I run it headless.

What can I check to find out why I cant get the backuppc login in my browser?

Thanks again for any help you can provide.
P
Reply With Quote
  #8  
Old 24th December 2008, 17:03
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Is there a backuppc folder in /usr/share?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 24th December 2008, 17:12
phreon phreon is offline
Junior Member
 
Join Date: Dec 2008
Posts: 16
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Hi Falco,

Yes there is a backuppc folder in /usr/share.
In it is ...
bin cgi-bin doc image lib

Thanks
P
Reply With Quote
  #10  
Old 25th December 2008, 11:05
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
 
Default

Is there something in there (or in the subfolders) that looks like an Apache configuration?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Virtual Users And Domains With Ubuntu 8.04 mikeyr Suggest HOWTO 12 8th May 2009 15:47
On Ubuntu 8.04 LTS Server Setup chrisathowtoforge Technical 4 2nd June 2008 18:20
Problem on restart bind9 satimis Server Operation 6 30th October 2007 02:01
BackupPC Problem in Ubuntu - Feisty handband2 Installation/Configuration 1 10th May 2007 18:05
Log for Debugging jwan Installation/Configuration 5 27th October 2006 14:34


All times are GMT +2. The time now is 05:47.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.