Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 18th May 2008, 21:20
kaixendog kaixendog is offline
Junior Member
 
Join Date: May 2008
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default "250-AUTH PLAIN LOGIN" instead of "250-AUTH LOGIN PLAIN"

In the Ubuntu 8.04 Perfect Server Howto; following the Postfix configuration; I telnet to port 25 and perform the "ehlo localhost" and the the following:

"250-AUTH PLAIN LOGIN" instead of "250-AUTH LOGIN PLAIN" as is listed in the Howto.

First question is, of course; Why did this happen / what caused this?
Second question is; how will this affect my Postfix server's functionality or will it?

I copied and pasted the commands into my SSH session, so I know the commands were typed verbatim. I'm setting up two servers, this being the second one, and the first one worked just as described in the Howto, but this second one (done about a week later) gives a different result.

Any help appreciated.
Reply With Quote
Sponsored Links
  #2  
Old 19th May 2008, 19:44
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

The order doesn't matter at all, so you can ignore this.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 7th July 2008, 01:53
omichaelshar omichaelshar is offline
Junior Member
 
Join Date: Jul 2008
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have been following the same tutorial and "ehlo local host" produces the following output:

250-AUTH PLAIN LOGIN CRAM-MD5 NTLM DIGEST-MD5
250-AUTH=PLAIN LOGIN CRAM-MD5 NTLM DIGEST-MD5

Is this an issue?

If so, how can I fix it?

Help gratefully appreciated....
Reply With Quote
  #4  
Old 7th July 2008, 18:18
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

What's in /etc/postfix/sasl/smtpd.conf?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 7th July 2008, 22:54
omichaelshar omichaelshar is offline
Junior Member
 
Join Date: Jul 2008
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

cat /etc/postfix/sasl/smtpd.conf

pwcheck_method: saslauthd
mechlist: plain login

Any suggestions?

Last edited by omichaelshar; 7th July 2008 at 22:55. Reason: orig incomplete
Reply With Quote
  #6  
Old 8th July 2008, 13:55
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Are you using Ubuntu 8.04?
What's the output of
Code:
netstat -tap
and
Code:
uname -a
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 8th July 2008, 23:52
omichaelshar omichaelshar is offline
Junior Member
 
Join Date: Jul 2008
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks Falko for your interest.

Yes, I am using Ubuntu 8.04. Clean install from ISO with OpenSSL, PostgreSQL and Samba. Then followed instructions in your tutorial perfect-server-ubuntu8.04-lts.

netstat -tap output below:
Code:
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 *:mysql                 *:*                     LISTEN      5657/mysqld
tcp        0      0 *:netbios-ssn           *:*                     LISTEN      5926/smbd
tcp        0      0 *:www                   *:*                     LISTEN      6084/apache2
tcp        0      0 2mar-fs02.2MAROO:domain *:*                     LISTEN      5542/named
tcp        0      0 localhost.locald:domain *:*                     LISTEN      5542/named
tcp        0      0 localhost.lo:postgresql *:*                     LISTEN      5735/postgres
tcp        0      0 *:smtp                  *:*                     LISTEN      5907/master
tcp        0      0 localhost.localdoma:953 *:*                     LISTEN      5542/named
tcp        0      0 *:https                 *:*                     LISTEN      6084/apache2
tcp        0      0 *:microsoft-ds          *:*                     LISTEN      5926/smbd
tcp6       0      0 [::]:imaps              [::]:*                  LISTEN      5808/couriertcpd
tcp6       0      0 [::]:pop3s              [::]:*                  LISTEN      5842/couriertcpd
tcp6       0      0 [::]:pop3               [::]:*                  LISTEN      5822/couriertcpd
tcp6       0      0 [::]:imap2              [::]:*                  LISTEN      5788/couriertcpd
tcp6       0      0 [::]:ftp                [::]:*                  LISTEN      6037/proftpd: (acce
tcp6       0      0 [::]:domain             [::]:*                  LISTEN      5542/named
tcp6       0      0 [::]:ssh                [::]:*                  LISTEN      5562/sshd
tcp6       0      0 [::]:smtp               [::]:*                  LISTEN      5907/master
tcp6       0      0 ip6-localhost:953       [::]:*                  LISTEN      5542/named
tcp6       0      0 2mar-fs02.2MAROOBA:ssh  192.168.0.101%8191:4097 ESTABLISHED 6113/sshd: omichael
uname -a output below:
Code:
Linux 2mar-fs02.2marooba 2.6.24-16-server #1 SMP Thu Apr 10 13:58:00 UTC 2008 i686 GNU/Linux
Reply With Quote
  #8  
Old 9th July 2008, 21:40
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
 
Default

What's the output of
Code:
updatedb
locate smtpd.conf
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Webmail problems with only one domain? compner Installation/Configuration 14 16th February 2010 16:59
dovecot problem sojic Server Operation 21 23rd March 2008 18:22
Unable to authenticate to SMTP server ashkev Installation/Configuration 15 6th February 2007 17:46
FC5 - Virtual Users Howto- SASL LOGIN Auth Failed nsurge HOWTO-Related Questions 6 22nd September 2006 03:39
Total Frustration-HELP palkat Installation/Configuration 17 3rd September 2005 17:28


All times are GMT +2. The time now is 21:33.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.