Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 1st February 2006, 13:03
bogdinator bogdinator is offline
Member
 
Join Date: Dec 2005
Posts: 58
Thanks: 0
Thanked 0 Times in 0 Posts
Exclamation Mail configuration issue

I am not quite sure whether this is an issue in my configuration of the ISPConfig or the fact of some routing/firewall settings in the university I am in.

I've installed ISPConfig on the machine which suppose to be serv as a department server (Mail, CVS, FTP, bla bla bla). I've setup the web for the department and crated users (I took out user prefix web[WEBID]_ and just used normal names like stephan, john etc. I don't think it's a problem because i know that I wont have same usernames in different webs - anywhay I've only one web for now)

What happens now is that I want to set up IMAP - should actually run by default if one goes after "The Perfect ... SUSE...". The name of the machine is "alpheratz" and the doumain it is in is "cpm.aca.mmu.ac.uk" So in the settings of ISPConfig I entered alpheratz as a host and cpm.aca.mmu.ac.uk as domain. Wright so for isn't it?

I couldn't connect via IMAP first because the box "Maildir" in the ISPConfig settings for email wasn't ticked. So I did this.
The weird thing is that ICPConfig proposes following email for john --> john@cpm.aca.mmu.ac.uk and not john@alpheratz.cpm.aca.mmu.ac.uk as I would assume from my knowledge
Now I can connect to the server and put some emails form other accounts with Thunderbird but if i send emails with it I am getting the following as reply in Thunderbird
Code:
This is the Postfix program at host alpheratz.cpm.aca.mmu.ac.uk.

I'm sorry to have to inform you that your message could not
be delivered to one or more recipients. It's attached below.

For further assistance, please send mail to <postmaster>

If you do so, please include this problem report. You can
delete your own text from the attached returned message.

			The Postfix program

<whoeveremailitis@mmu.ac.uk>: host load-balance-smtpin.mmu.ac.uk[149.170.190.144]
    said: 550 HELO/EHLO is invalid, domain alpheratz.cpm.aca.mmu.ac.uk is not
    permitted (in reply to RCPT TO command)



Reporting-MTA: dns; alpheratz.cpm.aca.mmu.ac.uk
X-Postfix-Queue-ID: C93DF27068
X-Postfix-Sender: rfc822; john@alpheratz.cpm.aca.mmu.ac.uk
Arrival-Date: Wed,  1 Feb 2006 11:27:18 +0000 (GMT)

Final-Recipient: rfc822; whoeveremailitis@mmu.ac.uk
Action: failed
Status: 5.0.0
Diagnostic-Code: X-Postfix; host load-balance-smtpin.mmu.ac.uk[149.170.190.144]
    said: 550 HELO/EHLO is invalid, domain alpheratz.cpm.aca.mmu.ac.uk is not
    permitted (in reply to RCPT TO command)
besides the /var/log/mail is full of these weird messages (this makes out nearly 80% of the log file)
Code:
Feb  1 11:54:36 alpheratz imapd: Failed to create cache file: maildirwatch (bogdan)
Feb  1 11:54:36 alpheratz imapd: Error: Input/output error
Feb  1 11:54:36 alpheratz imapd: Check for proper operation and configuration
Feb  1 11:54:36 alpheratz imapd: of the File Access Monitor daemon (famd).
and this is comming frequently
Code:
Feb  1 11:21:34 alpheratz postfix/smtpd[31161]: warning: connect to private/tlsmgr: No such file or directory
Feb  1 11:21:35 alpheratz postfix/smtpd[31161]: warning: connect to private/tlsmgr: No such file or directory
Feb  1 11:21:35 alpheratz postfix/smtpd[31161]: warning: problem talking to server private/tlsmgr: No such file or directory
Uni it guys told me that aAlpheratz already is allowed through the central gateways

Guys please need help! otherwise i'll be lynched in the course of this day
Reply With Quote
Sponsored Links
  #2  
Old 1st February 2006, 14:19
bogdinator bogdinator is offline
Member
 
Join Date: Dec 2005
Posts: 58
Thanks: 0
Thanked 0 Times in 0 Posts
Default

The same thing happens if I use POP protocol as well
Reply With Quote
  #3  
Old 1st February 2006, 14:35
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Quote:
Originally Posted by bogdinator
What happens now is that I want to set up IMAP - should actually run by default if one goes after "The Perfect ... SUSE...". The name of the machine is "alpheratz" and the doumain it is in is "cpm.aca.mmu.ac.uk" So in the settings of ISPConfig I entered alpheratz as a host and cpm.aca.mmu.ac.uk as domain. Wright so for isn't it?
That's correct.

Quote:
Originally Posted by bogdinator
I couldn't connect via IMAP first because the box "Maildir" in the ISPConfig settings for email wasn't ticked. So I did this.
The weird thing is that ICPConfig proposes following email for john --> john@cpm.aca.mmu.ac.uk and not john@alpheratz.cpm.aca.mmu.ac.uk as I would assume from my knowledge
Please check the Co-Domains tab. I bet you have cpm.aca.mmu.ac.uk there. If you don't need it, delete it.
Explanation: If you create a web site www.example.com, ISPConfig automatically creates the Co-Domain example.com because that's what most users want and expect. Therefore you have this Co-Domain cpm.aca.mmu.ac.uk even if you didn't create it yourself.

Quote:
Originally Posted by bogdinator
Now I can connect to the server and put some emails form other accounts with Thunderbird but if i send emails with it I am getting the following as reply in Thunderbird
Code:
This is the Postfix program at host alpheratz.cpm.aca.mmu.ac.uk.

I'm sorry to have to inform you that your message could not
be delivered to one or more recipients. It's attached below.

For further assistance, please send mail to <postmaster>

If you do so, please include this problem report. You can
delete your own text from the attached returned message.

			The Postfix program

<whoeveremailitis@mmu.ac.uk>: host load-balance-smtpin.mmu.ac.uk[149.170.190.144]
    said: 550 HELO/EHLO is invalid, domain alpheratz.cpm.aca.mmu.ac.uk is not
    permitted (in reply to RCPT TO command)



Reporting-MTA: dns; alpheratz.cpm.aca.mmu.ac.uk
X-Postfix-Queue-ID: C93DF27068
X-Postfix-Sender: rfc822; john@alpheratz.cpm.aca.mmu.ac.uk
Arrival-Date: Wed,  1 Feb 2006 11:27:18 +0000 (GMT)

Final-Recipient: rfc822; whoeveremailitis@mmu.ac.uk
Action: failed
Status: 5.0.0
Diagnostic-Code: X-Postfix; host load-balance-smtpin.mmu.ac.uk[149.170.190.144]
    said: 550 HELO/EHLO is invalid, domain alpheratz.cpm.aca.mmu.ac.uk is not
    permitted (in reply to RCPT TO command)
This looks as if it blocked by your university...
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #4  
Old 1st February 2006, 14:44
bogdinator bogdinator is offline
Member
 
Join Date: Dec 2005
Posts: 58
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks falko for the fast reply, I'll check the thing with our IT department and report shortly. I've deleted the co-domain (even don't know whot I would need it for).
Reply With Quote
  #5  
Old 1st February 2006, 14:55
bogdinator bogdinator is offline
Member
 
Join Date: Dec 2005
Posts: 58
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Is there any solution for this coming constantly in the mail-log

Code:
Feb  1 13:48:21 alpheratz pop3d: LOGIN, user=john, ip=[::ffff:149.170.198.6]
Feb  1 13:48:22 alpheratz pop3d: LOGOUT, user=john, ip=[::ffff:149.170.198.6], top=0, retr=7340, time=1
Feb  1 13:48:31 alpheratz imapd: Failed to create cache file: maildirwatch (john)
Feb  1 13:48:31 alpheratz imapd: Error: Input/output error
Feb  1 13:48:31 alpheratz imapd: Check for proper operation and configuration
Feb  1 13:48:31 alpheratz imapd: of the File Access Monitor daemon (famd).
Is it something I have to worry about?
Reply With Quote
  #6  
Old 1st February 2006, 16:34
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

As far as I know SuSE needs this famd otherwise POP3/IMAP fail. Please check if famd is running.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 1st February 2006, 17:55
bogdinator bogdinator is offline
Member
 
Join Date: Dec 2005
Posts: 58
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ok falco it was a long session in our IT department - these guy don't like people running their own things within universities :-)
here is the outcome of the exhausting conversation - we have and outgoing server load-balance-smtpout.mmu.ac.uk. I remember that when I've setup our old server (which will be replaced by the one I am setting up ISPConfig on) I configured sendmail.cf and entered there this server. Do I need to do something like this in ICPConfig or is it something I need to do in the intestines of SUSE?

As for the other problem - I can't find famd in /etc/init.d ! Is it something I have to install additionally? Why wasn't it mentioned in the HOWTO "The Perfect ...." Anyway will this
Code:
Failed to create cache file: maildirwatch (bogdan)
be sorted out together with famd?
Cheers for your appreciated HARD work!!!
Reply With Quote
  #8  
Old 1st February 2006, 18:15
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,777
Thanks: 821
Thanked 5,332 Times in 4,184 Posts
Default

Quote:
here is the outcome of the exhausting conversation - we have and outgoing server load-balance-smtpout.mmu.ac.uk. I remember that when I've setup our old server (which will be replaced by the one I am setting up ISPConfig on) I configured sendmail.cf and entered there this server. Do I need to do something like this in ICPConfig or is it something I need to do in the intestines of SUSE?
Add this line to your postfix main.cf:

relayhost = load-balance-smtpout.mmu.ac.uk

Code:
As for the other problem - I can't find famd in /etc/init.d ! Is it something I have to install additionally? Why wasn't it mentioned in the HOWTO "The Perfect ...."
To install famd (in the howto: yast -i courier-imap fam-server courier-authlib expect tcl):

yast -i fam-server

Quote:
Anyway will this
Code:
Failed to create cache file: maildirwatch (bogdan)
be sorted out together with famd?
Cheers for your appreciated HARD work!!!
maybe. Let us solve one problem after the other
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #9  
Old 2nd February 2006, 12:19
bogdinator bogdinator is offline
Member
 
Join Date: Dec 2005
Posts: 58
Thanks: 0
Thanked 0 Times in 0 Posts
Default

falco & till a big thanks goes to both of you!
Here is what I did and what solved some of the problems:
  1. installed famd (yast -i fam-server) which cleard mail-log from these nasty messages
    Code:
    Feb  1 11:54:36 alpheratz imapd: Failed to create cache file: maildirwatch (bogdan)
    Feb  1 11:54:36 alpheratz imapd: Error: Input/output error
    Feb  1 11:54:36 alpheratz imapd: Check for proper operation and configuration
    Feb  1 11:54:36 alpheratz imapd: of the File Access Monitor daemon (famd).
  2. added the relay server to the postfix main.cf (relayhost = load-balance-smtpout.mmu.ac.uk) which made me able to send emails

As we said we'll solve one problem at a time here is the some more work:
  1. I still have these messages in the mail-log every time I try to connect with my mail client (Thunderbird)
    Code:
    Feb  2 10:46:20 alpheratz postfix/smtp[23328]: warning: connect to private/tlsmgr: No such file or directory
    Feb  2 10:46:21 alpheratz postfix/smtp[23328]: warning: connect to private/tlsmgr: No such file or directory
    Feb  2 10:46:21 alpheratz postfix/smtp[23328]: warning: problem talking to server private/tlsmgr: No such file or directory
    Feb  2 10:46:21 alpheratz postfix/smtp[23328]: warning: no entropy for TLS key generation: disabling TLS support
  2. This is maybe obvious for you guys but I not for me - do I also need to enter the incomming server for postfix. I can send emails from it but I can't receive any. This is the bounce email I am getting:
    Code:
    This message was created automatically by mail delivery software.
    
    A message that you sent could not be delivered to one or more of its
    recipients. This is a permanent error. The following address(es) failed:
    
      bogdan@alpheratz.cpm.aca.mmu.ac.uk
        Sorry, bogdan@alpheratz.cpm.aca.mmu.ac.uk is not recognised by mmu.ac.uk.
    
    ------ This is a copy of the message, including all the headers. ------
    
    Return-path: <eric@mmu.ac.uk>
    Received: from [149.170.188.2] (helo=anak.ayt.adm.mmu.ac.uk)
    	by majorforbes.isu.mmu.ac.uk with esmtp (Exim 4.41)
    	id 1F4c7j-0000VB-B4
    	for john@alpheratz.cpm.aca.mmu.ac.uk; Thu, 02 Feb 2006 10:55:35 +0000
    Received: from [149.170.198.6] (voyager.cpm.aca.mmu.ac.uk [149.170.198.6])
    	by anak.ayt.adm.mmu.ac.uk with ESMTP; Thu, 02 Feb 2006 10:55:10 +0000
    Message-ID: <43E1E532.6040800@mmu.ac.uk>
    Date: Thu, 02 Feb 2006 10:55:46 +0000
    From: Eric Mold <eric@mmu.ac.uk>
    User-Agent: Mozilla Thunderbird 1.0 (X11/20041207)
    X-Accept-Language: en-us, en
    MIME-Version: 1.0
    To: Bogdan Werth <john@alpheratz.cpm.aca.mmu.ac.uk>
    Subject: Re: just test
    References: <43E1E45B.1080607@alpheratz.cpm.aca.mmu.ac.uk>
    In-Reply-To: <43E1E45B.1080607@alpheratz.cpm.aca.mmu.ac.uk>
    Content-Type: text/plain; charset=ISO-8859-1; format=flowed
    Content-Transfer-Encoding: 7bit
    X-MMU-Signature: 379635f56aeebc356a6afe253c902bc5
    X-MMU-DBG: disclaimer checking - acl_m0 exists (external recipients)
  3. This is not so important for me but for the people in my department - all the folders like Sent, Trash, etc. are going out of the Inbox in Thunderbird and are not separately placed like on the old server
  4. Is it enough just to make a tape backup of /home/www/web6 to backup all mails fo the users in the web6. I know that with sendmail I also needed to save the /var folder. How is it solved in ISPConfig?
Reply With Quote
  #10  
Old 2nd February 2006, 12:39
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
 
Default

Quote:
Originally Posted by bogdinator
[*]I still have these messages in the mail-log every time I try to connect with my mail client (Thunderbird)
Code:
Feb  2 10:46:20 alpheratz postfix/smtp[23328]: warning: connect to private/tlsmgr: No such file or directory
Feb  2 10:46:21 alpheratz postfix/smtp[23328]: warning: connect to private/tlsmgr: No such file or directory
Feb  2 10:46:21 alpheratz postfix/smtp[23328]: warning: problem talking to server private/tlsmgr: No such file or directory
Feb  2 10:46:21 alpheratz postfix/smtp[23328]: warning: no entropy for TLS key generation: disabling TLS support
Have a look here: http://www.howtoforge.com/forums/showthread.php?t=781

Quote:
Originally Posted by bogdinator
[*]This is maybe obvious for you guys but I not for me - do I also need to enter the incomming server for postfix. I can send emails from it but I can't receive any. This is the bounce email I am getting:
Code:
This message was created automatically by mail delivery software.

A message that you sent could not be delivered to one or more of its
recipients. This is a permanent error. The following address(es) failed:

  bogdan@alpheratz.cpm.aca.mmu.ac.uk
    Sorry, bogdan@alpheratz.cpm.aca.mmu.ac.uk is not recognised by mmu.ac.uk.

------ This is a copy of the message, including all the headers. ------

Return-path: <eric@mmu.ac.uk>
Received: from [149.170.188.2] (helo=anak.ayt.adm.mmu.ac.uk)
	by majorforbes.isu.mmu.ac.uk with esmtp (Exim 4.41)
	id 1F4c7j-0000VB-B4
	for john@alpheratz.cpm.aca.mmu.ac.uk; Thu, 02 Feb 2006 10:55:35 +0000
Received: from [149.170.198.6] (voyager.cpm.aca.mmu.ac.uk [149.170.198.6])
	by anak.ayt.adm.mmu.ac.uk with ESMTP; Thu, 02 Feb 2006 10:55:10 +0000
Message-ID: <43E1E532.6040800@mmu.ac.uk>
Date: Thu, 02 Feb 2006 10:55:46 +0000
From: Eric Mold <eric@mmu.ac.uk>
User-Agent: Mozilla Thunderbird 1.0 (X11/20041207)
X-Accept-Language: en-us, en
MIME-Version: 1.0
To: Bogdan Werth <john@alpheratz.cpm.aca.mmu.ac.uk>
Subject: Re: just test
References: <43E1E45B.1080607@alpheratz.cpm.aca.mmu.ac.uk>
In-Reply-To: <43E1E45B.1080607@alpheratz.cpm.aca.mmu.ac.uk>
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: 7bit
X-MMU-Signature: 379635f56aeebc356a6afe253c902bc5
X-MMU-DBG: disclaimer checking - acl_m0 exists (external recipients)
This seems to be another issue that you should discuss with your IT department. Seems as if they block something more...

Quote:
Originally Posted by bogdinator
[*]This is not so important for me but for the people in my department - all the folders like Sent, Trash, etc. are going out of the Inbox in Thunderbird and are not separately placed like on the old server
Can you explain this a little more in detail?

Quote:
Originally Posted by bogdinator
[*]Is it enough just to make a tape backup of /home/www/web6 to backup all mails fo the users in the web6. I know that with sendmail I also needed to save the /var folder. How is it solved in ISPConfig?
If you use Maildir, then it's enough to save /home/www/web6. If you use mbox, you must also save /var/spool/mail.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Cant get mail after applying the update 2.1.2 mphayesuk Installation/Configuration 2 31st December 2008 14:48
Filtering emails using Spamassassin and Clamav for Exchange 2000 Server Rocky Server Operation 19 11th March 2008 08:27
Postfix mail is held in queue indefinitely... squallbsr Server Operation 9 15th January 2006 19:13
Mail server jas_esp Server Operation 1 7th December 2005 18:17
Mail Configuration mphayesuk General 1 12th September 2005 13:16


All times are GMT +2. The time now is 20:44.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.