Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 2nd February 2006, 19:21
Rocky Rocky is offline
Senior Member
 
Join Date: Oct 2005
Posts: 553
Thanks: 14
Thanked 49 Times in 48 Posts
Default

My main.cf looks like this:

# See /usr/share/postfix/main.cf.dist for a commented, more complete version

smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

myhostname = server1.mcrirents.org
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
mydestination = server1.mcrirents.org, localhost, localhost.localdomain
relayhost =
mynetworks = 127.0.0.0/8
mailbox_command = procmail -a "$EXTENSION"
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
virtual_alias_domains =
virtual_alias_maps = proxy:mysql:/etc/postfix/mysql-virtual_forwardings.cf, proxy:mysql:/etc/postfix/mysql-virtual_email2emai
l.cf
virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql-virtual_domains.cf
virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailboxes.cf
virtual_mailbox_base = /home/vmail
virtual_uid_maps = static:5000
virtual_gid_maps = static:5000
smtpd_sasl_auth_enable = yes
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination
smtpd_use_tls = yes
smtpd_tls_cert_file = /etc/postfix/smtpd.cert
smtpd_tls_key_file = /etc/postfix/smtpd.key
transport_maps = proxy:mysql:/etc/postfix/mysql-virtual_transports.cf
virtual_create_maildirsize = yes
virtual_mailbox_extended = yes
virtual_mailbox_limit_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailbox_limit_maps.cf
virtual_mailbox_limit_override = yes
virtual_maildir_limit_message = "The user you are trying to reach is over quota."
virtual_overquota_bounce = yes
proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virt
ual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $re
located_maps $transport_maps $mynetworks $virtual_mailbox_limit_maps
content_filter = amavis:[127.0.0.1]:10024
receive_override_options = no_address_mappings
Reply With Quote
Sponsored Links
  #12  
Old 2nd February 2006, 21:58
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,722 Times in 2,563 Posts
Default

Ok, I guess these linebreaks are only in this forum, not in your file:
Quote:
Originally Posted by Rocky
proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virt
ual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $re
located_maps $transport_maps $mynetworks $virtual_mailbox_limit_maps
What's in /etc/postfix/mysql-virtual_transports.cf?
Also, can you try to comment out
Code:
receive_override_options = no_address_mappings
in /etc/postfix/main.cf and restart Postfix?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #13  
Old 2nd February 2006, 22:35
Rocky Rocky is offline
Senior Member
 
Join Date: Oct 2005
Posts: 553
Thanks: 14
Thanked 49 Times in 48 Posts
Default

My mysql-virtual_transports.cf looks like this:

user = mail_admin
password = xxxxxxx
dbname = mail
table = transport
select_field = transport
where_field = domain
hosts = 127.0.0.1

I tried to comment out 'receive_override_options = no_address_mappings' but received the following:
Permanent Failure: 550_<malli@mcrirents.com>:_Recipient_address_rejec ted:_User_unknown_in_virtual_mailbox_table

Last edited by Rocky; 2nd February 2006 at 22:38.
Reply With Quote
  #14  
Old 2nd February 2006, 23:46
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,722 Times in 2,563 Posts
Default

Can you double-check all your configuration files and compare them with the ones from the tutorial? Maybe you have a typo or something like this somewhere...
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #15  
Old 3rd February 2006, 02:13
Rocky Rocky is offline
Senior Member
 
Join Date: Oct 2005
Posts: 553
Thanks: 14
Thanked 49 Times in 48 Posts
Default

I've compared my 6 config files and all seems correct. I did copy and paste the config information. I don't know what else could be wrong.

Last edited by Rocky; 7th February 2006 at 02:28.
Reply With Quote
  #16  
Old 7th February 2006, 02:28
Rocky Rocky is offline
Senior Member
 
Join Date: Oct 2005
Posts: 553
Thanks: 14
Thanked 49 Times in 48 Posts
Default

Would it be better for me just to create all the mail users manually? Also, how do I lower the lever of spam identification?
Reply With Quote
  #17  
Old 7th February 2006, 09:54
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,722 Times in 2,563 Posts
Default

Quote:
Originally Posted by Rocky
Would it be better for me just to create all the mail users manually?
You mean on the command line, without tools as phpMyAdmin? That makes no difference.

Quote:
Originally Posted by Rocky
Also, how do I lower the lever of spam identification?
You can change that in the amavisd configuration file /etc/amavisd.conf, towards the end. Restart amavisd afterwards.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #18  
Old 8th February 2006, 02:40
Rocky Rocky is offline
Senior Member
 
Join Date: Oct 2005
Posts: 553
Thanks: 14
Thanked 49 Times in 48 Posts
Default

What i meant was since the virtual setup is not allowing mails to pass through without the users being created, should i create the users or would it be better to try a re-install?

My setup is as follows:
Hosting domain is domainC
I have domainA entered in the domian table
I have smtp:[192.168.0.xx] entered in the transport table

If i didn't create the virtual users, shouldn't the server catch mails going to domainA and pass it over to my exchange? Or does it only work if the users are added to the virtual table?
Reply With Quote
  #19  
Old 8th February 2006, 10:56
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,722 Times in 2,563 Posts
Default

The transports worked for me without users being created...
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #20  
Old 8th February 2006, 19:50
Rocky Rocky is offline
Senior Member
 
Join Date: Oct 2005
Posts: 553
Thanks: 14
Thanked 49 Times in 48 Posts
 
Question

Falko I know that I'm being a pain about this setup but I really would like to implement this in my organizaton.

I reloaded the server and tried the following config:
Domain = domainA
Transport = domainA -> smtp:[192.168.0.xx]
This produced the error, the user does not exist in the virtual user table.

I then tried:
Domain = domainA
Transport = domainA -> smtp:[192.168.0.xx]
Forwarding = @domainA -> @domainA
This config allowed mails to be filtered and passed to my exchange without creating the users.

I checked my confiuration thorougly and every setting/configuraton seems correct. The question is, would my second configuration work without causing any problems?

I will eventually be filtering mails for domainA and domainB which will then be routed to my exchange server through the transport.

I was able to figure out how to change the spamassassin level check, thanks to you.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota... killfrog HOWTO-Related Questions 3 25th September 2009 21:45
Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, SpamAs ruskicar HOWTO-Related Questions 26 20th July 2007 16:28
Backup the Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Qu rogierbanis HOWTO-Related Questions 1 13th January 2006 09:34
Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, SpamAs amilcar HOWTO-Related Questions 1 1st January 2006 17:12
Virtual Users And Domains With Postfix, Courier And MySQL (+ SMTP-AUTH, Quota, SpamAs pontifex HOWTO-Related Questions 2 26th October 2005 17:54


All times are GMT +2. The time now is 17:44.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.