Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 12th May 2008, 21:01
jasmith86 jasmith86 is offline
Junior Member
 
Join Date: May 2008
Posts: 2
Thanks: 2
Thanked 0 Times in 0 Posts
Default mysql_connect() warning when logging into ISPConfig

I have followed the Perfect Server setup guide for Ubuntu 8.04 Server (http://howtoforge.com/perfect-server-ubuntu8.04-lts). My issue is that when I try to log into the ISPConfig Control Panel, I get the following error message (I can get to the login page, but it shows this message once I type in my username/password):

Code:
Warning: mysql_connect() [function.mysql-connect]: Host 'XXXX.comcast.net' is not allowed to connect to this MySQL server in /home/admispconfig/ispconfig/lib/classes/ispconfig_db_mysql.lib.php on line 77

Warning: mysql_connect() [function.mysql-connect]: Host 'XXXX.comcast.net' is not allowed to connect to this MySQL server in /home/admispconfig/ispconfig/lib/classes/ispconfig_db_mysql.lib.php on line 77

Warning: Cannot modify header information - headers already sent by (output started at /home/admispconfig/ispconfig/lib/classes/ispconfig_db_mysql.lib.php:77) in /home/admispconfig/ispconfig/web/login/login.php on line 60
I tend to think that I have entered in something into ISPConfig incorrectly during the setup process (database password or maybe database name), but I am honestly stuck. I tried looking around the forums and searching in Google, but really did not find anyone with this same issue.
As far as I can tell, mysql is up and running -- this is what netstat puts out
Code:
# netstat -tap | grep mysql
tcp        0      0 *:mysql                 *:*                     LISTEN      14677/mysqld
# netstat -tap | grep isp
tcp        0      0 *:81                    *:*                     LISTEN      11280/ispconfig_htt
What can I do to make sure that ISPConfig is using the correct username/password/database name to communicate with mysql? Is there something else that is more likely to be the problem?
Thanks in advance!
Reply With Quote
Sponsored Links
  #2  
Old 12th May 2008, 21:53
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,977
Thanks: 825
Thanked 5,369 Times in 4,216 Posts
Default

I guess you entered the wrong hostname for the mysql server during setup. Please change the mysql hostanme to "localhost" in the file /home/admispconfig/ispconfig/lib/config.inc.php
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
jasmith86 (12th May 2008)
  #3  
Old 12th May 2008, 21:54
catdude catdude is offline
Senior Member
 
Join Date: Jun 2007
Posts: 178
Thanks: 1
Thanked 12 Times in 11 Posts
Default

I'd recommend taking a look inside /home/admispconfig/ispconfig/lib/config.inc.php to see that the proper values are specified for the database. Specifically, you might want to look at:
$go_info["server"]["db_host"]
$go_info["server"]["db_name"]
$go_info["server"]["db_user"]
$go_info["server"]["db_password"]
$go_info["server"]["db_type"]
Reply With Quote
The Following User Says Thank You to catdude For This Useful Post:
jasmith86 (12th May 2008)
  #4  
Old 12th May 2008, 23:19
jasmith86 jasmith86 is offline
Junior Member
 
Join Date: May 2008
Posts: 2
Thanks: 2
Thanked 0 Times in 0 Posts
 
Default

Thanks! I just changed the settings in that file and everything seems to be working now.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Exim4 Debian Etch issues lordshadow Server Operation 35 7th May 2008 20:24
Apache Ownership cybereatl General 2 26th March 2008 12:25
Need help with ATI's graphics driver installer Wraithfire Installation/Configuration 25 16th June 2007 13:33
Warning on ispconfig start bin-online General 4 3rd March 2006 20:11
Logging in to IspConfig naj General 2 4th December 2005 13:43


All times are GMT +2. The time now is 00:00.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.