#1  
Old 11th May 2008, 07:27
v2k v2k is offline
Member
 
Join Date: Sep 2007
Location: Vancouver, Canada
Posts: 93
Thanks: 3
Thanked 1 Time in 1 Post
Default sendmail stopped working

running fc7.

from the logs /var/log/maillog : Connection refused by [127.0.0.1]

Code:
telnet localhost 25
fails to connect

iptables:
Code:
 /etc/init.d/iptables status
Table: filter
Chain INPUT (policy ACCEPT)
num  target     prot opt source               destination
1    RH-Firewall-1-INPUT  all  --  0.0.0.0/0            0.0.0.0/0

Chain FORWARD (policy ACCEPT)
num  target     prot opt source               destination
1    REJECT     all  --  0.0.0.0/0            0.0.0.0/0           reject-with icmp-host-prohibited

Chain OUTPUT (policy ACCEPT)
num  target     prot opt source               destination

Chain RH-Firewall-1-INPUT (1 references)
num  target     prot opt source               destination
1    ACCEPT     all  --  0.0.0.0/0            0.0.0.0/0
2    ACCEPT     icmp --  0.0.0.0/0            0.0.0.0/0           icmp type 255
3    ACCEPT     esp  --  0.0.0.0/0            0.0.0.0/0
4    ACCEPT     ah   --  0.0.0.0/0            0.0.0.0/0
5    DROP       udp  --  0.0.0.0/0            224.0.0.251         udp dpt:5353
6    DROP       udp  --  0.0.0.0/0            0.0.0.0/0           udp dpt:631
7    DROP       tcp  --  0.0.0.0/0            0.0.0.0/0           tcp dpt:631
8    ACCEPT     all  --  0.0.0.0/0            0.0.0.0/0           state RELATED,ESTABLISHED
9    ACCEPT     tcp  --  0.0.0.0/0            0.0.0.0/0           state NEW tcp dpt:22
10   DROP       tcp  --  0.0.0.0/0            0.0.0.0/0           state NEW tcp dpt:25
11   DROP       tcp  --  0.0.0.0/0            0.0.0.0/0           tcp dpt:110
12   ACCEPT     tcp  --  0.0.0.0/0            0.0.0.0/0           state NEW tcp dpt:80
13   REJECT     all  --  0.0.0.0/0            0.0.0.0/0           reject-with icmp-host-prohibited
Reply With Quote
Sponsored Links
  #2  
Old 11th May 2008, 07:39
v2k v2k is offline
Member
 
Join Date: Sep 2007
Location: Vancouver, Canada
Posts: 93
Thanks: 3
Thanked 1 Time in 1 Post
Default

changing
Code:
10   DROP       tcp  --  0.0.0.0/0            0.0.0.0/0           state NEW tcp dpt:25
to accept on 25 doesn't help... turning off iptables doesnt allow me to telnet to localhost on 25 either.
Reply With Quote
  #3  
Old 11th May 2008, 07:44
v2k v2k is offline
Member
 
Join Date: Sep 2007
Location: Vancouver, Canada
Posts: 93
Thanks: 3
Thanked 1 Time in 1 Post
Default

hosts.allow contains:
ALL:127.0.0.1

and hosts.deny contains:
ALL: ALL EXCEPT localhost
Reply With Quote
  #4  
Old 11th May 2008, 07:54
v2k v2k is offline
Member
 
Join Date: Sep 2007
Location: Vancouver, Canada
Posts: 93
Thanks: 3
Thanked 1 Time in 1 Post
Default

This ended up fixing it:
Code:
 /etc/init.d/postfix start
Any idea why this didn't do it itself on startup -- or perhaps it stopped at some time and needed to be restarted?
Reply With Quote
  #5  
Old 12th May 2008, 00:12
chipsafts chipsafts is offline
Senior Member
 
Join Date: Nov 2007
Posts: 184
Thanks: 2
Thanked 6 Times in 6 Posts
Default

postfix is not sendmail
Reply With Quote
  #6  
Old 12th May 2008, 00:42
v2k v2k is offline
Member
 
Join Date: Sep 2007
Location: Vancouver, Canada
Posts: 93
Thanks: 3
Thanked 1 Time in 1 Post
 
Default

sendmail wasn't working and this fixed it.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Fedora 4 TPS mail problem Hagforce HOWTO-Related Questions 13 10th February 2010 18:23
Postfix/STMP abruptly stopped working XMG-Eric Server Operation 12 7th November 2008 13:48
Samba stopped working today dangeorge6 Server Operation 1 10th February 2007 20:42
UebiMiau stopped working after Apache reinstall shajazzi Installation/Configuration 6 18th February 2006 19:42
Web pages just stopped working ! skeeta Installation/Configuration 1 28th August 2005 19:30


All times are GMT +2. The time now is 23:54.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.