Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 6th May 2008, 18:57
hugoc hugoc is offline
Junior Member
 
Join Date: May 2008
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default Howto setup SiS190 Ethernet - not working for me

Hi to all,

I'm trying to setup a new computer, with the following configuration:

* Motherboard ASUS P5SD2-VM
* 2 CPU Core Duo
* SiS968 Southbridge
* SiS672 Northbridge
* Ethernet card SiS191-based

Now, almost everything works, except the network card.

I found the howto of howtoforge.org about the setup of this card, and used it. But the card still doesn't work.

When I insmod the new module, I get the output on the attached file "output_sis190.txt"

I'm using Slackware 12 with a vanilla kernel 2.6.22, as the howto says.

By the way, when I edited the "sis190.c" file, the piece of code that I must edit doesn't look the same as in the howto. You can see it in the attached file "code_sis190.txt"

Thanks for any opinion .
Attached Files
File Type: txt output_sis190.txt (835 Bytes, 428 views)
File Type: txt code_sis190.txt (553 Bytes, 432 views)
Reply With Quote
Sponsored Links
  #2  
Old 6th May 2008, 20:34
hugoc hugoc is offline
Junior Member
 
Join Date: May 2008
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

As you can see in "output_sis190", the card is detected, but when the system tries to configure it, I got a "link is not ready" message...
Reply With Quote
  #3  
Old 7th May 2008, 17:41
hugoc hugoc is offline
Junior Member
 
Join Date: May 2008
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi again,

I just tried a 2.6.25 vanilla kernel, and I got this output:

ACPI: PCI interrupt for device 0000:00:04.0 disabled
ACPI: PCI Interrupt 0000:00:04.0[A] -> GSI 19 (level, low) -> IRQ 19
PCI: Setting latency timer of device 0000:00:04.0 to 64
0000:00:04.0: Read MAC address from EEPROM
0000:00:04.0: Error EEPROM read 0.
0000:00:04.0: Read MAC address from APC.
0000:00:04.0: Unknown PHY transceiver at address 1.
0000:00:04.0: SiS 191 PCI Gigabit Ethernet adapter at f8e1ec00 (IRQ: 19), 00:1e:8c:a7:1f:8e
eth0: GMII mode.
eth0: Enabling Auto-negotiation.
ADDRCONF(NETDEV_UP): eth0: link is not ready

Seems to be a kernel problem, maybe the card is NOT supported
Reply With Quote
  #4  
Old 8th May 2008, 00:24
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,745 Times in 2,578 Posts
Default

Hm... Do you see the card in the output of
Code:
lspci
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 8th May 2008, 17:49
hugoc hugoc is offline
Junior Member
 
Join Date: May 2008
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Here is the output of "lspci":

00:00.0 Host bridge: Silicon Integrated Systems [SiS] Unknown device 0671
00:01.0 PCI bridge: Silicon Integrated Systems [SiS] SiS AGP Port (virtual PCI-t o-PCI bridge)
00:02.0 ISA bridge: Silicon Integrated Systems [SiS] SiS968 [MuTIOL Media IO] (r ev 01)
00:02.5 IDE interface: Silicon Integrated Systems [SiS] 5513 [IDE] (rev 01)
00:03.0 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 0f)
00:03.1 USB Controller: Silicon Integrated Systems [SiS] USB 1.0 Controller (rev 0f)
00:03.3 USB Controller: Silicon Integrated Systems [SiS] USB 2.0 Controller
00:04.0 Ethernet controller: Silicon Integrated Systems [SiS] 191 Gigabit Ethern et Adapter (rev 02)
00:05.0 IDE interface: Silicon Integrated Systems [SiS] SATA Controller / IDE mo de (rev 03)
00:06.0 PCI bridge: Silicon Integrated Systems [SiS] PCI-to-PCI bridge
00:07.0 PCI bridge: Silicon Integrated Systems [SiS] PCI-to-PCI bridge
00:0d.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139 C+ (rev 10)
00:0f.0 Audio device: Silicon Integrated Systems [SiS] Azalia Audio Controller
00:1f.0 PCI bridge: Silicon Integrated Systems [SiS] PCI-to-PCI bridge
01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS] 771/671 PCIE VGA Display Adapter (rev 10)

As you can see, the ISA line and the Ethernet line looks just like in the HOWTO (chipset 968 and 191 Gigabit Ethernet). But the solution of the howto doesn't work.
Reply With Quote
  #6  
Old 8th May 2008, 22:57
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,745 Times in 2,578 Posts
 
Default

Strange...
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
howto setup a linux box to have 2 internet link load balance? earth3 Installation/Configuration 2 3rd January 2014 06:56
Trouble with Postfix setup not working wmkconn Server Operation 13 9th April 2008 22:45
Question regarding PHP setup in Ubuntu 6.06 LAMP install Howto FXT HOWTO-Related Questions 1 23rd August 2007 19:53
howto setup a 2nd webserver for static content Ovidiu Suggest HOWTO 2 22nd December 2006 08:44
Is there a howto to setup gmail and imap? iith096 Installation/Configuration 2 8th September 2006 20:57


All times are GMT +2. The time now is 15:06.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.