Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 29th January 2006, 23:37
ayolo ayolo is offline
Junior Member
 
Join Date: Jan 2006
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default imap and pop connection failed (debian sarge)

Hi,
I followed your "howto" without any error I think but I can't perform connection to my imap or pop server.
I tried several combination for login but it doesn't work.

Code:
telnet 127.0.0.1 110
Trying 127.0.0.1...
Connected to 127.0.0.1.
Escape character is '^]'.
+OK Hello there.
user ayolo@ayolo.org
+OK Password required.
pass ******
-ERR Login failed.
Code:
telnet 127.0.0.1 110
Trying 127.0.0.1...
Connected to 127.0.0.1.
Escape character is '^]'.
+OK Hello there.
user ayolo@localhost.localdomain
+OK Password required.
pass ******
-ERR Login failed.
Code:
telnet 127.0.0.1 110
Trying 127.0.0.1...
Connected to 127.0.0.1.
Escape character is '^]'.
+OK Hello there.
user ayolo
+OK Password required.
pass ******
-ERR Login failed.
It's the same problem with the imap server.
If any body has an idea it would be nice.

Ayolo
Reply With Quote
Sponsored Links
  #2  
Old 30th January 2006, 07:59
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,509
Thanks: 815
Thanked 5,269 Times in 4,130 Posts
Default

PLease have a look at your mail.log, did you get any errors there? Do you have the courier packages installed or the pop3 / imap packages for mbox format?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 30th January 2006, 09:16
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Which tutorial (URL?) are you referring to?

Did you try to send a mail to that account before you tried to login with POP3? Sometimes that helps because the mailbox is only created when the first email arrives.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #4  
Old 30th January 2006, 16:19
ayolo ayolo is offline
Junior Member
 
Join Date: Jan 2006
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Thank you for your answers,
I check my /var/log/mail.log
and I found that :
Code:
Jan 30 15:06:29 localhost courierpop3login: Connection, ip=[::ffff:127.0.0.1]
Jan 30 15:06:43 localhost authdaemond.mysql: authmysql: mysql_select_db(provider) error: Access denied for user: 'provider_admin@localhost' to database 'provider'
Jan 30 15:06:48 localhost courierpop3login: LOGIN FAILED, ip=[::ffff:127.0.0.1]
Jan 30 15:06:50 localhost courierpop3login: LOGOUT, ip=[::ffff:127.0.0.1]
Jan 30 15:16:09 localhost authdaemond.mysql: restarting authdaemond children
Jan 30 15:16:09 localhost authdaemond.mysql: modules="authpam", daemons=5
Jan 30 15:16:09 localhost authdaemond.mysql: modules="authpam", daemons=5
Jan 30 15:16:23 localhost courierpop3login: Connection, ip=[::ffff:127.0.0.1]
Jan 30 15:16:32 localhost courierpop3login: LOGIN, user=ayolo, ip=[::ffff:127.0.0.1]
So I finaly understood that even with apt-get remove --purge courier-imap courier-pop courier-imap-ssl courier-pop-ssl
some files where not cleaned so when I followed your howto (here) there were conflicts with my last installation.
I just erase the file /etc/courier/authdaemonrc after apt-get remove --purge courier-imap courier-pop courier-imap-ssl courier-pop-ssl and I follow again your howto and now everything is ok.

I'm realy sorry for "my stupidity" but without your suggestion : "PLease have a look at your mail.log" I was not able to find the solution.

Moreover, I would like to say "thank you" to the website www.howtoforge.com and all it's members because first your guide are clear and easy and because when you ask for some help, you've got answers very quick.

Ayolo
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 07:34.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.