Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 30th April 2008, 15:16
M0rF3uS M0rF3uS is offline
Junior Member
 
Join Date: Apr 2008
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default amavis error with postfix-mysql

Hi there,

i've some troubles with amavis and postfix on debian etch, in my log i got:

Code:
Apr 30 14:08:21 localhost amavis[1931]: (01931-04) (!!) TROUBLE in check_mail: parts_decode_ext FAILED: run_command (open pipe): Can't fork at /usr/lib/perl/5.8/IO/File.pm line 70. (Cannot allocate memory) at /usr/sbin/amavisd-new line 2216.
Apr 30 14:08:21 localhost amavis[1931]: (01931-04) (!) PRESERVING EVIDENCE in /var/lib/amavis/tmp/amavis-20080430T140821-01931
so mails goes in queue but never delivered.

i followed this -> http://howtoforge.com/virtual_postfi..._quota_courier
could you help me?
thx
Reply With Quote
Sponsored Links
  #2  
Old 30th April 2008, 15:33
M0rF3uS M0rF3uS is offline
Junior Member
 
Join Date: Apr 2008
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

update:

could it be for low memory?

Mem: 262336k total, 251660k used, 10676k free, 1496k buffers

(used by spamd and amavis, but i've no traffic on the moment on the server lol)
Reply With Quote
  #3  
Old 30th April 2008, 16:29
M0rF3uS M0rF3uS is offline
Junior Member
 
Join Date: Apr 2008
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

solved: i installed dphys-swapfile to create a swap space so amavis can check e deliver mails
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
postfix problems with smtp linkdeb Server Operation 13 15th March 2014 18:58
Mail System Error - Returned Mail tristanlee85 General 16 16th March 2008 10:40
Management/system config/settings & /server/settings not working!! dactor Installation/Configuration 9 6th February 2008 10:11
Centos 4.4 32bit Hangs, High Server load 3cwired_com Server Operation 11 16th November 2006 16:47
Verify email setup meekish Installation/Configuration 28 27th October 2006 16:36


All times are GMT +2. The time now is 23:33.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.