Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 26th April 2008, 01:12
TheBirdMan TheBirdMan is offline
Junior Member
 
Join Date: Apr 2008
Posts: 27
Thanks: 8
Thanked 2 Times in 2 Posts
Default ISPConfig not resolving web pages

Hi,

I have a new install of ispconfig but when I test my client by pointing only to the new ispconfig server as dns it does not resolve names to itself as it should. What did I miss?

here is my netstat :
[root@ns ~]# netstat -tap
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 localhost:2208 *:* LISTEN 2275/hpiod
tcp 0 0 *:mysql *:* LISTEN 2747/mysqld
tcp 0 0 localhost:783 *:* LISTEN 2350/spamd.pid
tcp 0 0 *:sunrpc *:* LISTEN 2087/portmap
tcp 0 0 *:hosts2-ns *:* LISTEN 2780/ispconfig_http
tcp 0 0 localhost:domain *:* LISTEN 3111/named
tcp 0 0 localhost:ipp *:* LISTEN 2292/cupsd
tcp 0 0 localhost:rndc *:* LISTEN 3111/named
tcp 0 0 *:smtp *:* LISTEN 3081/master
tcp 0 0 *:1018 *:* LISTEN 2108/rpc.statd
tcp 0 0 localhost:2207 *:* LISTEN 2280/python
tcp 1 0 ns.mydomain:36801 mirrors.tummy.com:http CLOSE_WAIT 2543/python
tcp 0 0 ns.mydomain:53947 12.37.74.43:http TIME_WAIT -
tcp 1 0 ns.mydomain:49268 wiki.fedoraproject.org:http CLOSE_WAIT 2543/python
tcp 0 0 ns.mydomain:58812 157.238.197.42:http TIME_WAIT -
tcp 0 0 ns.mydomain:50369 77.67.126.25:http TIME_WAIT -
tcp 1 0 ns.mydomain:35176 hpc-mirror.usc.edu:http CLOSE_WAIT 2543/python
tcp 0 0 *:imaps *:* LISTEN 2331/dovecot
tcp 0 0 *op3s *:* LISTEN 2331/dovecot
tcp 0 0 *op3 *:* LISTEN 2331/dovecot
tcp 0 0 *:imap *:* LISTEN 2331/dovecot
tcp 0 0 *:http *:* LISTEN 3001/httpd
tcp 0 0 *:ftp *:* LISTEN 3132/proftpd: (acce
tcp 0 0 ::1:domain *:* LISTEN 3111/named
tcp 0 0 *:ssh *:* LISTEN 2306/sshd
tcp 0 0 ::1:rndc *:* LISTEN 3111/named
tcp 0 0 *:https *:* LISTEN 3001/httpd

Ps- thanks for all the help, I have never gotten Microsoft support like this.
Reply With Quote
Sponsored Links
  #2  
Old 26th April 2008, 11:05
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,698
Thanks: 819
Thanked 5,319 Times in 4,172 Posts
Default

You must set a DNS A-Record pointing to the IP address of your server on the dns server that is authoritive for this domain. The authoritive server is not nescessarily your own server, it might be the dns server of the company were you registered the domain.

Also be aware that it may take up to 48 hours until changes in the dns system become active.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 29th April 2008, 18:52
TheBirdMan TheBirdMan is offline
Junior Member
 
Join Date: Apr 2008
Posts: 27
Thanks: 8
Thanked 2 Times in 2 Posts
Default

Hi,

I setup a test domain along with a name server pointing to the ISPConfig server and it is still not working. I tried "telnet localhost 53" on the server I am connected. If I telnet 192.168.1.10 53 (its eth0) it does not connect.

Scott
Reply With Quote
  #4  
Old 30th April 2008, 16:18
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
Default

What's the output of
Code:
netstat -tap
and
Code:
iptables -L
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 30th April 2008, 17:34
TheBirdMan TheBirdMan is offline
Junior Member
 
Join Date: Apr 2008
Posts: 27
Thanks: 8
Thanked 2 Times in 2 Posts
Default

Hi Falko,

Here is what I have:

netstat -tap

Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 localhost:2208 *:* LISTEN 2277/hpiod
tcp 0 0 *:mysql *:* LISTEN 2749/mysqld
tcp 0 0 localhost:783 *:* LISTEN 2352/spamd.pid
tcp 0 0 *:sunrpc *:* LISTEN 2089/portmap
tcp 0 0 *:hosts2-ns *:* LISTEN 2799/ispconfig_http
tcp 0 0 localhost:domain *:* LISTEN 2068/named
tcp 0 0 localhost:ipp *:* LISTEN 2294/cupsd
tcp 0 0 *:smtp *:* LISTEN 2412/master
tcp 0 0 localhost:rndc *:* LISTEN 2068/named
tcp 0 0 *:1020 *:* LISTEN 2110/rpc.statd
tcp 0 0 localhost:2207 *:* LISTEN 2282/python
tcp 0 0 *:imaps *:* LISTEN 2333/dovecot
tcp 0 0 *op3s *:* LISTEN 2333/dovecot
tcp 0 0 *op3 *:* LISTEN 2333/dovecot
tcp 0 0 *:imap *:* LISTEN 2333/dovecot
tcp 0 0 *:http *:* LISTEN 2449/httpd
tcp 0 0 *:ftp *:* LISTEN 2425/proftpd: (acce
tcp 0 0 ::1:domain *:* LISTEN 2068/named
tcp 0 0 *:ssh *:* LISTEN 2308/sshd
tcp 0 0 ::1:rndc *:* LISTEN 2068/named
tcp 0 0 *:https *:* LISTEN 2449/httpd
tcp 0 1332 ::ffff:192.168.5.51:ssh ::ffff:192.168.6.83:1321 ESTABLISHED 3049/1


iptables -L

Chain INPUT (policy ACCEPT)
target prot opt source destination

Chain FORWARD (policy ACCEPT)
target prot opt source destination

Chain OUTPUT (policy ACCEPT)
target prot opt source destination
Reply With Quote
  #6  
Old 1st May 2008, 20:37
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
Default

BIND is listening on localhost only. What's in your named.conf?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 2nd May 2008, 17:15
TheBirdMan TheBirdMan is offline
Junior Member
 
Join Date: Apr 2008
Posts: 27
Thanks: 8
Thanked 2 Times in 2 Posts
Default

1) I have a named.conf under /var/named/chroot

options {
pid-file "/var/named/chroot/var/run/named/named.pid";
directory "/home/admispconfig/ispconfig/web/multidoc/edit";
auth-nxdomain no;
/*
* If there is a firewall between you and nameservers you want
* to talk to, you might need to uncomment the query-source
* directive below. Previous versions of BIND always asked
* questions using port 53, but BIND 8.1 uses an unprivileged
* port by default.
*/
// query-source address * port 53;
};

//
// a caching only nameserver config
//
zone "." {
type hint;
file "named.ca";
};

zone "0.0.127.in-addr.arpa" {
type master;
file "named.local";
};

zone "144.104.70.in-addr.arpa" {
type master;
file "pri.144.104.70.in-addr.arpa";
};
zone "5.168.192.in-addr.arpa" {
type master;
file "pri.5.168.192.in-addr.arpa";
};


zone "mydomain1.com" {
type master;
file "pri.mydomain1.com";
};
zone "mydomain2.com" {
type master;
file "pri.mydomain2.com";
};
zone "mydomain3.com" {
type master;
file "pri.mydomain3.com";
};



2) I also have a named.caching-nameserver.conf which is the only one under /etc

//
// named.caching-nameserver.conf
//
// Provided by Red Hat caching-nameserver package to configure the
// ISC BIND named(8) DNS server as a caching only nameserver
// (as a localhost DNS resolver only).
//
// See /usr/share/doc/bind*/sample/ for example named configuration files.
//
// DO NOT EDIT THIS FILE - use system-config-bind or an editor
// to create named.conf - edits to this file will be lost on
// caching-nameserver package upgrade.
//
options {
listen-on port 53 { 127.0.0.1; };
listen-on-v6 port 53 { ::1; };
directory "/var/named";
dump-file "/var/named/data/cache_dump.db";
statistics-file "/var/named/data/named_stats.txt";
memstatistics-file "/var/named/data/named_mem_stats.txt";
query-source port 53;
query-source-v6 port 53;
allow-query { localhost; };
};
logging {
channel default_debug {
file "data/named.run";
severity dynamic;
};
};
view localhost_resolver {
match-clients { localhost; };
match-destinations { localhost; };
recursion yes;
include "/etc/named.rfc1912.zones";
};
Reply With Quote
  #8  
Old 3rd May 2008, 20:58
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
Default

I guess this is the crucial line:
Code:
listen-on port 53 { 127.0.0.1; };
But I'm not sure why it's using named.caching-nameserver.conf...
Which distribution are you using? did you set up the system according to one of the "Perfect Setups"?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 3rd May 2008, 21:26
TheBirdMan TheBirdMan is offline
Junior Member
 
Join Date: Apr 2008
Posts: 27
Thanks: 8
Thanked 2 Times in 2 Posts
Default

I used the "perfect setup" for fedora 6.

These are the ISPConfig directories in the settings page:
/var/named/chroot/etc/named.conf
/home/admispconfig/ispconfig/web/multidoc/edit

I don't know if ISPConfig is even using /etc/named.caching-nameserver.conf I t was the only named file under /etc so I listed it.

The only other referance I can find to the localhost is:
/home/admispconfig/ispconfig/web/multidoc/edit/named.local
;
; BIND data file for local loopback interface
;
$TTL 604800
@ IN SOA localhost. root.localhost. (
1 ; Serial
604800 ; Refresh
86400 ; Retry
2419200 ; Expire
604800 ) ; Negative Cache TTL
;
@ IN NS localhost.
@ IN A 127.0.0.1
Reply With Quote
  #10  
Old 4th May 2008, 17:55
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
 
Default

Please restart Bind. Do you get any errors then?
What''s the output of
Code:
netstat -tap
afterwards?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't login into ispconfig web control interface angelika Installation/Configuration 10 18th May 2008 14:54
ISPConfig running on default web server (port 80) geek.de.nz Installation/Configuration 3 31st March 2008 10:32
Page not found on ISPCONFIG web Philip_Anselmo Installation/Configuration 3 28th March 2006 10:37
Web pages just stopped working ! skeeta Installation/Configuration 1 28th August 2005 19:30
Web pages just stopped working ! skeeta Installation/Configuration 1 28th August 2005 19:17


All times are GMT +2. The time now is 14:27.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.