Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 23rd April 2008, 23:23
White White is offline
Member
 
Join Date: Apr 2008
Posts: 65
Thanks: 0
Thanked 0 Times in 0 Posts
Default Virtual Users And Domains With Postfix, Courier And MySQL (Debian Etch)

Ok, in order to make this how to work for me at all i had to remove the proxy: from the mysql statements in main.cf

virtual_mailbox_maps=proxy:mysql:/etc/postfix/mysql-virtual_mailboxes.cf

and make it look like this

virtual_mailbox_maps=mysql:/etc/postfix/mysql-virtual_mailboxes.cf

which is copied from Christoph Haas's tutorial falko has linked to in his tutorial.

and figure out that if i have virtual domains example.com and example2.com then my server is still mail.mydomain.tld for all my virtual domains.

The system is now creating mailboxes for domains i have created in mysql there are a couple of problems im encountering now,

i can send and receive emails from my virtualusers@mydomain.tld using mail.mydomain.tld and i can send emails to my new virtualdomains.com to activate them.

i can mail in to mydomain.tld from outside my network but if i send a mail to my@example1.com and my@example2.com then somewhere from the other day is a cached email forwarding address that i inputted wrong and the emails fail and get returned to the external email address. Does anyone know in which file or db these cached addresses are so i can delete it, and no its not in mysql mail database. see below

from hotmail mailer-daemon

wronguser@hotmail.com(generated from admin@example1.com)SMTP error from remote mail server after RCPT TO:<wronguser@hotmail.com>:host mx3.hotmail.com [65.54.244.200]: 550 Requested action not taken:mailbox unavailable

now from this line above i think in know that this domain is working (generated from admin@example1.com)

and i have my@example3.com working and sending and receiving emails into and out of my network so it has to be this hidden cached file from the other day.

Hope what i have done might work for others who have difficulty with this how to aswell but like always no guarantees.
Reply With Quote
Sponsored Links
  #2  
Old 24th April 2008, 16:28
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
Default

Did you check the forwards table?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 24th April 2008, 20:22
White White is offline
Member
 
Join Date: Apr 2008
Posts: 65
Thanks: 0
Thanked 0 Times in 0 Posts
Default

yes, i completely emptied maildb and filled it up from fresh, twice (i only have half a dozen sites so it didnt take long)

i know it was the first time as the 2nd and 3rd times i populated the db i put nothing in the forwards or transport tables.

in your tutorial it says that postfix caches the emails but you can speed this up by doing $ postfix reload

im wondering if there is a file somewhere where these cached email accounts get stored that i can manually view and if need be clear.

as i say only 2 of my accounts fail due to this wronguser@hotmail.com, all the others are now sending and receiving emails perfectly
Reply With Quote
  #4  
Old 25th April 2008, 17:02
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
Default

Did you restart Postfix?

I don't know if Postfix is using files to cache, I rather think it's caching in memory.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 25th April 2008, 18:27
White White is offline
Member
 
Join Date: Apr 2008
Posts: 65
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Important: Postfix uses a caching mechanism for the transports, therefore it might take a while until you changes in the transport table take effect. If you want them to take effect immediately, run

postfix reload

am i getting this mixed up with something else?

i have done the postfix reload many times, my server is not fully operational yet and is turned off every evening so all programs reload from boot each day as i play with it.

i may start again and do a clean install tonight if no one has any suggestions, either way its a good practise for me.
Reply With Quote
  #6  
Old 26th April 2008, 13:48
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
Default

What's in /etc/postfix/main.cf and /etc/aliases?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 27th April 2008, 12:43
White White is offline
Member
 
Join Date: Apr 2008
Posts: 65
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

There was nothing in either file that was untoward.

I spent yesterday and did a clean install and now i have it working flawlessly, this is what i have done

followed debian etch perfect server setup but only to the hostname and hostname -f

i did NO updates, i then followed the virtual users and domains setup but not to the letter, i deleted the proxy: as mentioned in my first post and added my home pc 192.168.1.3 to the mynetworks.

i manually inputted my domains into phpmyadmin not using mysql shell but placed nothing in transports or email2email

i sent each account an opening message from my main user account me@mydomain.com and all opened new files in /home/vmail.

only when i was convinced everything was ok did i allow the system to update

i then went back to debian server and copied some extra files for mysql, php and apache2 but nothing for postfix or courier.

this may not be the right way to do it, i dont know but its the only way with my very limited knowledge i could get it to work.

my server seems to be happy now, which is a first, and so i can now get on with sorting out my sites. its been a good learning experience anyway.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Question on Virtual Users And Domains With Postfix, Courier And MySQL (Debian Etch) Horizon HOWTO-Related Questions 12 26th February 2008 20:22
Virtual Users And Domains With Postfix, Courier And MySQL (Debian Etch) ShadyB HOWTO-Related Questions 1 2nd November 2007 18:23
Virtual Users And Domains With Postfix, Courier And MySQL (Debian Etch) - Page 5 MisterVlad HOWTO-Related Questions 1 2nd November 2007 14:11
Virtual Users And Domains With Postfix, Courier And MySQL (Debian Etch) mcg HOWTO-Related Questions 2 25th July 2007 16:00
Virtual Users And Domains With Postfix, Courier And MySQL & debian etch Tortanick HOWTO-Related Questions 5 19th June 2007 12:29


All times are GMT +2. The time now is 20:09.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.