Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 7th May 2008, 06:19
lordshadow lordshadow is offline
Member
 
Join Date: Apr 2008
Posts: 89
Thanks: 0
Thanked 0 Times in 0 Posts
Default DNS Bind9 in Debian Etch

Hi,

I'm trying to get my server to recognize it's domain name name so I created an internal DNS server which I'm trying to point to the domain optiplex-networks.tk, through browser I want www.optiplex-networks.tk to resolve.

This works fine through WAN as DNS server comes off site where I got the domain name from.

However in my internal network it doesn't resolve which is why I'm doing this!

My zone file looks like this:

Code:
;
; BIND data file for example.com
;
$TTL    604800
@       IN      SOA     optiplex-networks.tk. info.optiplex-networks.tk. (
                            2008051605         ; Serial
                                  7200         ; Refresh
                                   120         ; Retry
                               2419200         ; Expire
                                604800)        ; Default TTL
;
@       IN      NS      ns1.optiplex-networks.tk.
#@       IN      NS      ns2.example.com.
optiplex-networks.tk.    IN      MX      10      mail.optiplex-networks.tk.
optiplex-networks.tk.    IN      A       192.168.1.51
www                     IN      CNAME   optiplex-networks.tk.
mail                    IN      A       192.168.1.51
ftp                     IN      CNAME   ftp.optiplex-networks.tk.
optiplex-networks.tk.   IN      TXT     "v=spf1 ip4:192.168.1.51 a mx ~all"
mail                    IN      TXT     "v=spf1 a -all"
and I have added this to named.conf.local:

Code:
zone "optiplex-networks.tk" {
       type master;
       file "/var/named/optiplex-netowrks.db";
};

zone "1.168.192.IN-ADDR.ARPA" {
       type master;
       file "/var/named192.168.1.rev";
};
however this sort of works internally from server: http://optiplex-networks.tk resolves but www.optiplex-networks.tk doesn't and from anyother computer on the network it doesn't resolve at all!

Can any one help?
Reply With Quote
Sponsored Links
  #2  
Old 7th May 2008, 06:22
lordshadow lordshadow is offline
Member
 
Join Date: Apr 2008
Posts: 89
Thanks: 0
Thanked 0 Times in 0 Posts
Default

~sorry I based the DNS and Bind setup on this howto: http://howtoforge.com/perfect_setup_debian_etch_p4
Reply With Quote
  #3  
Old 7th May 2008, 17:49
lordshadow lordshadow is offline
Member
 
Join Date: Apr 2008
Posts: 89
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ok I managed to get this one working. It was a simple case of editing the resolv.conf and hosts files. Also a little DNS zone forwarding through my Cisco router and I have perfect intranet functionality.

However from outside (WAN) I can't access ftp.optiplex-networks.tk??

I don't understand why as I registered the name optiplex-networks.tk. It's a free domain name so that maybe the reason why WAN DNS queries aren't found but I would've thought that through reverse lookup in my server's DNS server and routers DNS server that internet hosts would find it??

Maybe someone could explain domain hosting to me in the relevant areas so I understand better?
Reply With Quote
  #4  
Old 8th May 2008, 21:31
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Code:
mh1:~# dig ftp.optiplex-networks.tk

; <<>> DiG 9.3.4 <<>> ftp.optiplex-networks.tk
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 63911
;; flags: qr rd ra; QUERY: 1, ANSWER: 5, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;ftp.optiplex-networks.tk.      IN      A

;; ANSWER SECTION:
ftp.optiplex-networks.tk. 300   IN      A       193.33.61.2
ftp.optiplex-networks.tk. 300   IN      A       209.172.59.193
ftp.optiplex-networks.tk. 300   IN      A       217.115.151.98
ftp.optiplex-networks.tk. 300   IN      A       195.20.32.104
ftp.optiplex-networks.tk. 300   IN      A       217.119.57.19

;; Query time: 205 msec
;; SERVER: 213.133.98.98#53(213.133.98.98)
;; WHEN: Thu May  8 21:30:17 2008
;; MSG SIZE  rcvd: 122

mh1:~#
That hostname is pointing to multiple IP addresses. Are these all your servers?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 9th May 2008, 02:26
lordshadow lordshadow is offline
Member
 
Join Date: Apr 2008
Posts: 89
Thanks: 0
Thanked 0 Times in 0 Posts
Default

These servers are not mine, in fact my server is located at 81.178.2.118!

The thing is I can't understand why it isn't working as I registered the domain name optiplex-networks.tk. I'm not the owner and that maybe why this is happening but I fail to understand why I'm able to access www.optiplex-networks.tk and not anything else with it?
Reply With Quote
  #6  
Old 9th May 2008, 05:29
snewp snewp is offline
Junior Member
 
Join Date: Apr 2008
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Default

remove this:
ftp IN CNAME ftp.optiplex-networks.tk.

you can have:
ftp IN CNAME www

or

ftp IN A IP address
Reply With Quote
  #7  
Old 9th May 2008, 05:48
lordshadow lordshadow is offline
Member
 
Join Date: Apr 2008
Posts: 89
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ok I changed the format to:

ftp IN CNAME www

I don't currently have access to another internet line so I don't know if anyone could check to see if it works or not?
Reply With Quote
  #8  
Old 9th May 2008, 15:16
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Still not ok:

Code:
mh1:~# dig ftp.optiplex-networks.tk

; <<>> DiG 9.3.4 <<>> ftp.optiplex-networks.tk
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 38954
;; flags: qr rd ra; QUERY: 1, ANSWER: 5, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;ftp.optiplex-networks.tk.      IN      A

;; ANSWER SECTION:
ftp.optiplex-networks.tk. 300   IN      A       217.119.57.19
ftp.optiplex-networks.tk. 300   IN      A       193.33.61.2
ftp.optiplex-networks.tk. 300   IN      A       195.20.32.104
ftp.optiplex-networks.tk. 300   IN      A       209.172.59.193
ftp.optiplex-networks.tk. 300   IN      A       217.115.151.98

;; Query time: 365 msec
;; SERVER: 213.133.98.98#53(213.133.98.98)
;; WHEN: Fri May  9 15:15:29 2008
;; MSG SIZE  rcvd: 122

mh1:~#
But I see that there are no DNS server defined for the domain:

Code:
mh1:~# dig ns optiplex-networks.tk

; <<>> DiG 9.3.4 <<>> ns optiplex-networks.tk
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 23858
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;optiplex-networks.tk.          IN      NS

;; Query time: 147 msec
;; SERVER: 213.133.98.98#53(213.133.98.98)
;; WHEN: Fri May  9 15:15:39 2008
;; MSG SIZE  rcvd: 38

mh1:~#
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 9th May 2008, 15:23
lordshadow lordshadow is offline
Member
 
Join Date: Apr 2008
Posts: 89
Thanks: 0
Thanked 0 Times in 0 Posts
Default

hmm, internally it works fine as ns1.optiplex-networks.tk resolves to my Cisco router also my server??

What information could I provide that will help get me to a solution?
Reply With Quote
  #10  
Old 9th May 2008, 20:00
snewp snewp is offline
Junior Member
 
Join Date: Apr 2008
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

it would be better to have your own domain.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Google Apps dayjahone General 19 29th March 2008 17:25
Perfect setup Debian Etch ISPConfig - DNS Server kdclaver Installation/Configuration 16 28th December 2007 01:39
DNS: installing Master and slave dns server on debian Etch SHELLHOSTER Installation/Configuration 1 28th October 2007 15:08
dns failure perfect set up debian etch howto gdowrey HOWTO-Related Questions 1 23rd September 2007 20:18
Bind Failed christoph2k HOWTO-Related Questions 4 28th April 2007 00:57


All times are GMT +2. The time now is 06:42.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.