#1  
Old 21st April 2008, 03:58
allensim81 allensim81 is offline
Junior Member
 
Join Date: Apr 2008
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default Simple Mail Server

Hi
I am a newbie in setting up a simple mail server for testing purpose.I set up 2 machines,1 i used it as Quaranteen system & AntiSpam server, whilst another 1 i used it as mail server installed wth openLdap,pam,dovecot & sendmail.
Now i can succeccfully send mail and receive mail within 2 users. But my AntiSpam & Quaranteen seems been isolated!

My problem now is how can i send a mail that the mail will go through my Quaranteen & AntiSpam server first then followed by mail server.

Please... help me & guide me... appreciate for ur comments....
Thanks
Reply With Quote
Sponsored Links
  #2  
Old 21st April 2008, 05:22
tonton01 tonton01 is offline
Junior Member
 
Join Date: Feb 2008
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I'm not familiar with sendmail so I can't help you with any configurations but I can try to point you in the right direction (I hope ).

it sounds like you are directing all your mail to go straight to your mail server first. So nothing is passing through the spam server. You must direct port 25 on your router to point to the spam server and configure the spam server to relay your mail to the mail server. Not sure if your spam server is configured as a router or not. But regardless, the general idea is that incoming and/or outgoing mail must be routed to the filtering server first before it reaches the mail server.

Hope that helps.
Reply With Quote
  #3  
Old 21st April 2008, 05:37
allensim81 allensim81 is offline
Junior Member
 
Join Date: Apr 2008
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi, tonton01
u get exactly what i mean....

But how to direct the port 25 on router to point to the spam server and configure the spam server to relay your mail to the mail server?
Reply With Quote
  #4  
Old 21st April 2008, 16:10
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,749 Times in 2,579 Posts
 
Default

Quote:
Originally Posted by allensim81
Hi, tonton01
u get exactly what i mean....

But how to direct the port 25 on router to point to the spam server
You can do this in your router's web interface.

Quote:
Originally Posted by allensim81
and configure the spam server to relay your mail to the mail server?
You can tell the mail server to fetch mails from the spam filter with fetchmail or getmail, or you forward the mails from the spam filter with Postfix transports:
Code:
man 5 transport
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
php Apps email not going through palkat General 8 21st September 2011 06:35
The Perfect Setup - Debian Etch (Debian 4.0) some trouble daniel80 HOWTO-Related Questions 26 1st February 2008 17:30
setting up a antispam mail server - i have a few questions alexnz Installation/Configuration 1 21st November 2006 17:07
Server name change stops webmail working shajazzi Installation/Configuration 3 16th May 2006 17:00
Webmail Relay Error palkat General 17 23rd April 2006 19:12


All times are GMT +2. The time now is 06:55.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.