Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 17th April 2008, 04:35
webwork webwork is offline
Junior Member
 
Join Date: Apr 2008
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Smile NEW INSTALL WORKS GREAT BUT a few issues

Fresh install of Fedora 8, And it all works except for the following:
1) The services page shows the Web-Server: Offline , but it works great and is serving up pages fine, sites are greated fine and pointing properly, i am also getting e-mails which say: WARNING: service web not running (server: www.xxxxxx.com
2) On the system config section common tab there is nothing there. All other sections appear operational though
3) Error messages on the last part of install (shown below)

rm -f unix_.c
cc -o unzipsfx unzipsfx.o crc32.o crctab_.o crypt_.o extract_.o fileio_.o globals_.o inflate_.o match_.o process_.o ttyio_.o unix_.o -s
mv: cannot move `binaries/ispconfig_tcpserver' to `ispconfig/tools/tcpserver/ispconfig_tcpserver': No such file or directory
All prerequisites are fulfilled.
Here we go...
Please enter your MySQL server:localhost
OK
Please enter your MySQL user:
Please enter your MySQL password:
OK
Please enter a name for the ISPConfig database (e.g. db_ispconfig):ispconfigdb
Please enter the IP address of the ISPConfig web (e.g. 192.168.0.1):192.168.1.11
OK
Please enter the host name (e.g. www):XXXXX(REMOVED)
Please enter the domain (e.g. xyz.de):XXXXXl.com
OK
Please select the protocol (http or https (SSL encryption)) to use to access the ISPConfig system:
1) HTTPS
2) HTTP
Your Choice: 2

chown: cannot access `/home/admispconfig/ispconfig/backup': No such file or directory
chmod: cannot access `/home/admispconfig/ispconfig/backup': No such file or directory
chmod: cannot access `/home/admispconfig/ispconfig/tools/tcpserver/ispconfig_tcpserver': No such file or directory
chown: cannot access `/home/admispconfig/ispconfig/tools/tcpserver/ispconfig_tcpserver': No such file or directory
Connected successfully to MySQL server
no crontab for root
Restarting some services...
Shutting down postfix: [ OK ]
Starting postfix: [ OK ]
Shutting down proftpd: [ OK ]
Starting proftpd: [ OK ]
Starting ISPConfig system...
/root/ispconfig/httpd/bin/apachectl startssl: httpd started
ISPConfig system is now up and running!
Congratulations! Your ISPConfig system is now installed. If you had to install quota, please take the steps described in the installation manual. Otherwise your system is now available without reboot.
Please direct your browser to

ANY HELP IS APPRECIATED
Reply With Quote
Sponsored Links
  #2  
Old 17th April 2008, 20:46
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,726 Times in 2,565 Posts
Default

Quote:
Originally Posted by webwork
Fresh install of Fedora 8, And it all works except for the following:
1) The services page shows the Web-Server: Offline , but it works great and is serving up pages fine, sites are greated fine and pointing properly, i am also getting e-mails which say: WARNING: service web not running (server: www.xxxxxx.com
I guess your Apache is not listening on 127.0.0.1. What's the output of
Code:
netstat -tap
?


Quote:
Originally Posted by webwork
3) Error messages on the last part of install (shown below)

rm -f unix_.c
cc -o unzipsfx unzipsfx.o crc32.o crctab_.o crypt_.o extract_.o fileio_.o globals_.o inflate_.o match_.o process_.o ttyio_.o unix_.o -s
mv: cannot move `binaries/ispconfig_tcpserver' to `ispconfig/tools/tcpserver/ispconfig_tcpserver': No such file or directory
All prerequisites are fulfilled.
Here we go...
Please enter your MySQL server:localhost
OK
Please enter your MySQL user:
Please enter your MySQL password:
OK
Please enter a name for the ISPConfig database (e.g. db_ispconfig):ispconfigdb
Please enter the IP address of the ISPConfig web (e.g. 192.168.0.1):192.168.1.11
OK
Please enter the host name (e.g. www):XXXXX(REMOVED)
Please enter the domain (e.g. xyz.de):XXXXXl.com
OK
Please select the protocol (http or https (SSL encryption)) to use to access the ISPConfig system:
1) HTTPS
2) HTTP
Your Choice: 2

chown: cannot access `/home/admispconfig/ispconfig/backup': No such file or directory
chmod: cannot access `/home/admispconfig/ispconfig/backup': No such file or directory
chmod: cannot access `/home/admispconfig/ispconfig/tools/tcpserver/ispconfig_tcpserver': No such file or directory
chown: cannot access `/home/admispconfig/ispconfig/tools/tcpserver/ispconfig_tcpserver': No such file or directory
Connected successfully to MySQL server
no crontab for root
Restarting some services...
Shutting down postfix: [ OK ]
Starting postfix: [ OK ]
Shutting down proftpd: [ OK ]
Starting proftpd: [ OK ]
Starting ISPConfig system...
/root/ispconfig/httpd/bin/apachectl startssl: httpd started
ISPConfig system is now up and running!
Congratulations! Your ISPConfig system is now installed. If you had to install quota, please take the steps described in the installation manual. Otherwise your system is now available without reboot.
Please direct your browser to

ANY HELP IS APPRECIATED
Are you using ProFTPd or vsftpd? What's the output of
Code:
df -h
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 18th April 2008, 02:38
webwork webwork is offline
Junior Member
 
Join Date: Apr 2008
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Talking Hi Falco, these are the the lines, what do you think??

Hi Falco, these are the the lines, what do you think??

netstat -tap
root@support ~]# netstat -tap
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
tcp 0 0 *:mysql *:* LISTEN 2198/mysqld
tcp 0 0 *:sunrpc *:* LISTEN 1853/rpcbind
tcp 0 0 *:hosts2-ns *:* LISTEN 2664/ispconfig_http
tcp 0 0 localhost.localdomain:ipp *:* LISTEN 2442/cupsd
tcp 0 0 *:32855 *:* LISTEN 1872/rpc.statd
tcp 0 0 *:imaps *:* LISTEN 2229/dovecot
tcp 0 0 *op3s *:* LISTEN 2229/dovecot
tcp 0 0 *:5900 *:* LISTEN 2924/vino-server
tcp 0 0 *op3 *:* LISTEN 2229/dovecot
tcp 0 0 *:imap *:* LISTEN 2229/dovecot
tcp 0 0 *:ssh *:* LISTEN 2097/sshd
[root@support ~]#

[root@support ~]# df -h
Filesystem Size Used Avail Use% Mounted on
/dev/mapper/VolGroup00-LogVol00
269G 4.8G 250G 2% /
/dev/sda1 190M 19M 162M 11% /boot
tmpfs 506M 12K 506M 1% /dev/shm
[root@support ~]#
Reply With Quote
  #4  
Old 18th April 2008, 09:17
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,726 Times in 2,565 Posts
Default

Apache isn't running at all. Please start it:
Code:
/etc/init.d/httpd start
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 18th April 2008, 20:58
webwork webwork is offline
Junior Member
 
Join Date: Apr 2008
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
 
Smile Apache was running but listening on the local adapter

I changed the listen line from
LISTEN 192.168.1.34:80
to
LISTEN 127.0.0.1:80

in httpd.conf

And the web service indicator came back on in ISPCONFIG

Thank you very much
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
VMWare Server Free License - Invalid bardgd HOWTO-Related Questions 6 19th November 2006 17:50
install Net::DNS chrno Installation/Configuration 4 5th September 2006 17:01
Mandriva 10.2 Perfect Setup Install Problems... ctroyp Installation/Configuration 12 30th December 2005 16:04
New Install - Works Great But. fraginhell Installation/Configuration 7 24th December 2005 12:57
Install issues with PHP Part cksrealm Installation/Configuration 7 29th November 2005 18:55


All times are GMT +2. The time now is 02:04.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.