Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 16th April 2008, 08:12
boris boris is offline
Junior Member
 
Join Date: Apr 2008
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default Perfect Server Debian 4.0 and VPS

I followed falko's Perfect Server How to for Debian etch and it was great. Saved me a lot of headaches.

But I have one email problem. I can send and receive to and from anyone who's registered as a user on ISPConfig using the SquirrelMail I've installed on the site.

Registered users can receive email from outside with no problems.

But registered users cannot send email to anyone outside.

No "returned" or error messages are received. The email just never shows up in the intended recipient's box on Gmail.

My guess is that it's related to my being on a VPS server. I'm on a vps which gives me a hostname of myassignedusername.hostingcompanyname.de. I have a domain name, mycompanyname.com, that I have set up using ISPConfig's DNS options.

Sites I have set up on the server work fine.

Here is mail.log output of a successful send from one user to another on the local network:

Apr 16 07:43:42 myassignedusername postfix/smtpd[26113]: connect from localhost.localdomain[127.0.0.1]
Apr 16 07:43:42 myassignedusername postfix/smtpd[26113]: C0F2A213167A: client=localhost.localdomain[127.0.0.1]
Apr 16 07:43:42 myassignedusername postfix/cleanup[26116]: C0F2A213167A: message-id=<1641.XXX.XXX.XXX.XXX.1208324622.squirrel@www.m ycompanyname.com>
Apr 16 07:43:42 myassignedusername postfix/qmgr[22166]: C0F2A213167A: from=<support@mycompanyname.com>, size=734, nrcpt=1 (queue active)
Apr 16 07:43:42 myassignedusername postfix/smtpd[26113]: disconnect from localhost.localdomain[127.0.0.1]
Apr 16 07:43:42 myassignedusername imapd: Connection, ip=[::ffff:127.0.0.1]
Apr 16 07:43:42 myassignedusername imapd: LOGIN, user=support, ip=[::ffff:127.0.0.1], port=[43925], protocol=IMAP
Apr 16 07:43:42 myassignedusername postfix/pickup[22197]: D54D82131681: uid=10003 from=<fred>
Apr 16 07:43:42 myassignedusername postfix/cleanup[26116]: D54D82131681: message-id=<20080416054342.D54D82131681@mycompanyname.com>
Apr 16 07:43:42 myassignedusername postfix/local[26120]: C0F2A213167A: to=<fred@mycompanyname.com>, relay=local, delay=0.09, delays=0.06/0.01/0/0.02, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail -f-)
Apr 16 07:43:42 myassignedusername postfix/qmgr[22166]: C0F2A213167A: removed
Apr 16 07:43:42 myassignedusername postfix/qmgr[22166]: D54D82131681: from=<fred@mycompanyname.com>, size=351, nrcpt=1 (queue active)
Apr 16 07:43:42 myassignedusername postfix/local[26120]: D54D82131681: to=<admispconfig@localhost.localdomain>, relay=local, delay=0.01, delays=0.01/0/0/0.01, dsn=2.0.0,
status=sent (delivered to command: /usr/bin/procmail -f-)
Apr 16 07:43:42 myassignedusername postfix/qmgr[22166]: D54D82131681: removed

And here is output from mail.log on an unsucessful send to a Gmail user:

Apr 16 07:50:39 myassignedusername postfix/smtp[29896]: 607B32131681: to=<YYYYYYYYY@gmail.com>, relay=gmail-smtp-in.l.google.com[209.85.129.27]:25, delay=3.6, delays=0.08/0.01/0.79/2.7, dsn=2.0.0, status=sent (250 2.0.0 OK 1208325174 p38si13435417fke.13)
Apr 16 07:50:39 myassignedusername postfix/qmgr[22166]: 607B32131681: removed

I tried this once listing my VPS hostname in ISPConfig's server settings. That presented even more email problems. This time, I put my own domain name in ISPConfig's Server Settings box, and I have some functionality, but the problem with sending to the outside remains.

Changing /etc/hosts or hostname does not help. Those are set each time the system reboots.

How can I configure ISPConfig to make this work?

And yes, I do have the lines in /etc/postfix/main.cf pointing to local-host-names and virtusertable.
Reply With Quote
Sponsored Links
  #2  
Old 16th April 2008, 20:02
boris boris is offline
Junior Member
 
Join Date: Apr 2008
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default Now I see...

Emails were arriving but were being shoved into spam.

I have added an spf record in an attempt to help. Any other ideas?

Otherwise, awesome how to guide. It successfully led even me through a complex process.
Reply With Quote
  #3  
Old 16th April 2008, 23:13
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

Please check if your server is blacklisted: http://mxtoolbox.com/blacklists.aspx
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #4  
Old 16th April 2008, 23:59
boris boris is offline
Junior Member
 
Join Date: Apr 2008
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default Thanks for the tip.

I'm glad to know about that list.

No, the problem was really more DNS than mail related. Gmail was "neutral" about the email because of uncertainty about the DNS. Now everything is sending and receiving as it should.

Great How to!
Reply With Quote
  #5  
Old 17th April 2008, 08:14
boris boris is offline
Junior Member
 
Join Date: Apr 2008
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default All's well that ends well.

I went back to your tutorial on using GoDaddy and ISPConfig to set up nameservers. I didn't try to improvise this time, and everything worked fine. Mail is doing well too, except I can't figure out how to authenticate for sending mail from Thunderbird. With pop, I just have the ISPConfig username and pw, and all works fine, but with smtp, I try the same, and it keeps popping the pw prompt up over and over again. Send works fine from Squirrelmail on the server though, but of course, that's self-authenticating, right?
Reply With Quote
  #6  
Old 17th April 2008, 20:12
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

Any errors in your mail log?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 17th April 2008, 20:41
boris boris is offline
Junior Member
 
Join Date: Apr 2008
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default Aha!

There is an error:

warning: SASL authentication failure: cannot connect to saslauthd server: Permission denied

I have gone back over the modifications to the saslauthd file in the Perfect Server How to. And I've re-run the telnet test on localhost 25 and have STARTTLS, AUTH PLAIN LOGIN and AUTH=PLAIN LOGIN in the output. When I do a restart on saslauthd, it goes fine and shows no errors in the syslog.

I'm at a lost.
Reply With Quote
  #8  
Old 17th April 2008, 20:52
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

What'S the output of
Code:
ps aux | grep saslauthd
?

What's in /etc/default/saslauthd?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 17th April 2008, 21:09
boris boris is offline
Junior Member
 
Join Date: Apr 2008
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default Requested info

~# ps aux | grep saslauthd
root 28127 0.0 0.0 7932 752 ? Ss 20:36 0:00 /usr/sbin/saslauthd -a pam -c -m /var/spool/postfix/var/run/saslauthd -r -n 5
root 28128 0.0 0.0 7932 488 ? S 20:36 0:00 /usr/sbin/saslauthd -a pam -c -m /var/spool/postfix/var/run/saslauthd -r -n 5
root 28129 0.0 0.0 7932 372 ? S 20:36 0:00 /usr/sbin/saslauthd -a pam -c -m /var/spool/postfix/var/run/saslauthd -r -n 5
root 28130 0.0 0.0 7932 372 ? S 20:36 0:00 /usr/sbin/saslauthd -a pam -c -m /var/spool/postfix/var/run/saslauthd -r -n 5
root 28131 0.0 0.0 7932 372 ? S 20:36 0:00 /usr/sbin/saslauthd -a pam -c -m /var/spool/postfix/var/run/saslauthd -r -n 5
root 10108 0.0 0.0 1680 488 pts/0 R+ 21:03 0:00 grep saslauthd

Relevant lines from /etc/default/saslauthd:

START=yes
OPTIONS="-c -m /var/spool/postfix/var/run/saslauthd -r"
Reply With Quote
  #10  
Old 17th April 2008, 21:23
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
 
Default

What's the output of
Code:
ls -la /var/spool/postfix/var/run/saslauthd
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Debian Perfect Setup w/o ISPconfig, fiewall needed? minktoast HOWTO-Related Questions 2 2nd March 2008 20:22
Server IP address for VPS? toolish Installation/Configuration 1 19th January 2008 14:19
1 Name Server for all other VPS - Possible? webking General 1 13th May 2007 12:13
install fails, debian etch 4.0 edo660 Installation/Configuration 12 27th April 2007 02:40
ISPConfig on Virtuozzo VPS with Debian Sarge JohnSmith Installation/Configuration 2 25th January 2007 15:32


All times are GMT +2. The time now is 13:38.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.