Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 13th April 2008, 01:57
mbascombe mbascombe is offline
Member
 
Join Date: Oct 2007
Location: Brooklyn, NY 11226
Posts: 44
Thanks: 6
Thanked 0 Times in 0 Posts
Send a message via MSN to mbascombe Send a message via Yahoo to mbascombe
Default Error after upgrade

I upgrade my system to ISPConfig 2.22.2 and ran in to this error
Code:
root@server1:~# /etc/init.d/apache2 restart
 * Restarting web server apache2                                                Syntax error on line 48 of /etc/apache2/vhosts/Vhosts_ispconfig.conf:
Invalid command 'php_admin_flag', perhaps misspelled or defined by a module not included in the server configuration
                                                                         [fail]
root@server1:~# vi /etc/apache2/vhosts/Vhosts_ispconfig.conf
###################################
#
# ISPConfig vHost Configuration File
#         Version 1.0
#
#estarting web server apache2                                                Syntax error on line 48 of /etc/apache2/vhosts/Vhosts_ispconfig.conf:
Invalid command 'php_admin_flag', perhaps misspelled or defined by a module not included in the server configuration
                                                                         [fail]
 * Restarting web server apache2                                                Syntax error on line 48 of /etc/apache2/vhosts/Vhosts_ispconfig.conf:
Invalid command 'php_admin_flag', perhaps misspelled or defined by a module not included in the server configuration
                                                                         [fail]
Is there something I need to do
__________________
Dell Poweredge SC440
Ubuntu 8.10
ISPConfig 2.2.27
Joomla! 1.5
Drupal
Reply With Quote
Sponsored Links
  #2  
Old 13th April 2008, 03:54
daveb daveb is offline
Senior Member
 
Join Date: Dec 2006
Location: St Louis Mo
Posts: 272
Thanks: 43
Thanked 41 Times in 37 Posts
Default

By chance you use suphp?
Reply With Quote
  #3  
Old 13th April 2008, 04:05
mbascombe mbascombe is offline
Member
 
Join Date: Oct 2007
Location: Brooklyn, NY 11226
Posts: 44
Thanks: 6
Thanked 0 Times in 0 Posts
Send a message via MSN to mbascombe Send a message via Yahoo to mbascombe
Default

I upgraded ISPConfig and then was following the how to install suPHP with ISPConfig-2.2.20 whenI noticed the problem.
__________________
Dell Poweredge SC440
Ubuntu 8.10
ISPConfig 2.2.27
Joomla! 1.5
Drupal
Reply With Quote
  #4  
Old 13th April 2008, 04:11
daveb daveb is offline
Senior Member
 
Join Date: Dec 2006
Location: St Louis Mo
Posts: 272
Thanks: 43
Thanked 41 Times in 37 Posts
Default

suPHP does not support the php_value/php_admin_value directive known by mod_php to parse configuration options to scripts for certain virtual hosts or directories. You will have to either make the changes to your php.ini or have a individual php.ini for that web with the php options needed.
Reply With Quote
  #5  
Old 13th April 2008, 04:17
mbascombe mbascombe is offline
Member
 
Join Date: Oct 2007
Location: Brooklyn, NY 11226
Posts: 44
Thanks: 6
Thanked 0 Times in 0 Posts
Send a message via MSN to mbascombe Send a message via Yahoo to mbascombe
Default

Thanks but how do I go about making the change in the php.ini
__________________
Dell Poweredge SC440
Ubuntu 8.10
ISPConfig 2.2.27
Joomla! 1.5
Drupal
Reply With Quote
  #6  
Old 13th April 2008, 04:26
daveb daveb is offline
Senior Member
 
Join Date: Dec 2006
Location: St Louis Mo
Posts: 272
Thanks: 43
Thanked 41 Times in 37 Posts
Default

You can either make your changes server wide to your php.ini. Not sure your dist but in debian you would find it at
Code:
/etc/php5/cgi/php.ini
then restart apache2
or if you would like to just make the changes to 1 web
Code:
cp /etc/php5/cgi/php.ini /var/www/web#/php.ini
make your changes
and then in the apache directives for the site add
Code:
suPHP_ConfigPath /var/www/web#/php.ini
you might also have to restart apache2 afterwards
Reply With Quote
The Following User Says Thank You to daveb For This Useful Post:
mbascombe (14th April 2008)
  #7  
Old 13th April 2008, 04:38
mbascombe mbascombe is offline
Member
 
Join Date: Oct 2007
Location: Brooklyn, NY 11226
Posts: 44
Thanks: 6
Thanked 0 Times in 0 Posts
Send a message via MSN to mbascombe Send a message via Yahoo to mbascombe
Default

ok now I'm being told that there is no no such file or directory.
Does that mean I do not have php5 installed
__________________
Dell Poweredge SC440
Ubuntu 8.10
ISPConfig 2.2.27
Joomla! 1.5
Drupal
Reply With Quote
  #8  
Old 13th April 2008, 04:54
daveb daveb is offline
Senior Member
 
Join Date: Dec 2006
Location: St Louis Mo
Posts: 272
Thanks: 43
Thanked 41 Times in 37 Posts
Default

did you finish the install of suphp?
whats the contents of
Code:
cat /etc/apache2/httpd.conf
what file are you not able to find? php.ini
try
Code:
updatedb
locate php.ini
Reply With Quote
  #9  
Old 13th April 2008, 05:16
mbascombe mbascombe is offline
Member
 
Join Date: Oct 2007
Location: Brooklyn, NY 11226
Posts: 44
Thanks: 6
Thanked 0 Times in 0 Posts
Send a message via MSN to mbascombe Send a message via Yahoo to mbascombe
Default

ok I decided to do an update and upgrade and this is the result
Code:
Setting up mysql-server-5.0 (5.0.45-1ubuntu3.3) ...
 * Stopping MySQL database server mysqld                                 [ OK ]
 * Starting MySQL database server mysqld                                 [ OK ]
 * Checking for corrupt, not cleanly closed and upgrade needing tables.

Setting up mysql-server (5.0.45-1ubuntu3.3) ...
Setting up mysql-client (5.0.45-1ubuntu3.3) ...
Setting up libbz2-1.0 (1.0.4-0ubuntu2.1) ...

Setting up bzip2 (1.0.4-0ubuntu2.1) ...

Setting up python2.5 (2.5.1-5ubuntu5.1) ...

Setting up libkrb53 (1.6.dfsg.1-7ubuntu0.1) ...

Setting up libvolume-id0 (113-0ubuntu17) ...
Setting up volumeid (113-0ubuntu17) ...
update-initramfs: deferring update (trigger activated)

Setting up udev (113-0ubuntu17) ...
update-initramfs: deferring update (trigger activated)

Setting up libisc32 (1:9.4.1-P1-3ubuntu1) ...

Setting up libdns32 (1:9.4.1-P1-3ubuntu1) ...

Setting up libisccc30 (1:9.4.1-P1-3ubuntu1) ...

Setting up libisccfg30 (1:9.4.1-P1-3ubuntu1) ...

Setting up libbind9-30 (1:9.4.1-P1-3ubuntu1) ...

Setting up liblwres30 (1:9.4.1-P1-3ubuntu1) ...

Setting up bind9 (1:9.4.1-P1-3ubuntu1) ...
Installing new version of config file /etc/bind/db.root ...
 * Starting domain name service... bind                                  [ OK ]

Setting up bind9-host (1:9.4.1-P1-3ubuntu1) ...
Setting up dnsutils (1:9.4.1-P1-3ubuntu1) ...

Setting up openssh-client (1:4.6p1-5ubuntu0.2) ...

Setting up openssh-server (1:4.6p1-5ubuntu0.2) ...
 * Restarting OpenBSD Secure Shell server sshd                           [ OK ]

Setting up rsync (2.6.9-5ubuntu1.1) ...

Setting up libpcre3 (7.4-0ubuntu0.7.10.2) ...

Setting up libpq5 (8.2.7-0ubuntu0.7.10) ...

Setting up apache2-utils (2.2.4-3ubuntu0.1) ...
Setting up apache2.2-common (2.2.4-3ubuntu0.1) ...

Setting up apache2-mpm-prefork (2.2.4-3ubuntu0.1) ...
 * Starting web server apache2                                                  apache2: Syntax error on line 345 of /etc/apache2/apache2.conf: Syntax error on line 259 of /etc/apache2/vhosts/Vhosts_ispconfig.conf: /etc/apache2/vhosts/Vhosts_ispconfig.conf:274: <Files> was not closed.\n/etc/apache2/vhosts/Vhosts_ispconfig.conf:259: <VirtualHost> was not closed.
                                                                         [fail]
invoke-rc.d: initscript apache2, action "start" failed.

Setting up apache2 (2.2.4-3ubuntu0.1) ...
Setting up apache2-doc (2.2.4-3ubuntu0.1) ...
apache2: Syntax error on line 345 of /etc/apache2/apache2.conf: Syntax error on line 259 of /etc/apache2/vhosts/Vhosts_ispconfig.conf: /etc/apache2/vhosts/Vhosts_ispconfig.conf:274: <Files> was not closed.\n/etc/apache2/vhosts/Vhosts_ispconfig.conf:259: <VirtualHost> was not closed.
   ...fail!
invoke-rc.d: initscript apache2, action "reload" failed.
never got to finish the install because the apache2 could not restart. But here are the result
Code:

root@server1:~# cat /etc/apache2/httpd.conf

root@server1:~# updatedb

root@server1:~# locate php.ini
/etc/php5/apache2/php.ini
/etc/php5/apache2/.php.ini.swp
/etc/php5/cli/php.ini
/root/ispconfig/php/php.ini
/usr/share/doc/php5-common/examples/php.ini-dist
/usr/share/doc/php5-common/examples/php.ini-paranoid
/usr/share/doc/php5-common/examples/php.ini-recommended
/usr/share/php5/php.ini-dist
root@server1:~#
I appreciate your help
__________________
Dell Poweredge SC440
Ubuntu 8.10
ISPConfig 2.2.27
Joomla! 1.5
Drupal

Last edited by mbascombe; 13th April 2008 at 05:19.
Reply With Quote
  #10  
Old 13th April 2008, 05:31
daveb daveb is offline
Senior Member
 
Join Date: Dec 2006
Location: St Louis Mo
Posts: 272
Thanks: 43
Thanked 41 Times in 37 Posts
 
Default

So I guess you never finsihed the suphp install? looks like all you did when you fist posted was the first 2 steps right?
Code:
a2dismod php5
/etc/init.d/apache2 restart
then you got the errors for php_admin_flag correct, if correct thats because you disabled php in order to finish the install of suphp.
please post the contents of /etc/apache2/vhosts/Vhosts_ispconfig.conf
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Upgrade question for "Virtual Users And Domains With Postfix, Courier And MySQL" emresumengen HOWTO-Related Questions 3 1st December 2006 15:33
screwed up the upgrade provell Installation/Configuration 7 14th August 2006 13:33
Upgrade from Fedora 4 to Fedora 5 adamluz Installation/Configuration 4 16th June 2006 03:00
fedor core upgrade rahulgandhi Kernel Questions 1 11th April 2006 15:14
fedor core upgrade rahulgandhi Installation/Configuration 1 10th April 2006 21:51


All times are GMT +2. The time now is 11:39.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.