#1  
Old 6th April 2008, 23:56
bjarne-j bjarne-j is offline
Junior Member
 
Join Date: Apr 2008
Posts: 17
Thanks: 5
Thanked 0 Times in 0 Posts
Default email problems

hello

I have just installed ISPConfig and everything works except email. I'm able to create an email account from the control panel, but I can't login at mailuser or roundcube.

Mailuser says: Error: Could not get login password entry response

Hope someone are able to help me solving this problem.
Reply With Quote
Sponsored Links
  #2  
Old 7th April 2008, 19:43
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,749 Times in 2,579 Posts
Default

Any errors in your mail log?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 7th April 2008, 20:23
bjarne-j bjarne-j is offline
Junior Member
 
Join Date: Apr 2008
Posts: 17
Thanks: 5
Thanked 0 Times in 0 Posts
Default

Sorry.. In guess your talking about /var/log/mail.log?

Yes. I tried to logon at mailuser and roundcube a couple of times. Following is represented in /var/log/mail.log:

Code:
Apr  7 17:08:59 vps courierpop3login: Connection, ip=[::ffff:127.0.0.1]
Apr  7 17:08:59 vps courierpop3login: chdir Maildir: No such file or directory
Apr  7 17:12:28 vps courierpop3login: Connection, ip=[::ffff:127.0.0.1]
Apr  7 17:12:28 vps courierpop3login: chdir Maildir: No such file or directory
Apr  7 17:13:32 vps imapd: Connection, ip=[::ffff:127.0.0.1]
Apr  7 17:13:32 vps imapd: chdir Maildir: No such file or directory
Apr  7 17:16:16 vps imapd: Connection, ip=[::ffff:127.0.0.1]
Apr  7 17:16:16 vps imapd: chdir Maildir: No such file or directory
Reply With Quote
  #4  
Old 8th April 2008, 11:12
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,749 Times in 2,579 Posts
Default

Quote:
Apr 7 17:12:28 vps courierpop3login: chdir Maildir: No such file or directory
You must send an email first to new email accounts before you can fetch mails from them. The Maildir is created automatically when the first email arrives.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 8th April 2008, 15:24
bjarne-j bjarne-j is offline
Junior Member
 
Join Date: Apr 2008
Posts: 17
Thanks: 5
Thanked 0 Times in 0 Posts
Default

Still doesn't work. I tried to send a mail from my yahoo mail account.

Code:
Apr  8 11:57:03 vps postfix/smtpd[1659]: connect from web54012.mail.re2.yahoo.com[206.190.36.244]
Apr  8 11:57:03 vps postfix/smtpd[1659]: D27C254D245: client=web54012.mail.re2.yahoo.com[206.190.36.244]
Apr  8 11:57:04 vps postfix/cleanup[1663]: D27C254D245: message-id=<310038.20363.qm@web54012.mail.re2.yahoo.com>
Apr  8 11:57:04 vps postfix/qmgr[12022]: D27C254D245: from=<my yahoo-mail>, size=1838, nrcpt=1 (queue active)
Apr  8 11:57:04 vps postfix/pickup[7581]: 39D7354D24A: uid=10001 from=<web1_test>
Apr  8 11:57:04 vps postfix/cleanup[1663]: 39D7354D24A: message-id=<20080408115704.39D7354D24A@server1.example.com>
Apr  8 11:57:04 vps postfix/local[1664]: D27C254D245: to=<web1_test@vps.domain.com>, orig_to=<mail@domain2.com>, relay=local, delay=0.48, delays=0.45/0.01/0/0.02, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail -f-)
Apr  8 11:57:04 vps postfix/qmgr[12022]: D27C254D245: removed
Apr  8 11:57:04 vps postfix/qmgr[12022]: 39D7354D24A: from=<web1_test@vps.domain.com>, size=396, nrcpt=1 (queue active)
Apr  8 11:57:04 vps postfix/local[1664]: 39D7354D24A: to=<admispconfig@localhost.localdomain>, relay=local, delay=0.02, delays=0.01/0/0/0.01, dsn=2.0.0, status=sent (delivered to command: /usr/bin/procmail -f-)
Apr  8 11:57:04 vps postfix/qmgr[12022]: 39D7354D24A: removed
Apr  8 11:57:04 vps postfix/smtpd[1659]: disconnect from web54012.mail.re2.yahoo.com[206.190.36.244]
I replaced my two domains with "domain.com" and "domain2.com". When I installed ISPConfig I entered "domain2.com" as my domain.
"vps.domain.com" is the domain used by my VPS provider.

The log shows the mail from my yahoo-mail to mail@domain2.com
Reply With Quote
  #6  
Old 9th April 2008, 22:39
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,749 Times in 2,579 Posts
Default

Is this maybe your problem? http://www.howtoforge.com/faq/9_33_en.html
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 9th April 2008, 23:25
bjarne-j bjarne-j is offline
Junior Member
 
Join Date: Apr 2008
Posts: 17
Thanks: 5
Thanked 0 Times in 0 Posts
Default

O.K.. I need a domain used for ISPConfig only?

Can't find mydomain in /etc/postfix/main.cf btw.
Reply With Quote
  #8  
Old 9th April 2008, 23:28
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,995
Thanks: 840
Thanked 5,650 Times in 4,460 Posts
Default

Mushostname causes the same problem then mydomain. A subdomain is fine as well, it does not have to be a dedicated toplevel domain.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #9  
Old 10th April 2008, 00:05
bjarne-j bjarne-j is offline
Junior Member
 
Join Date: Apr 2008
Posts: 17
Thanks: 5
Thanked 0 Times in 0 Posts
Default

I've changed myhostname to "vps.domain.com" and reloaded postfix(postfix reload).

The email address is at "domain2.com". Still doesn't work.
Reply With Quote
  #10  
Old 10th April 2008, 19:37
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,749 Times in 2,579 Posts
 
Default

What's the value of myorigin?
What's the output of
Code:
postconf -d | grep mydomain
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig - Problems with Unique Email Addresses daadams2000 Installation/Configuration 1 7th March 2007 21:59
Problems with updating email account paddyman Installation/Configuration 1 1st February 2007 19:12
Email Problems With ISPConfig Harbinger Installation/Configuration 3 5th October 2006 12:00
Email problems lead to apache problems natewlew Installation/Configuration 7 10th July 2006 09:53
Sending email problems: Relay access denied jaffaizal HOWTO-Related Questions 35 24th April 2006 11:04


All times are GMT +2. The time now is 16:27.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.