Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 9th April 2008, 18:58
lordshadow lordshadow is offline
Member
 
Join Date: Apr 2008
Posts: 89
Thanks: 0
Thanked 0 Times in 0 Posts
Default Debian Etch SMTP relay server using exim4

Hi,

I'm having trouble setting up my server to send email.

I have set up my server using exim4, courier-imap, and fetchmail.

Currently it downloads email from my ISP and other email accounts that I have and then hosts it as an IMAP server so that all my clients can see the same emails according to the user.

I would like to do the opposite however and relay email messages sent out from my clients through my ISP's SMTP server but I can't even get the server to simply send email.

I've searched everywhere for an example or howto and found nothing, then I posted in the Debian forum but no-one replied.

If anyone has any suggestions I would be greatfull, it might be that I am missing something very basic here.

I don't have a domain name but I do have a static IP!

Many thanks in advance
Reply With Quote
Sponsored Links
  #2  
Old 10th April 2008, 18:09
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,726 Times in 2,565 Posts
Default

Take a look here:
http://www.eckes.org/article.php?sid=150
http://www.lexspoon.org/linux/smtp-relay.html
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 19th April 2008, 01:55
lordshadow lordshadow is offline
Member
 
Join Date: Apr 2008
Posts: 89
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks alot for those links! I will try to implement as soon as I can debug my mail fetch system.

So far everything seems to be fine apart from a few little niggles in which I have no idea of how to solve:

1. I created a .forward file in my directory to organize incoming mail more efficiently, however after it's creation my server seems to be sending reciepts to all senders which is nothing but a blank email.

for example I put fetchmail into crontab to run every half an hour in verbose mode and sure crontab sends local mail to me to my inbox. However a get a mail from me to cron appearing in my mailbox aswell after I forwarded the mails from cron to me to my inbox/.cron.

Also it seems outside senders are receiving blank emails now too.

How can I disable this? - I searched in all exim4 config files and found no luck.

2. I would also like to integrate Spamassassin and ClamAV into exim4 to scan my mail and I have installed the packages and uncommented their parts in the exim.conf.template file but with no luck. Since ClamAV has some other files assosiated with it I get a warning saying that:

Exim configuration error in line 115 of /var/lib/exim4/config.autogenerated.tmp:
main option "av_scanner" unknown
Invalid new configfile /var/lib/exim4/config.autogenerated.tmp
not installing /var/lib/exim4/config.autogenerated.tmp to
/var/lib/exim4/config.autogenerated


Are there any howto's on my problems or can anyone offer me any advice?

I've been struggling with this for a few weeks now and really like to learn how to get it up and running since this is my first experiance with mail servers and it's proving to be quite more complex then setting up anything else I've ever done on a linux machine!
Reply With Quote
  #4  
Old 30th April 2008, 23:49
lwh.dk lwh.dk is offline
Junior Member
 
Join Date: Dec 2006
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default Exim4

Are you running in exim4 in split mode ?

what version of exim are you running...

what's the output of:
Code:
netstat -a |grep clamav
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
DNS: installing Master and slave dns server on debian Etch SHELLHOSTER Installation/Configuration 1 28th October 2007 15:08
multiple domains with postfix on debian etch m61 HOWTO-Related Questions 3 27th October 2007 16:35
Syslog server telnetd,X windows twn,IPtables on Debian Etch 4.0r0 tommyjohn Suggest HOWTO 0 17th September 2007 08:10
Debian Apache Server - Proxy Issues? tcroteau Server Operation 5 16th September 2007 19:38
Problems with Postfix Mysql Courier PatrickAdrichem Installation/Configuration 3 13th April 2007 15:44


All times are GMT +2. The time now is 09:53.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.