Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 9th April 2008, 01:14
bahadirtonguc bahadirtonguc is offline
Junior Member
 
Join Date: Apr 2008
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Question Courier POP3 login refusal

hello,

I just installed Postfix and Courier. Postfix can receive messages (I can monitor from Webmin GUI) but when I try login inside or outside the network, it asks username and password then -ERR login failed. I try logging in with real accounts. What can be wrong. SMTP working okay but POP3 wont let me in..

I tried "telnet localhost pop3" or "telnet xx.xxx.xxx.xx 110" and both giving the same error.

Thanks for helping
Reply With Quote
Sponsored Links
  #2  
Old 9th April 2008, 23:23
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Any errors in your mail log?
How did you install Courier?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 10th April 2008, 19:01
bahadirtonguc bahadirtonguc is offline
Junior Member
 
Join Date: Apr 2008
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default popa3d

after a hard try, installing/removing courier 100 times, I installed popa3d and all was solved all of a sudden.. Why it is not told in forums and websites instead of writing millions of pages about courier..

bahadir
Reply With Quote
  #4  
Old 11th April 2008, 13:24
trallador trallador is offline
Junior Member
 
Join Date: Apr 2008
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

i have the same problem. I followed this guide:

http://www.howtoforge.com/virtual-us...ysql-centos5.1

courier and imap responses in telnet but not auth :/
Reply With Quote
  #5  
Old 11th April 2008, 22:28
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Any errors in your mail log?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 12th April 2008, 22:38
trallador trallador is offline
Junior Member
 
Join Date: Apr 2008
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ok partially solutioned. Now pop auth correctly but imap its not okay

Last edited by trallador; 13th April 2008 at 19:08.
Reply With Quote
  #7  
Old 13th April 2008, 21:29
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

I need the error messages from your mail log (in /var/log), otherwise I can't help you.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #8  
Old 17th April 2008, 21:18
imitrik imitrik is offline
Junior Member
 
Join Date: Apr 2008
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default Having the same issue with courier pop3

Hi! I have the same issue with loging to pop3 on courier (have ispconfig installed, postfix and courier). I can see in webmin that mail is arriving in the Maildir in the specified account, but neather /mailuser, nor /webmail can log in. In both cases the same error:
mail.log:
Apr 17 19:17:11 SERVER courierpop3login: Connection, ip=[::ffff:X.Y.Z.D]
Apr 17 19:17:11 SERVER courierpop3login: LOGIN FAILED, user=USER@EXAMPLE.org, ip=[::ffff:X.Y.Z.D]
Apr 17 19:17:16 SERVER courierpop3login: Disconnected, ip=[::ffff:X.Y.Z.D],

Can you help me?
Have tried loging in with e-mail and username as username, but nothing done.
Reply With Quote
  #9  
Old 17th April 2008, 22:21
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

USER@EXAMPLE.org is the wrong username. It must be something like web1_user. If it still doesn't work, please post the error messages again.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #10  
Old 18th April 2008, 00:51
imitrik imitrik is offline
Junior Member
 
Join Date: Apr 2008
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

I was researching through couriers files and found that in authmysqlrc (located in /etc/courier/), the file is left intend from my last configuration(other then ispconfig), and think that this is what is wrong about loging error(i have tried also with web1_USER, but no effect):
MYSQL_SERVER localhost
MYSQL_USERNAME mail_admin
MYSQL_PASSWORD mail_pass
MYSQL_PORT 3306
MYSQL_DATABASE mail
MYSQL_USER_TABLE users
MYSQL_CRYPT_PWFIELD password
#MYSQL_CLEAR_PWFIELD password
MYSQL_UID_FIELD 5000
MYSQL_GID_FIELD 5000
MYSQL_LOGIN_FIELD email
MYSQL_HOME_FIELD "/home/vmail"
MYSQL_MAILDIR_FIELD CONCAT(SUBSTRING_INDEX(email,'@',-1),'/',SUBSTRING_INDEX(email,'@',1),'/')
#MYSQL_NAME_FIELD
MYSQL_QUOTA_FIELD quota

This file tells courier to use other database (virtualmin created, before I removed it, but courier conf. unfortunately left untouched after ispconfig installation)
Can you help me, what should be the content of this file for ispconfig?

Thanks a lot!

This is my postfix conf. file:
# See /usr/share/postfix/main.cf.dist for a commented, more complete version


# Debian specific: Specifying a file name will cause the first
# line of that file to be used as the name. The Debian default
# is /etc/mailname.
#myorigin = /etc/mailname

smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

readme_directory = /usr/share/doc/postfix

# TLS parameters
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_use_tls = yes
smtpd_tls_session_cache_database = btree:${queue_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${queue_directory}/smtp_scache

# See /usr/share/doc/postfix/TLS_README.gz in the postfix-doc package for
# information on enabling SSL in the smtp client.

myhostname = www.example.net
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
#mydestination = example1.com, example2.com, localhost
relayhost =
mynetworks = 127.0.0.0/8
mailbox_command =
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
inet_protocols = all
smtpd_sasl_local_domain =
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject _unauth_destination
smtpd_tls_auth_only = no
smtp_use_tls = yes
smtp_tls_note_starttls_offer = yes
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom
home_mailbox = Maildir/

virtual_maps = hash:/etc/postfix/virtusertable

mydestination = /etc/postfix/local-host-names
debug_peer_list = example.org

Last edited by imitrik; 18th April 2008 at 01:31.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Webmail problems with only one domain? compner Installation/Configuration 14 16th February 2010 17:59
dovecot problem sojic Server Operation 21 23rd March 2008 19:22
Postfix POP3 Courier Login Problem mrkaylor Server Operation 1 5th September 2006 19:32
Problem with POP3 Login masterkain Installation/Configuration 6 15th January 2006 19:11
pop3 login stefanr Installation/Configuration 10 2nd January 2006 11:08


All times are GMT +2. The time now is 22:59.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.