#1  
Old 5th April 2008, 11:24
paulororke paulororke is offline
Junior Member
 
Join Date: Apr 2008
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default I broke my PHP

I can't seem to find an answer to this problem, if it's in another post that I missed I apologize.

Recently I upgraded a few apache packages on mt Debial Sarge LAMP server as per this document: http://plone.org/documentation/tutor...n-linux-server My intention was to install Plone behind my existing Apache2 installation. Unfortunately when doing the apt-get install apache2 part php5 was removed. I had expected to simply get a message that apache2 was already installed but it made quite a few changes.

To cut to the chase, I can't load the php5 module:

Code:
lamp:~# a2enmod php5
This module is already enabled!
Code:
lamp:~# /etc/init.d/apache2 force-reload
Forcing reload of web server: Apache2 ... failed!
You may still have some apache2 processes running.  There are
processes named 'apache2' which do not match your pid file,
and in the name of safety, we've left them alone.  Please review
the situation by hand.
Syntax error on line 1 of /etc/apache2/mods-enabled/php5.load:
Cannot load /usr/lib/apache2/modules/libphp5.so into server: /usr/lib/apache2/modules/libphp5.so: cannot open shared object file: No such file or directory
so it seems the .so (shared object?) file was indeed removed but when I try to use apt-get to install php5:
Code:
lamp:~# apt-get install php5
Reading Package Lists... Done
Building Dependency Tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  php5: Depends: libapache2-mod-php5 (>= 5.2.5-0.dotdeb.2) but it is not going to be installed or
                 libapache-mod-php5 (>= 5.2.5-0.dotdeb.2) but it is not going to be installed or
                 php5-cgi (>= 5.2.5-0.dotdeb.2) but it is not going to be installed
E: Broken packages
Code:
lamp:~# apt-get install libapache2-mod-php5
Reading Package Lists... Done
Building Dependency Tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  libapache2-mod-php5: Depends: libc6 (>= 2.3.6-6) but 2.3.2.ds1-22sarge4.xs3.2.0.58 is to be installed
                       Depends: libkrb53 (>= 1.4.2) but 1.3.6-2sarge5 is to be installed
                       Depends: libssl0.9.8 (>= 0.9.8c-1) but it is not installable
                       Depends: libxml2 (>= 2.6.27) but 2.6.16-7 is to be installed
E: Broken packages
I've tried apt-get update and apt-get upgrade but I don't seem to ba able to resolve these dependencies.
Reply With Quote
Sponsored Links
  #2  
Old 6th April 2008, 19:22
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
Default

What's in /etc/apt/sources.list?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 7th April 2008, 01:45
paulororke paulororke is offline
Junior Member
 
Join Date: Apr 2008
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default sources.list

Code:
paul@lamp:~$ cat /etc/apt/sources.list
deb http://ftp.debian.org/debian sarge main
deb http://www.backports.org/debian/ sarge-backports main
deb http://dotdeb.pimpmylinux.org/ stable all
deb-src http://ftp.debian.org/debian sarge main
deb-src http://www.backports.org/debian/ sarge-backports main
deb-src http://dotdeb.pimpmylinux.org/ stable all
Reply With Quote
  #4  
Old 7th April 2008, 19:45
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,751 Times in 2,581 Posts
Default

Please replace all references to stable with sarge because now Etch is stable, and Sarge is oldstable.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 8th April 2008, 19:25
paulororke paulororke is offline
Junior Member
 
Join Date: Apr 2008
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
 
Thumbs up

Thanks - that worked.

I still had a version conflict with dotdeb. I needed 5.2.5-0.dotdeb.0 - I had 5.2.5-0.dotdeb.2 but removing and reinstalling with apt-get put in the right version, from there everything went in place as expected.

Now I'm finding php errors I didn't have - due to changes in php5 I suspect (I wrote much of my stuff for php4) - but that's another issue.

Thanks again for the help - most appreciated.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Freebsd 6.1 support misterm Installation/Configuration 10 9th April 2009 10:29
network issues now it says "401 The web site is blocked by administrator" Check General 3 26th February 2008 15:22
Slightly Confused (DNS & Server Help) JohnnyBGoode Installation/Configuration 26 14th August 2007 10:54
Apache2 Freezes celtic Server Operation 31 28th May 2007 18:18


All times are GMT +2. The time now is 08:41.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.