#1  
Old 5th April 2008, 04:26
hochanh hochanh is offline
Junior Member
 
Join Date: Apr 2008
Posts: 2
Thanks: 1
Thanked 0 Times in 0 Posts
Default Log problem

I using Postfix, Dovecot, Mysql and Squirrelmail on Centos 5.1

[root@home postfix]# tail -f /var/log/maillog
Quote:
Apr 4 10:23:10 home dovecot: Auth process died too early - shutting down
Apr 4 10:23:10 home dovecot: auth(default): bind(/var/spool/postfix/private/auth) failed: Permission denied
Apr 4 10:23:10 home dovecot: auth(default): net_listen_unix(/var/spool/postfix/private/auth) failed: Permission denied
Apr 4 10:23:10 home dovecot: child 2962 (auth) returned error 89
Apr 4 10:23:10 home dovecot: Temporary failure in creating login processes, slowing down for now
Apr 4 11:28:07 home dovecot: Dovecot v1.0.rc15 starting up
Apr 4 11:28:09 home dovecot: Auth process died too early - shutting down
Apr 4 11:28:09 home dovecot: auth(default): bind(/var/spool/postfix/private/auth) failed: Permission denied
Apr 4 11:28:09 home dovecot: auth(default): net_listen_unix(/var/spool/postfix/private/auth) failed: Permission denied
Apr 4 11:28:09 home dovecot: child 3125 (auth) returned error 89
[root@home postfix]#cat /etc/postfix/main.cf
Quote:
readme_directory = no
virtual_mailbox_domains = mysql:/etc/postfix/mysql-virtual-mailbox-domains.cf
virtual_uid_maps = static:5000
virtual_gid_maps = static:5000
virtual_mailbox_maps = mysql:/etc/postfix/mysql-virtual-mailbox-maps.cf
virtual_alias_maps = mysql:/etc/postfix/mysql-virtual-alias-maps.cf,mysql:/etc/postfix/mysql-email2email.cf
virtual_transport = dovecot
dovecot_destination_recipient_limit = 1

#################### SASL/TLS Authentication###########################
######TLS PART###########
smptpd_tls_cert_file = /etc/ssl/maytinh/mailserver/smtpd.crt
smtpd_tls_key_file = /etc/ssl/maytinh/mailserver/smtpd.key
smtpd_tls_CAfile = /etc/ssl/maytinh/mailserver/cacert.pem
smtp_tls_auth_only = no
smtp_use_tls = yes
smtpd_use_tls = yes
smtpd_tls_received_header = no
smtp_tls_note_starttls_offer = yes
smtpd_tls_loglevel = 1
tls_random_source = dev:/dev/urandom
smtpd_tls_session_cache_timeout = 3600s
smtpd_tls_recieved_header = yes

smtpd_sasl_auth_enable = yes
smtpd_sasl_local_domain = $myhostname
smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination
smtpd_sasl_type = dovecot
smtpd_sasl_path = private/auth
Any help would be great i am a newbie to linux .
Thanks for help
Reply With Quote
Sponsored Links
  #2  
Old 5th April 2008, 13:32
topdog topdog is offline
Senior Member
 
Join Date: Jan 2008
Location: South Africa
Posts: 1,352
Thanks: 0
Thanked 153 Times in 150 Posts
Default

set your socket correctly in /etc/dovecot.conf

Code:
auth default {
  mechanisms = plain login
  passdb pam {
  }
  userdb passwd {
  }
#  user = root
  socket listen {
    client {
        path = /var/spool/postfix/private/auth
        mode = 0660
        user = postfix
        group = postfix
    }
  }
}
__________________
----
http://www.topdog.za.net - Got Linux problems ? - I can help.
http://www.baruwa.org - Try it.
Reply With Quote
The Following User Says Thank You to topdog For This Useful Post:
hochanh (5th April 2008)
  #3  
Old 5th April 2008, 14:16
hochanh hochanh is offline
Junior Member
 
Join Date: Apr 2008
Posts: 2
Thanks: 1
Thanked 0 Times in 0 Posts
Default

My dovecot
Quote:
protocols = imap imaps pop3 pop3s
disable_plaintext_auth = no
mail_location = maildir:/home/vmail/%d/%n
namespace private {
separator = .
prefix = INBOX.
inbox = yes
}
auth default {
mechanisms = plain login
passdb sql {
args = /etc/dovecot-sql.conf
}
userdb static {
args = uid=5000 gid=5000 home=/home/vmail/%d/%n allow_all_users=yes
}
socket listen {
master {
path = /var/run/dovecot/auth-master
mode = 0600
user = vmail
}
client {
path = /var/spool/postfix/private/auth
mode = 0660
user = postfix
group = postfix
}
}
Please help this topic help me, thanks
Reply With Quote
  #4  
Old 6th April 2008, 18:10
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
 
Default

What's the output of
Code:
ls -la /var/spool/postfix/private
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
problem of procmail nasir Installation/Configuration 8 13th March 2008 12:31
No delivery and log warnings after postfix/mysql tutorial TWadmin HOWTO-Related Questions 7 27th December 2006 22:24
SuseFirewall expert pls help zacch Installation/Configuration 11 17th March 2006 04:24
pop3 login stefanr Installation/Configuration 10 2nd January 2006 10:08
SMTP TLS Problem with Mail Client dschmid Installation/Configuration 1 9th December 2005 01:56


All times are GMT +2. The time now is 02:39.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.