Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 2nd April 2008, 10:50
SoftDux SoftDux is offline
Member
 
Join Date: Oct 2006
Posts: 35
Thanks: 1
Thanked 0 Times in 0 Posts
Default how to setup Linux to log messages from routers

Hi all

I want to log messages (info, debug, warn, etc) from our LAN routers, like our Linksys WRT54G wireless AP, or Netgear DG834 ADSL router. I can see in both routers I can specify an IP to send the logs to, but how do I setup OpenSuse 10.2, which uses syslog-ng to capture that info, and log it to syslog?
Is it possible to log each device to it's own log file, like /var/log/WRT54G & /var/log/netgear ?
Reply With Quote
Sponsored Links
  #2  
Old 2nd April 2008, 13:30
topdog topdog is offline
Senior Member
 
Join Date: Jan 2008
Location: South Africa
Posts: 1,352
Thanks: 0
Thanked 153 Times in 150 Posts
Default

syslog-ng is very configurable i think that should not be a problem http://www.campin.net/syslog-ng.conf
__________________
----
http://www.topdog.za.net - Got Linux problems ? - I can help.
http://www.baruwa.org - Try it.
Reply With Quote
  #3  
Old 2nd April 2008, 13:49
SoftDux SoftDux is offline
Member
 
Join Date: Oct 2006
Posts: 35
Thanks: 1
Thanked 0 Times in 0 Posts
Default

I saw the config file (well, the one on my server), but don't see how the server will "capture" the logs? Do I need to setup some TCP / UDP "trap"? How does it work?
Reply With Quote
  #4  
Old 2nd April 2008, 14:01
topdog topdog is offline
Senior Member
 
Join Date: Jan 2008
Location: South Africa
Posts: 1,352
Thanks: 0
Thanked 153 Times in 150 Posts
 
Default

Your routers are to log to the server using remote syslogging
__________________
----
http://www.topdog.za.net - Got Linux problems ? - I can help.
http://www.baruwa.org - Try it.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Daily mail logrotation?! schmidse Installation/Configuration 4 21st January 2008 13:55
Outlook does not Authenticates aberrio Server Operation 30 1st November 2007 19:21
No ftp login for ispconfig-webuser agri Installation/Configuration 12 19th March 2007 10:06
Problems installing NForce4 sound drivers Wraithfire Installation/Configuration 21 16th April 2006 17:30
KErnel not showing all my memory Jorem Kernel Questions 8 13th April 2006 12:59


All times are GMT +2. The time now is 14:05.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.