#1  
Old 2nd April 2008, 06:26
zars zars is offline
Junior Member
 
Join Date: Apr 2008
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default ispconfig on LAN

Hello people

I've managed to install Ubuntu server 7.10 on Virtualbox. I managed to install everything on it and now I can access to my ISPconfig site.

All I want is to create web sites and access to them within my LAN, as well as the mail server with the POP3 and stmp.

So far I've created 2 clients with 2 sites, but I can't see them. I also created 4 users that have "email" address but I don't know how to access to those email accounts.

Please point me to the right direction because right now I feel lost.

thanks in advance.
Reply With Quote
Sponsored Links
  #2  
Old 2nd April 2008, 11:09
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,704
Thanks: 819
Thanked 5,321 Times in 4,174 Posts
Default

To access the mail accounts, use the IP of your server as smtp and pop3 server in the mail client and the username and password that you created for the mail user.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 2nd April 2008, 17:40
zars zars is offline
Junior Member
 
Join Date: Apr 2008
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till
To access the mail accounts, use the IP of your server as smtp and pop3 server in the mail client and the username and password that you created for the mail user.

Thanks Till for the answer and sorry about the double post.

But how exactly should I go with the IP when configuring for example Mozilla Thunderbird?

I'd put in the incoming server: "pop.192.168.1.40"? or just the IP?

Last night I managed to install Uebimiau and could access to the emails with it.

As for the websites well, it's a little complicated I can access through then with a "hostname" that I created let's call it "sever.dyndns.org" <- it works locally but not in inet though I have it as a dyndns account but as I stated this is not important now.

But when I type for example site1.server.dyndns.org <- it resolves to the "hostname" I used when I installed the server which was something like "something.com.mx" and this doesn't work. so how I can change it to my other hostname (btw within the server there's an error message from Apache saying that it could not well resolve the dns name "something.com.mx").

PD: I also would like to install samba to give them space in the server to save their files, I did it with the Ubuntu desktop but I'm not sure this can be done with the Server because I used some visual things that helped me.

PD: When viewing the websites althought they actually work, the access is really slow and I think it's because of the SSH, I'd like them to show faster so is there a way or how can I disable the SSH to avoid this?.

Thanks for the help.

Last edited by zars; 2nd April 2008 at 18:42.
Reply With Quote
  #4  
Old 3rd April 2008, 05:53
zars zars is offline
Junior Member
 
Join Date: Apr 2008
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Okay, here a resume of what I've done.

I reconfigured the mail and now I can send mails through Mozilla thunderbird, but I can't receive them, I picked pop server and it says that it was not possible to connect to POP server 192.168.1.40 -ERR

Thanks for the help.
Reply With Quote
  #5  
Old 3rd April 2008, 19:39
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
Default

Quote:
Originally Posted by zars
Okay, here a resume of what I've done.

I reconfigured the mail and now I can send mails through Mozilla thunderbird, but I can't receive them, I picked pop server and it says that it was not possible to connect to POP server 192.168.1.40 -ERR

Thanks for the help.
Any errors in your mail log? What's the output of
Code:
netstat -tap
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 3rd April 2008, 20:37
zars zars is offline
Junior Member
 
Join Date: Apr 2008
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I'll have to check that at home.

I decided to install it again here at my office, it now works, I can see the sites and everything seems to work but the mail.

It keeps telling me "you can't login with the username and password entered Please check your username and password and try again"

Here is the output of netstat -tap

Code:
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name   
tcp        0      0 *:mysql                 *:*                     LISTEN     3777/mysqld         
tcp        0      0 *:www                   *:*                     LISTEN     4247/apache2        
tcp        0      0 *:81                    *:*                     LISTEN     4183/ispconfig_http 
tcp        0      0 unidit.dyndns.or:domain *:*                     LISTEN     6559/named          
tcp        0      0 localhost:domain        *:*                     LISTEN     6559/named          
tcp        0      0 localhost:953           *:*                     LISTEN     6559/named          
tcp        0      0 *:smtp                  *:*                     LISTEN     5268/master         
tcp        0      0 *:https                 *:*                     LISTEN     4247/apache2        
tcp6       0      0 *:imaps                 *:*                     LISTEN     3890/couriertcpd    
tcp6       0      0 *:pop3s                 *:*                     LISTEN     3926/couriertcpd    
tcp6       0      0 *:pop3                  *:*                     LISTEN     3903/couriertcpd    
tcp6       0      0 *:imap2                 *:*                     LISTEN     3862/couriertcpd    
tcp6       0      0 *:ftp                   *:*                     LISTEN     4413/proftpd: (acce 
tcp6       0      0 *:ssh                   *:*                     LISTEN     6100/sshd           
tcp6       0      0 ip6-localhost:953       *:*                     LISTEN     6559/named          
tcp6       0      0 *:smtp                  *:*                     LISTEN     5268/master         
tcp6       0      0 unidit.dyndns.org:ftp   ::ffff:192.168.1.5:3704 ESTABLISHED6989/proftpd: web1_

Last edited by zars; 3rd April 2008 at 22:59.
Reply With Quote
  #7  
Old 4th April 2008, 00:50
zars zars is offline
Junior Member
 
Join Date: Apr 2008
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Never mind I solved it, I had forgotten to active the Maildir checkbox. I just did it and it worked.

Now, I can send and receive emails, I just tried with two users and it worked, but when I tried with an outsider account e.g. 'something@gmail.com' it sent it but it's been around 2-3 hours and it hasn't arrived, besides, just after I tried this, I tried to send emails between the local users and they haven't arrived either.

Any ideas, thanks in advance.
Reply With Quote
  #8  
Old 4th April 2008, 19:30
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,739 Times in 2,574 Posts
Default

Quote:
Originally Posted by zars
Now, I can send and receive emails, I just tried with two users and it worked, but when I tried with an outsider account e.g. 'something@gmail.com' it sent it but it's been around 2-3 hours and it hasn't arrived, besides, just after I tried this, I tried to send emails between the local users and they haven't arrived either.
Any errors in your mail log?
Did you activate Maildir under Management > Server > Settings > Email?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 5th April 2008, 00:04
zars zars is offline
Junior Member
 
Join Date: Apr 2008
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko
Any errors in your mail log?
Did you activate Maildir under Management > Server > Settings > Email?
And yes I did activate it. Thanks.

Btw taking advance of this post, I reinstalled the server I had set up at home there everything's working although I haven't tried mailing accounts from outside the local network, but I would like to configure a mail software like thunderbird or evolution to handle the mail through there, but it doesn't work. I read about it and it seems that the mail needs to have the authentication turned on which I remember I did. Any ideas?? thanks.

Here is my mail.log it seems that it's too heavy to paste it here so I had to attach it.
Attached Files
File Type: zip mail.zip (7.6 KB, 167 views)

Last edited by zars; 5th April 2008 at 02:00.
Reply With Quote
  #10  
Old 5th April 2008, 05:51
zars zars is offline
Junior Member
 
Join Date: Apr 2008
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

Ok I managed to delete the messages that were in queue.

now local users can send mails among them but I haven't been able to make it send outside accounts.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Mastering ISPConfig llamy General 7 5th July 2007 01:24
4 questions about ispconfig and domains, please help! dimas Installation/Configuration 7 1st August 2006 11:55
Migrating from Virtualmin to ISPConfig xare Installation/Configuration 3 16th July 2006 12:58
FC4 Setup DNS and ISPCONFIG issues The General Installation/Configuration 7 15th May 2006 09:45
Recreating ISPConfig database retran Installation/Configuration 2 15th April 2006 23:22


All times are GMT +2. The time now is 00:29.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.