Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 20th January 2006, 10:04
ddelbia ddelbia is offline
Member
 
Join Date: Dec 2005
Posts: 56
Thanks: 1
Thanked 0 Times in 0 Posts
Default unknown filter was not added: PHP

Hi,
I get this error every time I view a php page on /var/log/apache/error.log:

[Fri Jan 20 09:59:18 2006] [error] an unknown filter was not added: PHP

This is vhost file written by ISPConfig

<VirtualHost 1.2.3.4:80>
SuexecUserGroup web14_ftp web14
ServerName www.xxxxxx.com:80
ServerAdmin webmaster@xxxxxx.com
DocumentRoot /var/www/web14/web
DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
ScriptAlias /cgi-bin/ /var/www/web14/cgi-bin/
AddHandler cgi-script .cgi
AddHandler cgi-script .pl
ErrorLog /var/www/web14/log/error.log
AddType application/x-httpd-php .php .php3 .php4 .php5
<Files *.php>
SetOutputFilter PHP
SetInputFilter PHP
</Files>
<Files *.php3>
SetOutputFilter PHP
SetInputFilter PHP
</Files>
<Files *.php4>
SetOutputFilter PHP
SetInputFilter PHP
</Files>
<Files *.php5>
SetOutputFilter PHP
SetInputFilter PHP
</Files>
php_admin_flag safe_mode On
php_admin_value open_basedir /var/www/web14/
php_admin_value file_uploads 1
php_admin_value upload_tmp_dir /var/www/web14/phptmp/
php_admin_value session.save_path /var/www/web14/phptmp/
Alias /error/ "/var/www/web14/web/error/"
ErrorDocument 400 /error/invalidSyntax.html
ErrorDocument 401 /error/authorizationRequired.html
ErrorDocument 403 /error/forbidden.html
ErrorDocument 404 /error/fileNotFound.html
ErrorDocument 405 /error/methodNotAllowed.html
ErrorDocument 500 /error/internalServerError.html
ErrorDocument 503 /error/overloaded.html
AliasMatch ^/~([^/]+)(/(.*))? /var/www/web14/user/$1/web/$3
AliasMatch ^/users/([^/]+)(/(.*))? /var/www/web14/user/$1/web/$3
</VirtualHost>
Reply With Quote
Sponsored Links
  #2  
Old 20th January 2006, 10:38
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,964
Thanks: 825
Thanked 5,366 Times in 4,213 Posts
Default

Thats nothing serious, just ignore it. ISPConfig has to enable PHP with filter records and addtpye records beacuse some of the first apache 2 versions wont work without. We will make this configurable in one of the next updates.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 20th January 2006, 11:01
ddelbia ddelbia is offline
Member
 
Join Date: Dec 2005
Posts: 56
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till
Thats nothing serious, just ignore it. ISPConfig has to enable PHP with filter records and addtpye records beacuse some of the first apache 2 versions wont work without. We will make this configurable in one of the next updates.
Ok, it only increases my error.log file ;-)
Reply With Quote
  #4  
Old 8th February 2007, 23:26
wr19026 wr19026 is offline
Senior Member
 
Join Date: Jan 2006
Posts: 172
Thanks: 7
Thanked 1 Time in 1 Post
Default

Is this still on the radar to be addressed in an upcoming release as I still see this error appear...
Reply With Quote
  #5  
Old 9th February 2007, 10:49
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,964
Thanks: 825
Thanked 5,366 Times in 4,213 Posts
Default

This has already been fixed many releases ago. You will just have to change the line from:

$go_info["server"]["apache2_php"] = 'both'; // one string of one or more comma seperated options: 'filter' = set PHP filters, 'addtype' = Set PHP addtype, 'both' = Set Filter + Addtype, 'engine' = Use "php_admin_flag engine on/off", suphp = SuPHP wrapper enabled, 'addhandler' = Set PHP AddHandler (nescessary for SuSE 10.2)


to:

$go_info["server"]["apache2_php"] = 'addtype'; // one string of one or more comma seperated options: 'filter' = set PHP filters, 'addtype' = Set PHP addtype, 'both' = Set Filter + Addtype, 'engine' = Use "php_admin_flag engine on/off", suphp = SuPHP wrapper enabled, 'addhandler' = Set PHP AddHandler (nescessary for SuSE 10.2)


in the file /home/admispconfig/ispconfig/lib/config.inc.php
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #6  
Old 15th February 2007, 22:50
wr19026 wr19026 is offline
Senior Member
 
Join Date: Jan 2006
Posts: 172
Thanks: 7
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by till
This has already been fixed many releases ago. You will just have to change the line from:

$go_info["server"]["apache2_php"] = 'both'; // one string of one or more comma seperated options: 'filter' = set PHP filters, 'addtype' = Set PHP addtype, 'both' = Set Filter + Addtype, 'engine' = Use "php_admin_flag engine on/off", suphp = SuPHP wrapper enabled, 'addhandler' = Set PHP AddHandler (nescessary for SuSE 10.2)


to:

$go_info["server"]["apache2_php"] = 'addtype'; // one string of one or more comma seperated options: 'filter' = set PHP filters, 'addtype' = Set PHP addtype, 'both' = Set Filter + Addtype, 'engine' = Use "php_admin_flag engine on/off", suphp = SuPHP wrapper enabled, 'addhandler' = Set PHP AddHandler (nescessary for SuSE 10.2)


in the file /home/admispconfig/ispconfig/lib/config.inc.php
Ok thanks. However, this is appearing on a server installed last December using the then most current version (2.2.7 or 2.2.8 I guess).

Forgot to mention, this is on a server running Ubuntu 6.06
Reply With Quote
  #7  
Old 15th February 2007, 22:59
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,964
Thanks: 825
Thanked 5,366 Times in 4,213 Posts
Default

Have you changed the config.inc.php file as I described above?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #8  
Old 19th February 2007, 23:45
wr19026 wr19026 is offline
Senior Member
 
Join Date: Jan 2006
Posts: 172
Thanks: 7
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by till
Have you changed the config.inc.php file as I described above?
Yes, I copied and pasted the update - should I restart apache for it to become effective?

Still, I notice it on a new install for 2.2.9, will this be fixed in an upcoming release, or is it Ubuntu (in this case 6.10) specific?
Reply With Quote
  #9  
Old 20th February 2007, 07:52
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,964
Thanks: 825
Thanked 5,366 Times in 4,213 Posts
Default

Quote:
Originally Posted by wr19026
Yes, I copied and pasted the update - should I restart apache for it to become effective?
After you changed this line, you must modify a avlue in one of your websites to let ISPConfig rewrite your configuration files.

Quote:
Still, I notice it on a new install for 2.2.9, will this be fixed in an upcoming release, or is it Ubuntu (in this case 6.10) specific?
My answer is still the same and yes, I know that is is fixed and working

This has already been fixed many releases ago. You will just have to change the line from:

$go_info["server"]["apache2_php"] = 'both'; // one string of one or more comma seperated options: 'filter' = set PHP filters, 'addtype' = Set PHP addtype, 'both' = Set Filter + Addtype, 'engine' = Use "php_admin_flag engine on/off", suphp = SuPHP wrapper enabled, 'addhandler' = Set PHP AddHandler (nescessary for SuSE 10.2)


to:

$go_info["server"]["apache2_php"] = 'addtype'; // one string of one or more comma seperated options: 'filter' = set PHP filters, 'addtype' = Set PHP addtype, 'both' = Set Filter + Addtype, 'engine' = Use "php_admin_flag engine on/off", suphp = SuPHP wrapper enabled, 'addhandler' = Set PHP AddHandler (nescessary for SuSE 10.2)


in the file /home/admispconfig/ispconfig/lib/config.inc.php
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #10  
Old 21st February 2007, 13:45
wr19026 wr19026 is offline
Senior Member
 
Join Date: Jan 2006
Posts: 172
Thanks: 7
Thanked 1 Time in 1 Post
 
Default

And as usual, it works Thanks again!

By the way, from what I heard there seems to be an inconsistency with HTTP code for port 81 traffic (starting off with control characters or so). Apparently this can cause problems with firewalls. I've asked for more details and will post in a seperate post once I know them.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
[error] an unkown filter was not added: PHP Arien Installation/Configuration 12 7th October 2006 14:17
upload fails with joomla CMS robd Installation/Configuration 7 19th July 2006 01:13
Can not access website after uploading brianetilley Installation/Configuration 21 11th January 2006 19:43
Sharedip Ivan Installation/Configuration 3 7th December 2005 15:36
Disable something in vhosts/Vhosts_ispconfig.conf Bruce Installation/Configuration 7 16th November 2005 09:11


All times are GMT +2. The time now is 03:32.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.