Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 15th March 2008, 16:59
redem redem is offline
Junior Member
 
Join Date: Mar 2008
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
Default Setting up pop3-imap server

I have serious problems with Dovecot IMAP/POP3 server and Sendmail...
I have installed through Webmin Sendmail and through ssh dovecot-common, dovecot-pop3d and dovecot-imapd, ok, now, sendmail and dovecot is running, but i can't receive/send e-mails.
I have set the record MX from my ISP DNS Control Panel (i can only set A records MX records and CNAME records, the NS records are pointed on ns1.myisp.tld and ns2.mysql.tld) to my VPS IP.

Please, help me,
Thanks.

PS: Sorry for my bad english
Reply With Quote
Sponsored Links
  #2  
Old 15th March 2008, 17:14
topdog topdog is offline
Senior Member
 
Join Date: Jan 2008
Location: South Africa
Posts: 1,352
Thanks: 0
Thanked 153 Times in 150 Posts
Default

what errors do you see in the logs
__________________
----
http://www.topdog.za.net - Got Linux problems ? - I can help.
http://www.baruwa.org - Try it.
Reply With Quote
  #3  
Old 15th March 2008, 17:41
redem redem is offline
Junior Member
 
Join Date: Mar 2008
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
Default

here the content of /var/log/mail.log

Code:
Log removed :)
Mail.warn

Code:
Log removed :)
PS: I can send mail to a tiscali.it email account, but this not work with hotmail or others :|

Last edited by redem; 16th March 2008 at 22:20.
Reply With Quote
  #4  
Old 16th March 2008, 10:24
redem redem is offline
Junior Member
 
Join Date: Mar 2008
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
Default

no suggestions?
Reply With Quote
  #5  
Old 16th March 2008, 12:32
topdog topdog is offline
Senior Member
 
Join Date: Jan 2008
Location: South Africa
Posts: 1,352
Thanks: 0
Thanked 153 Times in 150 Posts
Default

Please try to post the part of the logs when you are actually sending mail out.
__________________
----
http://www.topdog.za.net - Got Linux problems ? - I can help.
http://www.baruwa.org - Try it.
Reply With Quote
  #6  
Old 16th March 2008, 12:44
redem redem is offline
Junior Member
 
Join Date: Mar 2008
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Sorry, i'm a newbie XD...
however, here the last operation:

mail.log

Code:
Log Removed
Is correct or you need other log files?

Last edited by redem; 23rd March 2008 at 20:17.
Reply With Quote
  #7  
Old 16th March 2008, 12:48
topdog topdog is offline
Senior Member
 
Join Date: Jan 2008
Location: South Africa
Posts: 1,352
Thanks: 0
Thanked 153 Times in 150 Posts
Default

We that shows that the mail has been sent.
__________________
----
http://www.topdog.za.net - Got Linux problems ? - I can help.
http://www.baruwa.org - Try it.
Reply With Quote
  #8  
Old 16th March 2008, 12:58
redem redem is offline
Junior Member
 
Join Date: Mar 2008
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
Default

ye, but i don't see the mail on my hotmail account

PS:
I also tried with Postix, but with the same problem, maybe the MX Record is not set correctly?

Last edited by redem; 16th March 2008 at 13:06.
Reply With Quote
  #9  
Old 16th March 2008, 22:17
redem redem is offline
Junior Member
 
Join Date: Mar 2008
Posts: 27
Thanks: 0
Thanked 0 Times in 0 Posts
Default

ok, now i can send email to others e-mail accounts (like gmail) but not hotmail (??)...and i dont know why...
However, i can't receive the mails......please, help me

configuration: dovecot and sendmail (default configuration through Webmin)

PS: With Postfix i can receive emails, but i need sendmail
Reply With Quote
  #10  
Old 17th March 2008, 14:53
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
 
Default

Quote:
Originally Posted by redem
ok, now i can send email to others e-mail accounts (like gmail) but not hotmail (??)...and i dont know why...
These threads might help:
http://www.howtoforge.com/forums/sho...hlight=hotmail
http://www.howtoforge.com/forums/sho...hlight=hotmail
http://www.howtoforge.com/forums/sho...hlight=hotmail
http://www.howtoforge.com/forums/sho...hlight=hotmail
http://www.howtoforge.com/forums/sho...hlight=hotmail

Quote:
Originally Posted by redem
However, i can't receive the mails......please, help me
Any errors in your mail log? What's in /etc/postfix/main.cf?

Quote:
Originally Posted by redem
PS: With Postfix i can receive emails, but i need sendmail
Why? Postfix is 100% compatible with Sendmail.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
php Apps email not going through palkat General 8 21st September 2011 05:35
NO POP3!!! Ubuntu 7.10 Perfect Server captnops Installation/Configuration 6 24th January 2008 14:30
IMAP Server with QUOTA Extension capability djida Tips/Tricks/Mods 1 30th May 2007 11:21
Webmail Relay Error palkat General 17 23rd April 2006 18:12
Email - Ueb-Miau mazhar Installation/Configuration 5 21st December 2005 10:01


All times are GMT +2. The time now is 22:31.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.