Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 18th January 2006, 11:02
piratta piratta is offline
Junior Member
 
Join Date: Jan 2006
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default Big problem with apache2 on Ubuntu

I install ispconfig in Ubuntu (Server) whit the tutorial of howtoforge.
All works fine, but apache2 not run.
When i start manually apache2 the pront say me:

root@xxxx:~# /etc/init.d/apache2 start
* Starting web server (Apache2)... Syntax error on line 411 of /etc/apache2/apache2.conf:
Multiple <Directory> arguments not (yet) supported.
[fail]

I look the config file of apache and i don't understand.

#######################################
######### APACHE2.CONF##################
####################################

LINE 340 # To use CGI scripts outside /cgi-bin/:
#
#AddHandler cgi-script .cgi

# To use server-parsed HTML files
#
<FilesMatch "\.shtml(\..+)?$">
##ISPConfig INSTALL## SetOutputFilter INCLUDES
</FilesMatch>

# If you wish to use server-parsed imagemap files, use
#
#AddHandler imap-file map

BrowserMatch "Mozilla/2" nokeepalive
BrowserMatch "MSIE 4\.0b2;" nokeepalive downgrade-1.0 force-response-1.0
BrowserMatch "RealPlayer 4\.0" force-response-1.0
BrowserMatch "Java/1\.0" force-response-1.0
BrowserMatch "JDK/1\.0" force-response-1.0

#
# The following directive disables redirects on non-GET requests for
# a directory that does not include the trailing slash. This fixes a
# problem with Microsoft WebFolders which does not appropriately handle
# redirects for folders with DAV methods.
#

BrowserMatch "Microsoft Data Access Internet Publishing Provider" redirect-carefully
BrowserMatch "^WebDrive" redirect-carefully
BrowserMatch "^gnome-vfs" redirect-carefully
BrowserMatch "^WebDAVFS/1.[012]" redirect-carefully

# Allow server status reports, with the URL of http://servername/server-status
# Change the ".your_domain.com" to match your domain to enable.
#
#<Location /server-status>
# SetHandler server-status
# Order deny,allow
# Deny from all
# Allow from .your_domain.com
#</Location>

# Allow remote server configuration reports, with the URL of
# http://servername/server-info (requires that mod_info.c be loaded).
# Change the ".your_domain.com" to match your domain to enable.
#
#<Location /server-info>
# SetHandler server-info
# Order deny,allow
# Deny from all
# Allow from .your_domain.com
#</Location>

# Include the virtual host configurations:
Include /etc/apache2/sites-enabled/[^.#]*

<directory /var/www/sharedip>
Options +Includes -Indexes
AllowOverride None
AllowOverride Indexes AuthConfig Limit FileInfo
Order allow,deny
Allow from all
<files ~ "^\.ht">
Deny from all
</files>
</directory>

###############ispconfig_log###############
LogFormat "%v||||%b||||%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combined_ispconfig
CustomLog "|/root/ispconfig/cronolog --symlink=/var/log/httpd/ispconfig_access_log /var/log/httpd/ispconfig_access_log_%Y_%m_%d" combined_ispconfig

LINE 411 <directory /var/www as Web-Root/*/web>
Options +Includes -Indexes
AllowOverride None
AllowOverride Indexes AuthConfig Limit FileInfo
Order allow,deny
Allow from all
<files ~ "^\.ht">
Deny from all
</files>
</directory>

<directory /var/www as Web-Root/*/user/*/web>
Options +Includes -Indexes
AllowOverride None
AllowOverride Indexes AuthConfig Limit FileInfo
Order allow,deny
Allow from all
<files ~ "^\.ht">
Deny from all
</files>
</directory>

<directory /var/www as Web-Root/*/cgi-bin>
Options ExecCGI -Indexes
AllowOverride None
AllowOverride Indexes AuthConfig Limit FileInfo
Order allow,deny
Allow from all
<files ~ "^\.ht">
Deny from all
</files>
</directory>

Include /etc/apache2/vhosts/Vhosts_ispconfig.conf

###################################
######### END #####################
################################

SORRY for my bad english & thank you for your help.


piratta
Reply With Quote
Sponsored Links
  #2  
Old 18th January 2006, 13:04
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,573
Thanks: 792
Thanked 4,980 Times in 3,901 Posts
Default

Please replace these line:

<directory /var/www as Web-Root/*/web>

with:

<directory /var/www/*/web>

and:

<directory /var/www as Web-Root/*/user/*/web>

with:

<directory /var/www/*/user/*/web>

and:

<directory /var/www as Web-Root/*/cgi-bin>

with:

<directory /var/www/*/cgi-bin>
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 18th January 2006, 17:29
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
 
Default

... and restart Apache afterwards.

When you installed ISPConfig, and the installer asked you for the docroot, did you enter "/var/www as Web-Root"? Should have been "/var/www" instead.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange email problem for one of my domains... any help appreciated paulrobert_a Installation/Configuration 5 9th August 2010 14:15
Logging on to an ubuntu server DMJ HOWTO-Related Questions 3 8th January 2006 00:24
SMTP TLS Problem with Mail Client dschmid Installation/Configuration 1 9th December 2005 01:56
Unistalled but can't run apache2 on Ubuntu 5.0.4 chloe Installation/Configuration 6 23rd October 2005 14:35
Ubuntu 5.04 Server Noob Problem jugo23 Installation/Configuration 1 14th October 2005 09:23


All times are GMT +2. The time now is 04:18.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.