#1  
Old 13th March 2008, 07:59
nasir nasir is offline
Junior Member
 
Join Date: Mar 2006
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Default problem of procmail

hello evey1
we are facing problem on ispconfig
the problem is that 1 user web1_qadri did not recieve any mail and the sender recieve a bounce back message
in mail serve log i get that error

Mar 12 12:45:52 wikkid postfix/smtpd[18204]: C7CE2B8587: client=localhost.localdomain[127.0.0.1], sasl_sender=web1_qadri@wikkid.pk
Mar 12 12:45:52 wikkid postfix/qmgr[18154]: C7CE2B8587: from=<web1_qadri@wikkid.pk>, size=609, nrcpt=1 (queue active)
Mar 12 12:45:52 wikkid sendmail[18399]: m2C7jq7G018399: to=admispconfig@localhost.localdomain, ctladdr=web1_qadri (10266/10001), delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=30117, relay=[127.0.0.1] [127.0.0.1], dsn=2.0.0, stat=Sent (Ok: queued as C7CE2B8587)
Mar 12 12:45:52 wikkid postfix/local[18359]: B3D84B857D: to=<web1_qadri@wikkid.pk>, orig_to=<syed.tariq@wikkid.pk>, relay=local, delay=0.16, delays=0.05/0/0/0.1, dsn=5.2.0, status=bounced (can't create user output file. Command output: procmail: Error while writing to "/var/mail/web1_qadri" )


in cd /var/mail/
the web1_qadri ha following mailsize
-rw------- 1 web1_qadri mail 49M Mar 12 12:45 web1_qadri
i mv that mail in tmp and create new id and send mail to web1_qadri then its recieves mails when i put back to move data into that location then same problem happened.....
is that quota problem ya something else i think that user can't recieve more then 50 mb space
kindly told me the solution
Reply With Quote
Sponsored Links
  #2  
Old 13th March 2008, 08:01
nasir nasir is offline
Junior Member
 
Join Date: Mar 2006
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Default

before that 1 more error message i recieve

<web1_qadri@wi.pk> (expanded from <syed.tariq@wi.pk>): can't create

user output file. Command output: ==================== QUOTA:

1073741824 INBOXSIZE: 51137050 MAXMSG: 1022604774 procmail: Error

while

writing to "/var/mail/web1_qadri"


i think that information is enough to solve the problem if u required more then tell me
Reply With Quote
  #3  
Old 13th March 2008, 11:21
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,652 Times in 4,461 Posts
Default

Maybe the mailbox is corrupted. Remove the mailbox and see if receiving works again.

By the way, it is recommended to use maildir instead of mbox as described in the perfects etup guides so you will not get these mailbox corruption problems.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #4  
Old 13th March 2008, 11:46
nasir nasir is offline
Junior Member
 
Join Date: Mar 2006
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Default

yes when i move the mails in tmp and then delete the id and create new email on same name then its recuive mails after putting back those inbox into that location then same problem going on
but the problem is customer want those mails which i think 49Mb
so i do not want to move those mails now and want any solution ?
kindly help me dear
Reply With Quote
  #5  
Old 13th March 2008, 11:49
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,652 Times in 4,461 Posts
Default

If the mailbox is corrupted and the user is not able to access it with pop3 or imap anymore, then you will have to remove it or try to find a script or application that is able to repair mbox files. But I'am not aware of such a script at the moment.

Thats a common problem with mailboxes in mbox format and thats the reson why its highly recommended to use maildir intsead of mbox.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #6  
Old 13th March 2008, 11:59
nasir nasir is offline
Junior Member
 
Join Date: Mar 2006
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Default

now the problem is that i delete some of mails in his in inbox and he recieves his mail is that possible the problem of Quota???
cz i am not putting any quota in ispconfig ya by default 50 mb quota implemented in that Version of ispconfig?
Reply With Quote
  #7  
Old 13th March 2008, 12:08
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,015
Thanks: 840
Thanked 5,652 Times in 4,461 Posts
Default

It might be a quota problem.

ISPConfig has no default quota of 50 MB. But maybe you have set a max. mailbox size in your postfix configuration.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #8  
Old 13th March 2008, 12:50
nasir nasir is offline
Junior Member
 
Join Date: Mar 2006
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
Default

i have not mentioned anything related to quota or mailbox size in postfix
Reply With Quote
  #9  
Old 13th March 2008, 13:31
nasir nasir is offline
Junior Member
 
Join Date: Mar 2006
Posts: 21
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

i got the solution i think the problem related to postfix configuratio
i check the default mailbox size in postfix throught that command
postconf –d | grep size
by default the mailbox size is
mailbox_size_limit = 51200000
message_size_limit = 10240000
i put then
postconf –e message_size_limit=0
postconf –e mailbox_size_limit=0
now postfix mailbox size goes unlimited
i hope now i did not get any error message
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
sending e-mail using mail() function linuxuser1 HOWTO-Related Questions 38 21st April 2009 13:20
Quota Problem with Procmail rafaelenrike Installation/Configuration 1 16th June 2006 03:32
Procmail Delivery Problem sjmo2 Server Operation 1 1st April 2006 13:43
plenty of procmail/trashscan processes ZyanKLee Installation/Configuration 10 27th December 2005 21:09
procmail <defunct> ZyanKLee Installation/Configuration 1 19th December 2005 01:58


All times are GMT +2. The time now is 05:01.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.