Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 11th March 2008, 21:36
shelby shelby is offline
Junior Member
 
Join Date: Mar 2008
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default trouble with ntop - maybe need to install/configure http server ?

Hello -following the wonderful How to on network monitoring with ntop. This is exactly what I want to do. I am new to Linux - using Ubuntu/feisty. Have installed ntop, but when I try to start ntop, get the following in the error log:

This is a brand new install, and I have done nothing to install/configure any sort of server, so I think the problem is there. If anyone has any suggestions, please, make them as if I were a slow five year old when it comes to linux.

Tue 11 Mar 2008 03:16:09 PM EDT THREADMGMT[t3028437904]: DNSAR(1): Address resolution thread running [p6286]
Tue 11 Mar 2008 03:16:10 PM EDT SSL is present but https is disabled: use -W <https port> for enabling it
Tue 11 Mar 2008 03:16:10 PM EDT INITWEB: Initializing web server
Tue 11 Mar 2008 03:16:10 PM EDT INITWEB: Initializing tcp/ip socket connections for web server
Tue 11 Mar 2008 03:16:10 PM EDT **ERROR** INITWEB: binding problem - 'Address already in use'(98)
Tue 11 Mar 2008 03:16:10 PM EDT Check if another instance of ntop is running
Tue 11 Mar 2008 03:16:10 PM EDT or if the current user (-u) can bind to the specified port
Tue 11 Mar 2008 03:16:10 PM EDT **FATAL_ERROR** Binding problem, ntop shutting down...
Tue 11 Mar 2008 03:16:10 PM EDT CLEANUP[t3057198784]: ntop caught signal 2
Tue 11 Mar 2008 03:16:10 PM EDT THREADMGMT[t3057198784]: ntop RUNSTATE: SHUTDOWN(7)
Reply With Quote
Sponsored Links
  #2  
Old 12th March 2008, 19:52
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,727 Times in 2,565 Posts
Default

Please post the output of
Code:
netstat -tap
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 12th March 2008, 19:57
shelby shelby is offline
Junior Member
 
Join Date: Mar 2008
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default requested netstat output

hello falko, here is output you requested.

tcp 0 0 localhost:2208 *:* LISTEN 4453/hpiod
tcp 0 0 localhost:ipp *:* LISTEN 30030/cupsd
tcp 0 0 localhost:2207 *:* LISTEN 4462/python
tcp6 0 0 *:3000 *:* LISTEN 4698/ntop
Reply With Quote
  #4  
Old 13th March 2008, 17:57
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,727 Times in 2,565 Posts
Default

Quote:
tcp6 0 0 *:3000 *:* LISTEN 4698/ntop
ntop seems to be running. Do you get the same problem after a reboot?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #5  
Old 13th March 2008, 18:48
shelby shelby is offline
Junior Member
 
Join Date: Mar 2008
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default errors after reboot, and apache install

after reboot:
Thu Mar 13 13:39:15 2008 NOTE: Interface merge enabled by default
Thu Mar 13 13:39:15 2008 Initializing gdbm databases
Thu Mar 13 13:39:15 2008 **ERROR** ....open of /var/lib/ntop/prefsCache.db failed: File open error
Thu Mar 13 13:39:15 2008 Possible solution: please use '-P <directory>'
Thu Mar 13 13:39:15 2008 **FATAL_ERROR** GDBM open failed, ntop shutting down...
Thu Mar 13 13:39:15 2008 CLEANUP[t3057592000]: ntop caught signal 2
Thu Mar 13 13:39:15 2008 THREADMGMT[t3057592000]: ntop RUNSTATE: SHUTDOWN(7)
Thu Mar 13 13:39:15 2008 CLEANUP[t3057592000] catching thread is MAIN
Thu Mar 13 13:39:15 2008 CLEANUP: Running threads
Thu Mar 13 13:39:15 2008 CLEANUP: Locking purge mutex (may block for a little while)
Thu Mar 13 13:39:15 2008 CLEANUP: Locked purge mutex, continuing shutdown
Thu Mar 13 13:39:15 2008 CLEANUP: Continues
Thu Mar 13 13:39:15 2008 PLUGIN_TERM: Unloading plugins (if any)
Thu Mar 13 13:39:15 2008 CLEANUP: Clean up complete
Thu Mar 13 13:39:15 2008 THREADMGMT[t3057592000]: ntop RUNSTATE: TERM(8)
Thu Mar 13 13:39:15 2008 ===================================
Thu Mar 13 13:39:15 2008 ntop is shutdown...
Thu Mar 13 13:39:15 2008 ===================================
Reply With Quote
  #6  
Old 13th March 2008, 19:26
shelby shelby is offline
Junior Member
 
Join Date: Mar 2008
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default Disregard previous - wasn't running as right user

After reboot, and after installing apache,
this is what I get :

Thu 13 Mar 2008 02:23:05 PM EDT **WARNING** GDVERCHK: Unable to load gd, message is 'libgd.so: cannot open shared object file: No such file or directory'
Thu 13 Mar 2008 02:23:05 PM EDT GDVERCHK: ... as 2.x
Thu 13 Mar 2008 02:23:05 PM EDT Initializing external applications
Thu 13 Mar 2008 02:23:05 PM EDT THREADMGMT[t3051797392]: NPA: Started thread for network packet analyzer
Thu 13 Mar 2008 02:23:05 PM EDT THREADMGMT[t3043404688]: SFP: Started thread for fingerprinting
Thu 13 Mar 2008 02:23:05 PM EDT THREADMGMT[t3035011984]: SIH: Started thread for idle hosts detection
Thu 13 Mar 2008 02:23:05 PM EDT THREADMGMT[t3026619280]: DNSAR(1): Started thread for DNS address resolution
Thu 13 Mar 2008 02:23:05 PM EDT Calling plugin start functions (if any)
Thu 13 Mar 2008 02:23:05 PM EDT THREADMGMT[t3051797392]: NPA: network packet analyzer (packet processor) thread running [p6752]
Thu 13 Mar 2008 02:23:05 PM EDT THREADMGMT[t3043404688]: SFP: Fingerprint scan thread starting [p6752]
Thu 13 Mar 2008 02:23:05 PM EDT THREADMGMT[t3035011984]: SIH: Idle host scan thread starting [p6752]
Thu 13 Mar 2008 02:23:05 PM EDT THREADMGMT[t3026619280]: DNSAR(1): Address resolution thread running [p6752]
Thu 13 Mar 2008 02:23:05 PM EDT SSL is present but https is disabled: use -W <https port> for enabling it
Thu 13 Mar 2008 02:23:05 PM EDT INITWEB: Initializing web server
Thu 13 Mar 2008 02:23:05 PM EDT INITWEB: Initializing tcp/ip socket connections for web server
Thu 13 Mar 2008 02:23:05 PM EDT **ERROR** INITWEB: binding problem - 'Address already in use'(98)
Thu 13 Mar 2008 02:23:05 PM EDT Check if another instance of ntop is running
Thu 13 Mar 2008 02:23:05 PM EDT or if the current user (-u) can bind to the specified port
Thu 13 Mar 2008 02:23:05 PM EDT **FATAL_ERROR** Binding problem, ntop shutting down...
Thu 13 Mar 2008 02:23:05 PM EDT CLEANUP[t3055380160]: ntop caught signal 2
Thu 13 Mar 2008 02:23:05 PM EDT THREADMGMT[t3055380160]: ntop RUNSTATE: SHUTDOWN(7)
Thu 13 Mar 2008 02:23:05 PM EDT CLEANUP[t3055380160] catching thread is MAIN
Thu 13 Mar 2008 02:23:05 PM EDT CLEANUP: Running threads NPA SFP SIH DNSAR1
Thu 13 Mar 2008 02:23:05 PM EDT THREADMGMT[t3051797392]: NPA: network packet analyzer (packet processor) thread terminated [p6752]
Thu 13 Mar 2008 02:23:05 PM EDT THREADMGMT[t3026619280]: DNSAR(1): Address resolution thread terminated [p6752]
Thu 13 Mar 2008 02:23:05 PM EDT CLEANUP: Locking purge mutex (may block for a little while)
Thu 13 Mar 2008 02:23:05 PM EDT CLEANUP: Locked purge mutex, continuing shutdown
Thu 13 Mar 2008 02:23:05 PM EDT CLEANUP: Continues (still running SFP SIH)
Thu 13 Mar 2008 02:23:05 PM EDT FREE_HOST: Start, 1 device(s)
Thu 13 Mar 2008 02:23:05 PM EDT FREE_HOST: End, freed 0
Thu 13 Mar 2008 02:23:05 PM EDT PLUGIN_TERM: Unloading plugins (if any)
Thu 13 Mar 2008 02:23:05 PM EDT THREADMGMT[t3043404688]: SFP: Fingerprint scan thread running [p6752]
Thu 13 Mar 2008 02:23:05 PM EDT THREADMGMT[t3035011984]: SIH: Idle host scan thread running [p6752]
Thu 13 Mar 2008 02:23:05 PM EDT CLEANUP: Freeing device eth0 (idx=0)
Thu 13 Mar 2008 02:23:06 PM EDT CLEANUP: Clean up complete
Thu 13 Mar 2008 02:23:06 PM EDT THREADMGMT[t3055380160]: ntop RUNSTATE: TERM(8)
Thu 13 Mar 2008 02:23:06 PM EDT CLEANUP[t3055380160]: Still running threads SFP SIH
Thu 13 Mar 2008 02:23:06 PM EDT ===================================
Thu 13 Mar 2008 02:23:06 PM EDT ntop is shutdown...
Thu 13 Mar 2008 02:23:06 PM EDT ===================================
Reply With Quote
  #7  
Old 14th March 2008, 14:10
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,727 Times in 2,565 Posts
 
Default

Can you post the output of
Code:
netstat -tap
again as well as of
Code:
ps aux | grep -i ntop
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Statistics not compiling. thevinster Installation/Configuration 137 11th November 2010 10:54
Can't start apache Musty Server Operation 12 9th March 2008 13:58
cacti problem - graphs have huge gaps Chip Installation/Configuration 7 7th February 2008 23:24
Fedora 7 Directory Server Installation renegadeviking Server Operation 3 23rd June 2007 21:35
Dns question Mahir Installation/Configuration 48 14th November 2006 10:19


All times are GMT +2. The time now is 05:41.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.