Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 11th March 2008, 14:32
jon jon is offline
Member
 
Join Date: Jan 2007
Location: Canada
Posts: 87
Thanks: 12
Thanked 5 Times in 5 Posts
Send a message via Skype™ to jon
Default Chrooting Apache2 With mod_chroot On Debian Etch - MySQL Troubles

I've used the Apache2 chroot howto, and it worked perfectly. However it seems I cannot access the MySQL backend now. I see an error that says "MySQL said: Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (40)". When I got that, I made a symlink but it doesn't seem to work. Any help would be great.
Reply With Quote
Sponsored Links
  #2  
Old 12th March 2008, 19:24
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

Configure MySQL to use TCP instead of the socket.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
jon (12th March 2008)
  #3  
Old 12th March 2008, 20:46
jon jon is offline
Member
 
Join Date: Jan 2007
Location: Canada
Posts: 87
Thanks: 12
Thanked 5 Times in 5 Posts
Send a message via Skype™ to jon
Default

Just another reason I'm happy to spend $5 a month on this amazing site. Thanks! It worked perfectly.

On that note, from what I know about mysql and what I've read, you cannot have localhost not connect to the socket, but you have to use 127.0.0.1 instead. Is that still the same? Is there a way I can work around this?
Reply With Quote
  #4  
Old 13th March 2008, 18:10
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
 
Default

If you want to use TCP all the time, I'd use 127.0.0.1 instead of localhost.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Question on Virtual Users And Domains With Postfix, Courier And MySQL (Debian Etch) Horizon HOWTO-Related Questions 12 26th February 2008 20:22
Management/system config/settings & /server/settings not working!! dactor Installation/Configuration 9 6th February 2008 09:11
The Perfect Setup - Debian Etch (Debian 4.0) mysql question paul55 HOWTO-Related Questions 9 4th November 2007 11:28
Debian Etch (Debian 4.0) apache2 file needed Dekalb Installation/Configuration 3 1st June 2007 23:40
Bind Failed christoph2k HOWTO-Related Questions 4 28th April 2007 00:57


All times are GMT +2. The time now is 00:37.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.