Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 17th January 2006, 21:50
--::wizZzard::-- --::wizZzard::-- is offline
Member
 
Join Date: Jan 2006
Location: Gera / Thueringen / Germany
Posts: 39
Thanks: 0
Thanked 0 Times in 0 Posts
Default now what about these mounting points

at first my dedicated server has an 80GB HD.

my /etc/fstab looks like this:

#<file sys> <mount point> <type> <options> <dump> <pass>
/dev/hda1 / ext3
rw,errors=remount-ro,usrquota,grpquota 0 1
/dev/hda2 none swap rw 0 0
none /proc proc defaults 0 0
/dev/hda3 /home ext3 rw 0 2
none /proc/bus/usb usbdevfs defaults
/dev/fd0 /floppy auto users,noauto 0 0

to me (an complete Linux newbie) seems as there are 3 hardrives, or partitions and one Floppy mounted.

my ISPConfig sais to me that on hda1 are 5GB on hda2 237MB and hda3 are 67GB. this all is ok!

to hda1 is mounted: /
and
to hda3 is mounted /home

my web server data directory is /var/www

is this directory now on hda1? yes?

how do i get it to hda3 (without loosing all the data in it)? because this seems to me is the best way of using all the space for an server which only provides an Web and Mailserver.
Reply With Quote
Sponsored Links
  #2  
Old 18th January 2006, 19:18
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Quote:
Originally Posted by --::wizZzard::--
at first my dedicated server has an 80GB HD.

my /etc/fstab looks like this:

#<file sys> <mount point> <type> <options> <dump> <pass>
/dev/hda1 / ext3
rw,errors=remount-ro,usrquota,grpquota 0 1
/dev/hda2 none swap rw 0 0
none /proc proc defaults 0 0
/dev/hda3 /home ext3 rw 0 2
none /proc/bus/usb usbdevfs defaults
/dev/fd0 /floppy auto users,noauto 0 0

to me (an complete Linux newbie) seems as there are 3 hardrives, or partitions and one Floppy mounted.
Yes, you have 3 partitions, one of them is swap space.

Quote:
Originally Posted by --::wizZzard::--

is this directory now on hda1? yes?
Yes.

Quote:
Originally Posted by --::wizZzard::--
how do i get it to hda3 (without loosing all the data in it)? because this seems to me is the best way of using all the space for an server which only provides an Web and Mailserver.
Run
Code:
mv /var/www /home/www
Then replace all occurrences of /var/www with /home/www in your Apache configuration file and also in the files that are included in your Apache configuration file. Afterwards, restart Apache.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 18th January 2006, 19:42
--::wizZzard::-- --::wizZzard::-- is offline
Member
 
Join Date: Jan 2006
Location: Gera / Thueringen / Germany
Posts: 39
Thanks: 0
Thanked 0 Times in 0 Posts
Default

must i also alter ISPConfig configuration? Or only apche2 config?
Reply With Quote
  #4  
Old 18th January 2006, 19:46
nveid nveid is offline
Member
 
Join Date: Jan 2006
Location: Daytona Beach, FL
Posts: 87
Thanks: 7
Thanked 17 Times in 14 Posts
Send a message via Yahoo to nveid Send a message via Skype™ to nveid
Default

Judging by the demo site, it seems /home/www is what ISPconfig defaults to access those files.

So I'd say best bet modify your apache configuration files where its looking from /var/www to /home/www
__________________
-- RLB
Reply With Quote
  #5  
Old 18th January 2006, 20:46
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Quote:
Originally Posted by --::wizZzard::--
must i also alter ISPConfig configuration? Or only apche2 config?
I didn't know that you have ISPConfig installed. Yes, you must change the ISPConfig configuration. Adjust the values in the table isp_server, in Vhosts_ispconfig.conf, the users' homedirs in /etc/passwd. I hope I didn't forget anything.
Restart Apache afterwards.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 28th February 2006, 00:03
--::wizZzard::-- --::wizZzard::-- is offline
Member
 
Join Date: Jan 2006
Location: Gera / Thueringen / Germany
Posts: 39
Thanks: 0
Thanked 0 Times in 0 Posts
Default

so, now that my exams are over i tried to make the changes, apache2 itself works properly. but the php or pear (i am not quit familiar whats the difference) isn't working.

i looked through the files in /etc/apache2/mods-enabled/ but there arent any /var/www/ strings in it. where is php4 or pear also configured?

^^problem solved, it was only an absulute path saved in my joomla config file (wich now points also to /home/www/ )

But now:

Where do i find the file "Vhosts-ispconfig.conf" and the table "isp_server" ?

In ISP Configs Web Interface i altered all entries from /var/www to /home/www

Last edited by --::wizZzard::--; 28th February 2006 at 00:23.
Reply With Quote
  #7  
Old 28th February 2006, 00:54
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Quote:
Originally Posted by --::wizZzard::--
Where do i find the file "Vhosts-ispconfig.conf" and the table "isp_server" ?
Do you use Debian Sarge? Then Vhosts_ispconfig.conf is in /etc/apache2/vhosts.
The table isp_server is in the ISPConfig MySQL database. You can use phpMyAdmin to access it.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #8  
Old 28th February 2006, 00:59
--::wizZzard::-- --::wizZzard::-- is offline
Member
 
Join Date: Jan 2006
Location: Gera / Thueringen / Germany
Posts: 39
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko
Do you use Debian Sarge? Then Vhosts_ispconfig.conf is in /etc/apache2/vhosts.
The table isp_server is in the ISPConfig MySQL database. You can use phpMyAdmin to access it.
oh, then i already alterd Vhosts_ispconfig.conf and as i see the table was perfectly altered by ISPConfig itself through the Webinterface, where you can enter the webservers document root!

so i think for now are no more problems, i hope so!
Reply With Quote
  #9  
Old 28th February 2006, 02:07
--::wizZzard::-- --::wizZzard::-- is offline
Member
 
Join Date: Jan 2006
Location: Gera / Thueringen / Germany
Posts: 39
Thanks: 0
Thanked 0 Times in 0 Posts
Default

i have found one problem

in the /home/www/ there are located the web# and there corrosponding link files.

but after the changes, the link files aren't working anymore. how do i change them?
Reply With Quote
  #10  
Old 28th February 2006, 11:05
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
 
Default

Quote:
Originally Posted by --::wizZzard::--
i have found one problem

in the /home/www/ there are located the web# and there corrosponding link files.

but after the changes, the link files aren't working anymore. how do i change them?
Can you explain in more detail what you did and what is the problem now?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 19:33.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.