Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 16th January 2006, 23:13
amoswright amoswright is offline
Junior Member
 
Join Date: Jan 2006
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default Shared IP error when adding new site

Hi, I'm having trouble setting up a new site with ISPConfig - I get a shared IP error.

When I set up the site, it only gives me the option of using the internal IP, which I assume is good. I've looked in the forums and tried changing the ISPConfig server address in /home/admispconfig/ispconfig/lib/config.inc.php between the internal and external IP numbers, and tried using one of the external URL FQDN's there too, but it didn't seem to help. My server is at www.bathskatepark.org, and I have www.reachmorse.org pointed to the same external IP. With no new sites installed, when I go to www.bathskatepark.org I get the default apache web page. When I add www.reachmorse.org as a new site, both domains give the shared IP error.

I have a linksys wrt54g router acting as a gateway. I have the following ports forwarded:
ispconfig 81
ftp 21
pop3 110
https 443
bind 53
ssh 22
smtp 25
http 80
domain 53
imaps 993...
and that is all that I have space for on the admin web site for the router. But, I also tried the turning off the fire wall on the router, and still no luck.

Likely I'm missing something obvious... any sugggestions what that might be? Thanks!!!
Amos
Reply With Quote
Sponsored Links
  #2  
Old 16th January 2006, 23:18
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,775
Thanks: 840
Thanked 5,610 Times in 4,421 Posts
Default

1) Point all your domains in DNS to your external IP address.
2) Forward the ports you named above to your internal server IP address.
3) Setup the websites in ISPCOnfig with your internal server IP, it must be the same IP where you forwarded the ports on your router.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 17th January 2006, 16:43
amoswright amoswright is offline
Junior Member
 
Join Date: Jan 2006
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till
1) Point all your domains in DNS to your external IP address.
2) Forward the ports you named above to your internal server IP address.
3) Setup the websites in ISPCOnfig with your internal server IP, it must be the same IP where you forwarded the ports on your router.
Thanks for the quick response Till. I had tried that set-up, and just tried it again. Unfortunately, as soon as I add a second site, I get the shared IP error.

Are there settings from my DNS provider (yahoo.com, both domains are set up as masked forwarding) that would effect this? Or router issues I could look into?

Thanks again,
Amos
Reply With Quote
  #4  
Old 17th January 2006, 17:28
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,775
Thanks: 840
Thanked 5,610 Times in 4,421 Posts
Default

The shared IP site is not an error or error site, it only says that you do not have a website with the corrct IP / Domain combination on your server.

What is masked forwarding? You need DNS A-Records pointing to your external IP, not any kind of forwarding.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 17th January 2006, 18:36
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

What's in your Vhosts_ispconfig.conf?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #6  
Old 20th January 2006, 17:53
amoswright amoswright is offline
Junior Member
 
Join Date: Jan 2006
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hi and thanks! It appears that getting rid of yahoo.com's "masked forwarding" and adding the DNS A records did the trick!

It is great that you guys are so tollerant of newbies like myself!

Thanks again, Amos
Reply With Quote
  #7  
Old 13th June 2006, 17:01
mattfletcher mattfletcher is offline
Junior Member
 
Join Date: Jun 2006
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

A friend of mine is having similar problems, shared IP error. The DNS is set up as a CNAME to a dyndns.org domain on this one however - is this enough for it to work or must it be an A record?

Thanks, Matt
Reply With Quote
  #8  
Old 14th June 2006, 01:44
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

What's the domain, and what is in Vhosts_ispconfig.conf?
What's the output of
Code:
ifconfig
?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 14th June 2006, 11:39
mattfletcher mattfletcher is offline
Junior Member
 
Join Date: Jun 2006
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

The domain is doodlebug.stanleyroad.org.uk

This is set up as a CNAME to stanleyroad.dnsalias.com, a free DNS redirection domain from dyndns.org.

ifconfig for eth0 is:

Code:
eth0      Link encap:Ethernet  HWaddr 00:00:E2:52:EA:97
          inet addr:192.168.0.100  Bcast:192.168.0.255  Mask:255.255.255.0
          inet6 addr: fe80::200:e2ff:fe52:ea97/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:170321 errors:0 dropped:0 overruns:0 frame:0
          TX packets:121194 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:168375978 (160.5 MiB)  TX bytes:22008701 (20.9 MiB)
          Interrupt:10 Base address:0x8000
The vhosts file reads:

Code:
###################################
#
# ISPConfig vHost Configuration File
#         Version 1.0
#
###################################
#
NameVirtualHost 192.168.0.100:80
<VirtualHost 192.168.0.100:80>
  ServerName localhost
  ServerAdmin root@localhost
  DocumentRoot /var/www/sharedip
</VirtualHost>
NameVirtualHost 88.104.244.101:80
<VirtualHost 88.104.244.101:80>
  ServerName localhost
  ServerAdmin root@localhost
  DocumentRoot /var/www/sharedip
</VirtualHost>
#
#
######################################
# Vhost: www.doodlebug.stanleyroad.org.uk:80
######################################
#
#
<VirtualHost 88.104.244.101:80>
ServerName www.doodlebug.stanleyroad.org.uk:80
ServerAdmin webmaster@doodlebug.stanleyroad.org.uk
DocumentRoot /home/www/web3/web
ServerAlias duggie.doodlebug.stanleyroad.org.uk
DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
ScriptAlias  /cgi-bin/ /home/www/web3/cgi-bin/
AddHandler cgi-script .cgi
AddHandler cgi-script .pl
ErrorLog /home/www/web3/log/error.log
AddType application/x-httpd-php .php .php3 .php4 .php5
<Files *.php>
    SetOutputFilter PHP
    SetInputFilter PHP
</Files>
<Files *.php3>
    SetOutputFilter PHP
    SetInputFilter PHP
</Files>
<Files *.php4>
    SetOutputFilter PHP
    SetInputFilter PHP
</Files>
<Files *.php5>
    SetOutputFilter PHP
    SetInputFilter PHP
</Files>
php_admin_flag safe_mode On
php_admin_value open_basedir /home/www/web3/
php_admin_value file_uploads 1
php_admin_value upload_tmp_dir /home/www/web3/phptmp/
php_admin_value session.save_path /home/www/web3/phptmp/
AddType text/html .shtml
AddOutputFilter INCLUDES .shtml
AddType application/vnd.wap.wmlscriptc .wmlsc .wsc
AddType text/vnd.wap.wml .wml
AddType text/vnd.wap.wmlscript .ws .wmlscript
AddType image/vnd.wap.wbmp .wbmp
Alias /error/ "/home/www/web3/web/error/"
ErrorDocument 400 /error/invalidSyntax.html
ErrorDocument 401 /error/authorizationRequired.html
ErrorDocument 403 /error/forbidden.html
ErrorDocument 404 /error/fileNotFound.html
ErrorDocument 405 /error/methodNotAllowed.html
ErrorDocument 500 /error/internalServerError.html
ErrorDocument 503 /error/overloaded.html
AliasMatch ^/~([^/]+)(/(.*))? /home/www/web3/user/$1/web/$3
AliasMatch ^/users/([^/]+)(/(.*))? /home/www/web3/user/$1/web/$3
</VirtualHost>
#
#
#
######################################
# Vhost: www.workitellyou:80
######################################
#
#
<VirtualHost 192.168.0.100:80>
ServerName www.workitellyou:80
ServerAdmin webmaster@workitellyou
DocumentRoot /home/www/web4/web
ServerAlias workitellyou
DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
ScriptAlias  /cgi-bin/ /home/www/web4/cgi-bin/
AddHandler cgi-script .cgi
AddHandler cgi-script .pl
ErrorLog /home/www/web4/log/error.log
AddType application/x-httpd-php .php .php3 .php4 .php5
<Files *.php>
    SetOutputFilter PHP
    SetInputFilter PHP
</Files>
<Files *.php3>
    SetOutputFilter PHP
    SetInputFilter PHP
</Files>
<Files *.php4>
    SetOutputFilter PHP
    SetInputFilter PHP
</Files>
<Files *.php5>
    SetOutputFilter PHP
    SetInputFilter PHP
</Files>
php_admin_flag safe_mode On
php_admin_value open_basedir /home/www/web4/
php_admin_value file_uploads 1
php_admin_value upload_tmp_dir /home/www/web4/phptmp/
php_admin_value session.save_path /home/www/web4/phptmp/
AddType text/html .shtml
AddOutputFilter INCLUDES .shtml
AddType application/vnd.wap.wmlscriptc .wmlsc .wsc
AddType text/vnd.wap.wml .wml
AddType text/vnd.wap.wmlscript .ws .wmlscript
AddType image/vnd.wap.wbmp .wbmp
Alias /error/ "/home/www/web4/web/error/"
ErrorDocument 400 /error/invalidSyntax.html
ErrorDocument 401 /error/authorizationRequired.html
ErrorDocument 403 /error/forbidden.html
ErrorDocument 404 /error/fileNotFound.html
ErrorDocument 405 /error/methodNotAllowed.html
ErrorDocument 500 /error/internalServerError.html
ErrorDocument 503 /error/overloaded.html
AliasMatch ^/~([^/]+)(/(.*))? /home/www/web4/user/$1/web/$3
AliasMatch ^/users/([^/]+)(/(.*))? /home/www/web4/user/$1/web/$3
</VirtualHost>
#
#
Reply With Quote
  #10  
Old 14th June 2006, 19:01
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
 
Default

Your domain isn't a CNAME, it's an A record:

Code:
dig stanleyroad.dnsalias.com

; <<>> DiG 9.2.1 <<>> stanleyroad.dnsalias.com
;; global options:  printcmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 56259
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;stanleyroad.dnsalias.com.      IN      A

;; ANSWER SECTION:
stanleyroad.dnsalias.com. 60    IN      A       88.104.244.101

;; Query time: 177 msec
;; SERVER: 81.169.163.104#53(81.169.163.104)
;; WHEN: Wed Jun 14 17:59:29 2006
;; MSG SIZE  rcvd: 58
Is 88.104.244.101 your public IP address?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
how i can open a web site hadisaadeh Installation/Configuration 10 20th January 2006 16:46
host site at same domain as ISPConfig server? amoswright Installation/Configuration 2 13th January 2006 23:43
Pure https site erk Installation/Configuration 2 9th January 2006 21:45
Removed site, but it is still there mromer General 2 21st December 2005 18:46
can't delete a site KenMcGinnis Installation/Configuration 2 14th August 2005 16:02


All times are GMT +2. The time now is 13:27.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.