Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Kernel Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 3rd November 2005, 18:39
floobit floobit is offline
Junior Member
 
Join Date: Oct 2005
Posts: 6
Thanks: 0
Thanked 1 Time in 1 Post
Default You're right!

I added a initrd line to my menu.lst, and it booted wonderfully - thanks a bunch! However, when compiling, I had installed the latest gcc (4.0) and g++, but it said it would use the earlier 3.3 version to compile the kernel. does this mean if I compile any modules (like the latest nvidia driver), they will use gcc/g++ 4.0, and won't be compatible with my kernel? Is there a way to check (to see if I'm wrong) which g++/gcc compiler I used?

Dylan
Reply With Quote
Sponsored Links
  #12  
Old 5th November 2005, 02:48
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,752 Times in 2,582 Posts
Default

Quote:
Originally Posted by floobit
does this mean if I compile any modules (like the latest nvidia driver), they will use gcc/g++ 4.0, and won't be compatible with my kernel?
I don't think so. I'd try it.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #13  
Old 19th November 2005, 16:46
JL84 JL84 is offline
Junior Member
 
Join Date: Nov 2005
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I went through the whole process of upgrading to kernel 2.6 and I made sure that the initr-img was in the right place, but when I loaded with the new kernel 2.6 it gave me another error. The boot was trying to find /sbin/init/ and /dev/console/ where would those be entered in so that the kernel can load?
Reply With Quote
  #14  
Old 23rd November 2005, 02:44
Iwan Iwan is offline
Junior Member
 
Join Date: Nov 2005
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Works great except I had to

apt-get install yaird

aswell
Reply With Quote
  #15  
Old 22nd January 2006, 22:23
Januss Januss is offline
Junior Member
 
Join Date: Jan 2006
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default Are you sure you have your root FS compiled in kernel?

Quote:
Originally Posted by JL84
I went through the whole process of upgrading to kernel 2.6 and I made sure that the initr-img was in the right place, but when I loaded with the new kernel 2.6 it gave me another error. The boot was trying to find /sbin/init/ and /dev/console/ where would those be entered in so that the kernel can load?
Hi,
I had the same problem with my upgrade to 2.6.8.
At first the kernel didn't boot at all, but after i
did mkinitrd and added the initrd image to grub menu.lst I had the same results as you had written.
As it turned out, I forgot to compile ext3 support into the kernel, which is needed if you have ext3 as the root fs (/).

Hope this helps someone.
Reply With Quote
  #16  
Old 6th March 2006, 06:03
stevendemetrius stevendemetrius is offline
Junior Member
 
Join Date: Mar 2006
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by floobit
after running the apt-get update with these sources:
deb http://security.debian.org/ stable/updates main contrib non-free
deb http://secure-testing.debian.net/debian-secure-testing testing/security-updates main contrib non-free
deb http://http.us.debian.org/debian/ stable main contrib non-free
deb http://http.us.debian.org/debian/ testing main contrib non-free
deb http://http.us.debian.org/debian/ unstable main contrib non-free
deb http://debian.kcore.org/ ./


I started following the instructions. On the first line

apt-get install kernel-package ncurses-dev fakeroot wget bzip2
I encountered 2 errors. First, it informed me that:
Reading Package Lists...
Building Dependency Tree...
Package ncurses-dev is a virtual package provided by:
libncurses5-dev 5.4-9
You should explicitly select one to install.

and it installed none of the packages

so, I removed the ncurses-dev from the install list and tried again. this time, all packages were installed, but it prompted me for if I wanted to stop gdm before I installed glibc. This was slightly weird, because I logged in as "repair" from grub. also, I don't believe gdm was running, because ps -A yielded:

PID TTY TIME CMD
1 ? 00:00:00 init
2 ? 00:00:00 ksoftirqd/0
3 ? 00:00:00 events/0
4 ? 00:00:00 khelper
5 ? 00:00:00 kacpid
35 ? 00:00:00 kblockd/0
45 ? 00:00:00 pdflush
46 ? 00:00:00 pdflush
48 ? 00:00:00 aio/0
47 ? 00:00:00 kswapd0
184 ? 00:00:00 kseriod
293 ? 00:00:00 kjournald
346 ? 00:00:00 udevd
1452 ? 00:00:00 khubd
2731 ? 00:00:00 dhclient
2736 ? 00:00:00 portmap
3083 tty1 00:00:00 init
3101 tty1 00:00:00 bash
3497 tty1 00:00:00 ps


I chose to install glibc anyway, but can easily start over if I need to.

Thanks,
Dylan Evans

Check the command you typed. It should be "libncurses5-dev" not "ncurses-dev"
Reply With Quote
  #17  
Old 6th March 2006, 06:09
stevendemetrius stevendemetrius is offline
Junior Member
 
Join Date: Mar 2006
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Do you know the type of file system on your boot drive? It must be complied in the kernel and *not* as a module. This is set in the kernel configuration.

If you boot file system is ext3 then when you configure the kernel then the ext3 file system must be marked to be compiled in the kernel.
Reply With Quote
  #18  
Old 8th March 2006, 21:32
Flip Flip is offline
Junior Member
 
Join Date: Mar 2006
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Ill get this error,
Pivot_root: No such file or directory
/sbin/init: 432: cannot open dev/console: No such file
Kernel panic - not syncing: Attempted to kill init:

This is my /boot/grub/menu.lst

Code:
# menu.lst - See: grub(8), info grub, update-grub(8)
#            grub-install(8), grub-floppy(8),
#            grub-md5-crypt, /usr/share/doc/grub
#            and /usr/share/doc/grub-doc/.

## default num
# Set the default entry to the entry number NUM. Numbering starts from 0, and
# the entry number 0 is the default if the command is not used.
#
# You can specify 'saved' instead of a number. In this case, the default entry
# is the entry saved with the command 'savedefault'.           
default		0

## timeout sec
# Set a timeout, in SEC seconds, before automatically booting the default entry
# (normally the first entry defined).
timeout		20

# Pretty colours
color cyan/blue white/blue

## password ['--md5'] passwd
# If used in the first section of a menu file, disable all interactive editing
# control (menu entry editor and command-line)  and entries protected by the
# command 'lock'
# e.g. password topsecret
#      password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/
# password topsecret

#
# examples
#
# title		Windows 95/98/NT/2000
# root		(hd0,0)
# makeactive
# chainloader	+1
#
# title		Linux
# root		(hd0,1)
# kernel	/vmlinuz root=/dev/hda2 ro
#

#
# Put static boot stanzas before and/or after AUTOMAGIC KERNEL LIST

### BEGIN AUTOMAGIC KERNELS LIST
## lines between the AUTOMAGIC KERNELS LIST markers will be modified
## by the debian update-grub script except for the default options below

## DO NOT UNCOMMENT THEM, Just edit them to your needs

## ## Start Default Options ##
## default kernel options
## default kernel options for automagic boot options
## If you want special options for specifiv kernels use kopt_x_y_z
## where x.y.z is kernel version. Minor versions can be omitted.
## e.g. kopt=root=/dev/hda1 ro
# kopt=root=/dev/hda1 ro

## default grub root device
## e.g. groot=(hd0,0)
# groot=(hd0,0)

## should update-grub create alternative automagic boot options
## e.g. alternative=true
##      alternative=false
# alternative=true

## should update-grub lock alternative automagic boot options
## e.g. lockalternative=true
##      lockalternative=false
# lockalternative=false

## altoption boot targets option
## multiple altoptions lines are allowed
## e.g. altoptions=(extra menu suffix) extra boot options
##      altoptions=(recovery mode) single
# altoptions=(recovery mode) single

## controls how many kernels should be put into the menu.lst
## only counts the first occurence of a kernel, not the
## alternative kernel options
## e.g. howmany=all
##      howmany=7
# howmany=all

## should update-grub create memtest86 boot option
## e.g. memtest86=true
##      memtest86=false
# memtest86=true

## ## End Default Options ##

title		Debian GNU/Linux, kernel 2.6.15.6 
root		(hd0,0)
kernel		/boot/vmlinuz-2.6.15.6 root=/dev/hda1 ro 
initrd		/boot/initrd.img-2.6.15.6
savedefault
boot

title		Debian GNU/Linux, kernel 2.6.15.6 (recovery mode)
root		(hd0,0)
kernel		/boot/vmlinuz-2.6.15.6 root=/dev/hda1 ro single
initrd		/boot/initrd.img-2.6.15.6
savedefault
boot

title		Debian GNU/Linux, kernel 2.6.11.7 
root		(hd0,0)
kernel		/boot/vmlinuz-2.6.11.7 root=/dev/hda1 ro 
initrd		/boot/initrd.img-2.6.11.7
savedefault
boot

title		Debian GNU/Linux, kernel 2.6.11.7 (recovery mode)
root		(hd0,0)
kernel		/boot/vmlinuz-2.6.11.7 root=/dev/hda1 ro single
initrd		/boot/initrd.img-2.6.11.7
savedefault
boot

title		Debian GNU/Linux, kernel 2.4.27-2-386 
root		(hd0,0)
kernel		/boot/vmlinuz-2.4.27-2-386 root=/dev/hda1 ro 
initrd		/boot/initrd.img-2.4.27-2-386
savedefault
boot

title		Debian GNU/Linux, kernel 2.4.27-2-386 (recovery mode)
root		(hd0,0)
kernel		/boot/vmlinuz-2.4.27-2-386 root=/dev/hda1 ro single
initrd		/boot/initrd.img-2.4.27-2-386
savedefault
boot

### END DEBIAN AUTOMAGIC KERNELS LIST

# This is a divider, added to separate the menu items below from the Debian
# ones.
title		Other operating systems:
root
Can you help me?
Reply With Quote
  #19  
Old 8th March 2006, 22:25
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,752 Times in 2,582 Posts
Default

Can you post your /etc/fstab here?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #20  
Old 12th March 2006, 18:27
Flip Flip is offline
Junior Member
 
Join Date: Mar 2006
Posts: 8
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

This is my /etc/fstab

Code:
# /etc/fstab: static file system information.
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
/dev/hda1       /               ext3    defaults,errors=remount-ro 0       1
/dev/hda5       none            swap    sw              0       0
/dev/hdc        /media/cdrom0   iso9660 ro,user,noauto  0       0
/dev/fd0        /media/floppy0  auto    rw,user,noauto  0       0
/dev/hdb1       /home           ext3    defaults,errors=remount-ro 0       1
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 15:15.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.