Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #21  
Old 23rd January 2006, 06:01
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

The end of the log lines are cut off. Can you post the complete lines again?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Sponsored Links
  #22  
Old 23rd January 2006, 07:55
--::wizZzard::-- --::wizZzard::-- is offline
Member
 
Join Date: Jan 2006
Location: Gera / Thueringen / Germany
Posts: 39
Thanks: 0
Thanked 0 Times in 0 Posts
Default

oh man these lines are long! i had to download the file to my local computer....so here we go:

Jan 23 08:36:11 85-31-186-56 postfix/qmgr[798]: 1006B7BFB6: to=<root@debian_webmin.blue.kundencontroller.de>, orig_to=<root>, relay=none, delay=41770, status=deferred (delivery temporarily suspended: connect to debian_webmin.blue.kundencontroller.de[192.168.0.29]: Connection timed out)
Jan 23 08:36:11 85-31-186-56 postfix/qmgr[798]: B97C67BFD9: to=<web8_project-bizarre.de@debian_webmin.blue.kundencontroller.de> , orig_to=<web8_project-bizarre.de@mail.project-bizarre.de>, relay=none, delay=388541, status=deferred (delivery temporarily suspended: connect to debian_webmin.blue.kundencontroller.de[192.168.0.29]: Connection timed out)

Jan 23 08:36:11 85-31-186-56 postfix/qmgr[798]: B88FB7BFC1: to=<root@debian_webmin.blue.kundencontroller.de>, orig_to=<root>, relay=none, delay=171370, status=deferred (delivery temporarily suspended: connect to debian_webmin.blue.kundencontroller.de[192.168.0.29]: Connection timed out)

Jan 23 08:36:11 85-31-186-56 postfix/qmgr[798]: 822207BF5B: to=<root@debian_webmin.blue.kundencontroller.de>, relay=none, delay=168799, status=deferred (delivery temporarily suspended: connect to debian_webmin.blue.kundencontroller.de[192.168.0.29]: Connection timed out)

Jan 23 08:36:11 85-31-186-56 postfix/qmgr[798]: 8D3A87BFAE: to=<www-data@debian_webmin.blue.kundencontroller.de>, relay=none, delay=49391, status=deferred (delivery temporarily suspended: connect to debian_webmin.blue.kundencontroller.de[192.168.0.29]: Connection timed out)

Jan 23 08:36:11 85-31-186-56 postfix/qmgr[798]: 69F877BFDF: to=<web8_project-bizarre.de@debian_webmin.blue.kundencontroller.de> , orig_to=<admin@project-bizarre.de>, relay=none, delay=305041, status=deferred (delivery temporarily suspended: connect to debian_webmin.blue.kundencontroller.de[192.168.0.29]: Connection timed out)

so, now they are completely posted
Reply With Quote
  #23  
Old 23rd January 2006, 18:13
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Quote:
Originally Posted by --::wizZzard::--
Jan 23 08:36:11 85-31-186-56 postfix/qmgr[798]: 69F877BFDF: to=<web8_project-bizarre.de@debian_webmin.blue.kundencontroller.de> , orig_to=<admin@project-bizarre.de>, relay=none, delay=305041, status=deferred (delivery temporarily suspended: connect to debian_webmin.blue.kundencontroller.de[192.168.0.29]: Connection timed out)

so, now they are completely posted
Somehow your server tries to connect to a private IP address (192.168.0.29).
What's in /etc/hosts and /etc/postfix/main.cf? Also post the output of
Code:
hostname
and
Code:
hostname -f
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #24  
Old 24th January 2006, 10:01
--::wizZzard::-- --::wizZzard::-- is offline
Member
 
Join Date: Jan 2006
Location: Gera / Thueringen / Germany
Posts: 39
Thanks: 0
Thanked 0 Times in 0 Posts
Default

cat /etc/hosts (preconfigured from Server Provider, here i have editet nothing)
127.0.0.1 localhost
192.168.0.8 INSTALLSERVER
85.31.186.56 85-31-186-56
192.168.0.29 debian_webmin.blue.kundencontroller.de debian_webmin
127.0.0.1 localhost

cat etc/postfix/main.cf:
# See /usr/share/postfix/main.cf.dist for a commented, more complete version

smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

myhostname = debian_webmin.blue.kundencontroller.de
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
#mydestination = debian_webmin.blue.kundencontroller.de, localhost.blue.kundenco
ntroller.de, , localhost
relayhost =
mynetworks = 127.0.0.0/8
mailbox_command =
mailbox_size_limit = 0
recipient_delimiter = +
inet_interfaces = all
smtpd_sasl_local_domain =
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,rejec
t_unauth_destination
smtpd_tls_auth_only = no
smtp_use_tls = yes
smtpd_use_tls = yes
smtp_tls_note_starttls_offer = yes
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom
home_mailbox = Maildir/

virtual_maps = hash:/etc/postfix/virtusertable

and:

85-31-186-56:/# hostname
85-31-186-56
85-31-186-56:/# hostname -f
85-31-186-56
85-31-186-56:/#



mydestination = /etc/postfix/local-host-names
Reply With Quote
  #25  
Old 24th January 2006, 21:13
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Quote:
Originally Posted by --::wizZzard::--
cat /etc/hosts (preconfigured from Server Provider, here i have editet nothing)
127.0.0.1 localhost
192.168.0.8 INSTALLSERVER
85.31.186.56 85-31-186-56
192.168.0.29 debian_webmin.blue.kundencontroller.de debian_webmin
127.0.0.1 localhost
Either change /etc/hosts to

Code:
127.0.0.1 localhost.localdomain localhost debian_webmin.blue.kundencontroller.de debian_webmin
192.168.0.8 INSTALLSERVER
85.31.186.56 85-31-186-56.blue.kundencontroller.de 85-31-186-56
or - this is the better solution, I think - change myhostname in /etc/postfix/main.cf from debian_webmin.blue.kundencontroller.de to 85-31-186-56.blue.kundencontroller.de and restart Postfix.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #26  
Old 24th January 2006, 21:58
--::wizZzard::-- --::wizZzard::-- is offline
Member
 
Join Date: Jan 2006
Location: Gera / Thueringen / Germany
Posts: 39
Thanks: 0
Thanked 0 Times in 0 Posts
Default

must i wait some time untill the changes take efect after i restartet postfix ?(postfix reload was the command, wasn't it?)

2nd: can i alter both? etc/hosts and /etc/postfix/main.cf ?

what purpose has the line "192.168.0.29 debian_webmin.blue.kundencontroller.de debian_webmin" in etc/hosts ?

Last edited by --::wizZzard::--; 24th January 2006 at 22:00.
Reply With Quote
  #27  
Old 24th January 2006, 22:48
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Quote:
Originally Posted by --::wizZzard::--
must i wait some time untill the changes take efect after i restartet postfix ?(postfix reload was the command, wasn't it?)
No, the changes should work immediately.
The command is
Code:
/etc/init.d/postfix restart
Quote:
Originally Posted by --::wizZzard::--
2nd: can i alter both? etc/hosts and /etc/postfix/main.cf ?
Sure, you can change both.
Quote:
Originally Posted by --::wizZzard::--
what purpose has the line "192.168.0.29 debian_webmin.blue.kundencontroller.de debian_webmin" in etc/hosts ?
It tells your server that debian_webmin.blue.kundencontroller.de has the IP address 192.168.0.29 so it doesn't have to ask a DNS server.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #28  
Old 24th January 2006, 23:21
--::wizZzard::-- --::wizZzard::-- is offline
Member
 
Join Date: Jan 2006
Location: Gera / Thueringen / Germany
Posts: 39
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko
It tells your server that debian_webmin.blue.kundencontroller.de has the IP address 192.168.0.29 so it doesn't have to ask a DNS server.
i thought that, but why want somebody this? i think i don't need that server.

by the way i changed postfix/main.cf and restartet the postfix service.

then i had a look at the error logs, and the problem is still there. the mailserver reroutes the message and gets a time out from 192.168.0.29. perhaps i change etc/hosts now too! results tomorrow.
Reply With Quote
  #29  
Old 25th January 2006, 07:25
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,735 Times in 2,571 Posts
Default

Quote:
Originally Posted by --::wizZzard::--
i thought that, but why want somebody this? i think i don't need that server.
I think your hoster should provide better Linux images. The /etc/hosts file looks pretty weird...
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #30  
Old 25th January 2006, 09:29
--::wizZzard::-- --::wizZzard::-- is offline
Member
 
Join Date: Jan 2006
Location: Gera / Thueringen / Germany
Posts: 39
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

so...i changed both.....like you said

here the last lines of my mail.log

Jan 25 10:05:05 85-31-186-56 postfix/postfix-script: stopping the Postfix mail system
Jan 25 10:05:05 85-31-186-56 postfix/master[16451]: terminating on signal 15
Jan 25 10:05:05 85-31-186-56 postfix/postfix-script: starting the Postfix mail system
Jan 25 10:05:05 85-31-186-56 postfix/master[24883]: daemon started -- version 2.1.5
Jan 25 10:05:26 85-31-186-56 postfix/smtpd[24891]: connect from smtp07.web.de[217.72.192.225]
Jan 25 10:05:26 85-31-186-56 postfix/smtpd[24891]: setting up TLS connection from smtp07.web.de[217.72.192.225]
Jan 25 10:05:26 85-31-186-56 postfix/smtpd[24891]: TLS connection established from smtp07.web.de[217.72.192.225]: TLSv1 with cipher DHE-RSA-AES256-SHA (256/256 bits)
Jan 25 10:05:26 85-31-186-56 postfix/smtpd[24891]: E7F7C7BFB9: client=smtp07.web.de[217.72.192.225]
Jan 25 10:05:26 85-31-186-56 postfix/cleanup[24894]: E7F7C7BFB9: message-id=<E1F1ffm-0008T2-00@smtp07.web.de>
Jan 25 10:05:26 85-31-186-56 postfix/qmgr[24886]: E7F7C7BFB9: from=<michael.wizard@web.de>, size=7894, nrcpt=1 (queue active)
Jan 25 10:05:27 85-31-186-56 postfix/smtpd[24891]: disconnect from smtp07.web.de[217.72.192.225]
Jan 25 10:05:27 85-31-186-56 postfix/smtp[24895]: E7F7C7BFB9: to=<web8_project-bizarre.de@debian_webmin.blue.kundencontroller.de> , , orig_to=<admin@project-bizarre.de>, relay=none, delay=1, status=bounced (mail for debian_webmin.blue.kundencontroller.de loops back to myself)
Jan 25 10:05:27 85-31-186-56 postfix/cleanup[24894]: 0944F7BFC8: message-id=<20060125090527.0944F7BFC8@85-31-186-56.blue.kundencontroller.de>
Jan 25 10:05:27 85-31-186-56 postfix/qmgr[24886]: 0944F7BFC8: from=<>, size=10035, nrcpt=1 (queue active)
Jan 25 10:05:27 85-31-186-56 postfix/qmgr[24886]: E7F7C7BFB9: removed
Jan 25 10:05:44 85-31-186-56 postfix/smtp[24895]: 0944F7BFC8: to=<michael.wizard@web.de>, relay=mx-ha01.web.de[217.72.192.149], delay=17, status=sent (250 OK id=1F1fg5-00053h-00)
Jan 25 10:05:44 85-31-186-56 postfix/qmgr[24886]: 0944F7BFC8: removed

in the webmail-->inbox ore no mails, except through the webmail how can i get to my mails? what i have to enter as "pop3 server name" and "smtp server name" both mail.project-bizarre.de ?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How to send mails using php mail function outside domain pankaj Technical 1 19th December 2005 22:09
How to retrive mails from 2nd server dstme Server Operation 3 1st December 2005 18:28
I can't get root mails delivered to other account killfrog HOWTO-Related Questions 5 28th October 2005 02:22
Lost arrived mails ManuelW Installation/Configuration 1 21st October 2005 00:21
howto filter mails Ovidiu Installation/Configuration 2 16th October 2005 18:04


All times are GMT +2. The time now is 12:33.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.