Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 25th February 2008, 23:53
mexus mexus is offline
Junior Member
 
Join Date: May 2007
Posts: 23
Thanks: 1
Thanked 0 Times in 0 Posts
Default Domainkeys In Postfix problem

I have followed: http://www.howtoforge.com/virtual-us...ysql-centos5.1 and http://www.howtoforge.com/how-to-imp...lter-centos5.1

When i try to start dk-milter:
[root@mexus domainkeys]# service dk-milter start
Starting DomainKeys milter (dk-filter #0): dk-filter: smfi_opensocket() failed

I tried:
chown dk-milt:mail *.pem
postfix and dk..... restart but still there is no dk.sock.
How can i fix this?
I read http://www.howtoforge.com/forums/showthread.php?t=20410 and

http://domainkeys.sourceforge.net/policycheck.html says:
Testing mexus.org
Policy TXT=t=y; o=~
This policy record appears valid.
o ~ Domain signs some email
t y Domain is in test mode

the keys are identical (double checked that).

Please help me!
Reply With Quote
Sponsored Links
  #2  
Old 26th February 2008, 07:15
topdog topdog is offline
Senior Member
 
Join Date: Jan 2008
Location: South Africa
Posts: 1,352
Thanks: 0
Thanked 153 Times in 150 Posts
Default

Seems like the socket can not be created do you have selinux in enforcing mode ?

What is the output of
Code:
ls /var/run/ -l
__________________
----
http://www.topdog.za.net - Got Linux problems ? - I can help.
http://www.baruwa.org - Try it.
Reply With Quote
  #3  
Old 26th February 2008, 11:22
mexus mexus is offline
Junior Member
 
Join Date: May 2007
Posts: 23
Thanks: 1
Thanked 0 Times in 0 Posts
Default

drwxrwx--- 2 dk-milt mail 4096 Feb 26 00:14 dk-milter

se linux is disabled....
Reply With Quote
  #4  
Old 26th February 2008, 11:26
topdog topdog is offline
Senior Member
 
Join Date: Jan 2008
Location: South Africa
Posts: 1,352
Thanks: 0
Thanked 153 Times in 150 Posts
Default

Are you sure that there is no socket in
/var/run/dk-milter ?

If so then post your config here its see may be there is a typo in the location of your socket
__________________
----
http://www.topdog.za.net - Got Linux problems ? - I can help.
http://www.baruwa.org - Try it.
Reply With Quote
  #5  
Old 26th February 2008, 11:41
mexus mexus is offline
Junior Member
 
Join Date: May 2007
Posts: 23
Thanks: 1
Thanked 0 Times in 0 Posts
Default

sorry, yesterday it was missing... not its there:
srwxrwx--- 1 dk-milt mail 0 Feb 26 00:14 dk.sock

Here is the config:
USER="dk-milt"
PORT="local:/var/run/dk-milter/dk.sock"
SIGNING_DOMAIN="mexus.org"
SELECTOR_NAME="mexus.org"
KEYFILE="/etc/mail/domainkeys/dk_mexus.org.pem"
(its the same with the delault value; i'm sure that there is no typo in the generated files i have double checked....)
SIGNER=yes
VERIFIER=yes
CANON=simple
REJECTION="bad=r,dns=t,int=t,no=a,miss=r"
EXTRA_ARGS="-h -l -D"
MILTER_GROUP="mail"

Last edited by mexus; 26th February 2008 at 11:43.
Reply With Quote
  #6  
Old 26th February 2008, 11:44
topdog topdog is offline
Senior Member
 
Join Date: Jan 2008
Location: South Africa
Posts: 1,352
Thanks: 0
Thanked 153 Times in 150 Posts
Default

Okay now that its there what error are you getting from postfix ?
__________________
----
http://www.topdog.za.net - Got Linux problems ? - I can help.
http://www.baruwa.org - Try it.
Reply With Quote
  #7  
Old 26th February 2008, 16:01
mexus mexus is offline
Junior Member
 
Join Date: May 2007
Posts: 23
Thanks: 1
Thanked 0 Times in 0 Posts
Default

>/etc/init.d/postfix restart
Shutting down postfix: [ OK ]
Starting postfix: [ OK ]




Feb 26 16:57:41 mexus sendmail[19418]: m1QEvfhA019418: Authentication-Warning: mexus.org: apache set sender to master@mexus.org using -f
Feb 26 16:57:41 mexus sendmail[19418]: m1QEvfhA019418: from=master@mexus.org, size=353, class=0, nrcpts=1, msgid=<e39ed2c3c6762b41ad1bd57095b5c7a3@localhost> , relay=apache@localhost
Feb 26 16:57:41 mexus postfix/smtpd[19419]: connect from localhost.localdomain[127.0.0.1]
Feb 26 16:57:41 mexus postfix/smtpd[19419]: warning: connect to Milter service unix:/var/run/dk-milter/dk.sock: Connection refused
Feb 26 16:57:41 mexus postfix/smtpd[19419]: NOQUEUE: milter-reject: CONNECT from localhost.localdomain[127.0.0.1]: 451 4.7.1 Service unavailable - try again later; proto=SMTP
Feb 26 16:57:41 mexus postfix/smtpd[19419]: NOQUEUE: milter-reject: EHLO from localhost.localdomain[127.0.0.1]: 451 4.7.1 Service unavailable - try again later; proto=SMTP
Feb 26 16:57:41 mexus postfix/smtpd[19419]: NOQUEUE: milter-reject: MAIL from localhost.localdomain[127.0.0.1]: 451 4.7.1 Service unavailable - try again later; proto=ESMTP helo=<mexus.org>
Feb 26 16:57:41 mexus sendmail[19418]: m1QEvfhA019418: to=mexus@abv.bg, delay=00:00:00, xdelay=00:00:00, mailer=relay, pri=30353, relay=[127.0.0.1] [127.0.0.1], dsn=4.0.0, stat=Deferred: 451 4.7.1 Service unavailable - try again later
Feb 26 16:57:41 mexus postfix/smtpd[19419]: disconnect from localhost.localdomain[127.0.0.1]
Feb 26 16:57:41 mexus imapd: LOGOUT, user=master@mexus.org, ip=[::ffff:127.0.0.1], headers=0, body=0, rcvd=450, sent=423, time=0
Feb 26 16:57:41 mexus imapd: Connection, ip=[::ffff:127.0.0.1]
Feb 26 16:57:41 mexus imapd: LOGIN, user=master@mexus.org, ip=[::ffff:127.0.0.1], port=[56657], protocol=IMAP
Feb 26 16:57:41 mexus imapd: LOGOUT, user=master@mexus.org, ip=[::ffff:127.0.0.1], headers=2146, body=0, rcvd=478, sent=6190, time=0
Feb 26 16:57:42 mexus imapd: Connection, ip=[::ffff:127.0.0.1]
Feb 26 16:57:42 mexus imapd: LOGIN, user=master@mexus.org, ip=[::ffff:127.0.0.1], port=[56658], protocol=IMAP
Feb 26 16:57:42 mexus imapd: LOGOUT, user=master@mexus.org, ip=[::ffff:127.0.0.1], headers=0, body=0, rcvd=301, sent=1799, time=0
Reply With Quote
  #8  
Old 26th February 2008, 16:10
topdog topdog is offline
Senior Member
 
Join Date: Jan 2008
Location: South Africa
Posts: 1,352
Thanks: 0
Thanked 153 Times in 150 Posts
Default

Try running it on a tcp port instead of a unix socket, the other thread has details on doing that. If it fails then you did something wrong with the way you setup the keys.
__________________
----
http://www.topdog.za.net - Got Linux problems ? - I can help.
http://www.baruwa.org - Try it.
Reply With Quote
  #9  
Old 26th February 2008, 16:21
mexus mexus is offline
Junior Member
 
Join Date: May 2007
Posts: 23
Thanks: 1
Thanked 0 Times in 0 Posts
Default

I tried that too.
I did that:
/usr/share/doc/dk-milter-0.6.0/gentxt.sh mexus.org mexus.org
i send to the dns admin of the domain to add this to the zone:
default._domainkey IN TXT "g=; k=rsa; t=y; p=MFwwDQYJKoZIhvcNAQEBBQADSwAwSAJBAJQfGTmsFzILU6ep 6aSFg+WrTkaOLmoRillFNbOpNOr5Gst5H8wG9Oh2SpUytaruP/7j/eWQ8Wyz6zX2gAtzwF0CAwEAAQ==" ; ----- DomainKey default for example.com (example)
_domainkey IN TXT "t=y; o=~"

mv default.private /etc/mail/domainkeys/dk_mexus.org.pem
chown dk-milt:dk-milt /etc/mail/domainkeys/dk_mexus.org.pem
chmod 600 /etc/mail/domainkeys/dk_mexus.org.pem

that's all. Have double checked the keys are fine.
Where could be the problem?

> service dk-milter restart
Shutting down all DomainKeys milter (dk-filter): [FAILED]
Cleanup for DomainKeys milter (dk-filter #0):
Starting DomainKeys milter (dk-filter #0): dk-filter: smfi_opensocket() failed
Reply With Quote
  #10  
Old 26th February 2008, 16:25
topdog topdog is offline
Senior Member
 
Join Date: Jan 2008
Location: South Africa
Posts: 1,352
Thanks: 0
Thanked 153 Times in 150 Posts
 
Default

Quote:
Originally Posted by mexus
I tried that too.
I did that:
/usr/share/doc/dk-milter-0.6.0/gentxt.sh mexus.org mexus.org
i send to the dns admin of the domain to add this to the zone:
default._domainkey IN TXT "g=; k=rsa; t=y; p=MFwwDQYJKoZIhvcNAQEBBQADSwAwSAJBAJQfGTmsFzILU6ep 6aSFg+WrTkaOLmoRillFNbOpNOr5Gst5H8wG9Oh2SpUytaruP/7j/eWQ8Wyz6zX2gAtzwF0CAwEAAQ==" ; ----- DomainKey default for example.com (example)
_domainkey IN TXT "t=y; o=~"

mv default.private /etc/mail/domainkeys/dk_mexus.org.pem
chown dk-milt:dk-milt /etc/mail/domainkeys/dk_mexus.org.pem
chmod 600 /etc/mail/domainkeys/dk_mexus.org.pem

that's all. Have double checked the keys are fine.
Where could be the problem?

> service dk-milter restart
Shutting down all DomainKeys milter (dk-filter): [FAILED]
Cleanup for DomainKeys milter (dk-filter #0):
Starting DomainKeys milter (dk-filter #0): dk-filter: smfi_opensocket() failed
smfi_opensocket() is only when you are using a unix socket and the socket file exists i.e was not removed by the previous process.

If your PORT is pointing to a TCP socket you cannot get that error.
__________________
----
http://www.topdog.za.net - Got Linux problems ? - I can help.
http://www.baruwa.org - Try it.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
postfix problems with smtp linkdeb Server Operation 13 15th March 2014 17:58
Mail System Error - Returned Mail tristanlee85 General 16 16th March 2008 09:40
Postfix problem: lost connection after CONNECT from unknown fernando_torrez Server Operation 5 30th November 2007 14:17
Centos 4.4 32bit Hangs, High Server load 3cwired_com Server Operation 11 16th November 2006 15:47
Verify email setup meekish Installation/Configuration 28 27th October 2006 15:36


All times are GMT +2. The time now is 22:51.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.