#1  
Old 29th February 2008, 12:14
hvrossum hvrossum is offline
Member
 
Join Date: Dec 2007
Posts: 66
Thanks: 8
Thanked 0 Times in 0 Posts
Default Messed up Mailserver

Hi,

I tried to do some updating of my spamassisan clamav. This didn't go well, as I got error messages so I wanted to stop with it.

I followed guidelines which I found in the howto section, http://www.howtoforge.com/postfix_an..._clamav_ubuntu

But as I already had a wrking postfix with virtual users setup I didn;t start from the top. I was actually only interested in updating spam and clamav.
BUt got into troubles

I would like to resolve it that my postfix will work again (no accounts are capable of receiving mail at this moment.

Telnet localhost 25 followed by the command ehlo localhost gives me a connection refused message.

My mail.warn file gives this error
Feb 29 11:55:58 mussorubuntu postfix/master[8248]: warning: process /usr/lib/postfix/smtpd pid 8675 exit status 1
Feb 29 11:55:58 mussorubuntu postfix/master[8248]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling

My maillog gives following messages:
Feb 29 11:56:59 mussorubuntu postfix/master[8248]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling
Feb 29 11:57:59 mussorubuntu postfix/smtpd[8714]: fatal: open database /etc/postfix/sender_access.db: No such file or directory
Feb 29 11:58:00 mussorubuntu postfix/master[8248]: warning: process /usr/lib/postfix/smtpd pid 8714 exit status 1
Feb 29 11:58:00 mussorubuntu postfix/master[8248]: warning: /usr/lib/postfix/smtpd: bad command startup -- throttling

How should I repair this??
Thanks
Harry
__________________
I am stil a Linux amateur, never thought that a sales person would like fiddling around with Linux.

Setup:
Dell Power Edge SC440
Ubuntu 8.04
ISPConfig
Webmin 1.420
Reply With Quote
Sponsored Links
  #2  
Old 29th February 2008, 12:19
topdog topdog is offline
Senior Member
 
Join Date: Jan 2008
Location: South Africa
Posts: 1,352
Thanks: 0
Thanked 153 Times in 150 Posts
Default

Create the file /etc/postfix/sender_access then run this command
Code:
postmap /etc/postfix/sender_access
__________________
----
http://www.topdog.za.net - Got Linux problems ? - I can help.
http://www.baruwa.org - Try it.
Reply With Quote
The Following User Says Thank You to topdog For This Useful Post:
hvrossum (29th February 2008)
  #3  
Old 29th February 2008, 12:27
hvrossum hvrossum is offline
Member
 
Join Date: Dec 2007
Posts: 66
Thanks: 8
Thanked 0 Times in 0 Posts
Default

That was easy, great thanks.

any advice how to do clamav and spamassisan
__________________
I am stil a Linux amateur, never thought that a sales person would like fiddling around with Linux.

Setup:
Dell Power Edge SC440
Ubuntu 8.04
ISPConfig
Webmin 1.420
Reply With Quote
  #4  
Old 29th February 2008, 12:29
topdog topdog is offline
Senior Member
 
Join Date: Jan 2008
Location: South Africa
Posts: 1,352
Thanks: 0
Thanked 153 Times in 150 Posts
Default

Whats the problem with those ? Am sure you can continue following the howto for that.
__________________
----
http://www.topdog.za.net - Got Linux problems ? - I can help.
http://www.baruwa.org - Try it.
Reply With Quote
  #5  
Old 29th February 2008, 12:45
hvrossum hvrossum is offline
Member
 
Join Date: Dec 2007
Posts: 66
Thanks: 8
Thanked 0 Times in 0 Posts
Default

I ran into problems updating clamav.

But I'll try again starting from paragraph 4.1 from this Howto
__________________
I am stil a Linux amateur, never thought that a sales person would like fiddling around with Linux.

Setup:
Dell Power Edge SC440
Ubuntu 8.04
ISPConfig
Webmin 1.420
Reply With Quote
  #6  
Old 29th February 2008, 12:52
topdog topdog is offline
Senior Member
 
Join Date: Jan 2008
Location: South Africa
Posts: 1,352
Thanks: 0
Thanked 153 Times in 150 Posts
Default

What were the problems maybe i can help ?
__________________
----
http://www.topdog.za.net - Got Linux problems ? - I can help.
http://www.baruwa.org - Try it.
Reply With Quote
  #7  
Old 29th February 2008, 12:55
hvrossum hvrossum is offline
Member
 
Join Date: Dec 2007
Posts: 66
Thanks: 8
Thanked 0 Times in 0 Posts
Default

THe howto told me to update clamav, I did with apt-get install command, but it keep on telling me it was outdated when I needed to configure clamav (with freshclam)
__________________
I am stil a Linux amateur, never thought that a sales person would like fiddling around with Linux.

Setup:
Dell Power Edge SC440
Ubuntu 8.04
ISPConfig
Webmin 1.420
Reply With Quote
  #8  
Old 29th February 2008, 12:59
topdog topdog is offline
Senior Member
 
Join Date: Jan 2008
Location: South Africa
Posts: 1,352
Thanks: 0
Thanked 153 Times in 150 Posts
 
Default

That means the repo has not been upgraded to the latest clamav that is available upstream. There is no need to panic.
__________________
----
http://www.topdog.za.net - Got Linux problems ? - I can help.
http://www.baruwa.org - Try it.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
How to use an external mailserver within ISPConfig? Hans General 8 3rd September 2009 19:37
Mailserver 554 Permanent Problems Message asyadiqin Server Operation 7 15th November 2007 15:09
local-host-names and external mailserver Tyrael General 2 24th September 2007 18:56
Cannot receive emails : DSN: User Unknown shiidii Installation/Configuration 24 22nd September 2006 18:05
Postfix and external Mailserver vpns2000 Installation/Configuration 2 7th April 2006 22:00


All times are GMT +2. The time now is 13:52.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.