Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 2 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 12th January 2006, 18:59
heftigrat heftigrat is offline
Member
 
Join Date: Jan 2006
Location: Chicago, IL
Posts: 62
Thanks: 0
Thanked 0 Times in 0 Posts
Default How do you set up client for SSL?

Using Mozilla Thunderbird I've tried all combinations of checking and un-checking "use secure connection (SSL)" and "use secure authentication", but nothing works. This should all be set up, correct? Is there a special port # I should be using? I can use "mail.clientdom.dom", I don't have to use "ispchost.ispcserver.dom", correct? Thanks!
Reply With Quote
Sponsored Links
  #2  
Old 12th January 2006, 21:39
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,740 Times in 2,575 Posts
Default

No, you don't have to use a special port. Are POP3s and IMAPs running? What does
Code:
netstat -tap
show? Which distribution do you use?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 12th January 2006, 22:05
heftigrat heftigrat is offline
Member
 
Join Date: Jan 2006
Location: Chicago, IL
Posts: 62
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Code:
root# netstat -tap
Active Internet connections (servers and established)
Proto Recv-Q Send-Q Local Address           Foreign Address         State       PID/Program name
tcp        0      0 localhost.localdo:32769 *:*                     LISTEN     6675/hpiod
tcp        0      0 localhost.localdo:32770 *:*                     LISTEN     6688/python
tcp        0      0 localhost.localdo:mysql *:*                     LISTEN     6896/mysqld
tcp        0      0 *:81                    *:*                     LISTEN     14108/ispconfig_htt
tcp        0      0 *:ftp                   *:*                     LISTEN     15688/proftpd: (acc
tcp        0      0 10.57.3.33:domain       *:*                     LISTEN     14278/named
tcp        0      0 localhost.locald:domain *:*                     LISTEN     14278/named
tcp        0      0 localhost.localdoma:ipp *:*                     LISTEN     10899/cupsd
tcp        0      0 *:smtp                  *:*                     LISTEN     25737/master
tcp        0      0 localhost.localdoma:953 *:*                     LISTEN     14278/named
tcp        0      0 localhost.localdo:50506 localhost.localdo:32769 ESTABLISHED6688/python
tcp        0      0 localhost.localdo:32769 localhost.localdo:50506 ESTABLISHED6675/hpiod
tcp6       0      0 *:imaps                 *:*                     LISTEN     6776/couriertcpd
tcp6       0      0 *:pop3s                 *:*                     LISTEN     6817/couriertcpd
tcp6       0      0 *:pop3                  *:*                     LISTEN     6794/couriertcpd
tcp6       0      0 *:imap2                 *:*                     LISTEN     6753/couriertcpd
tcp6       0      0 *:www                   *:*                     LISTEN     16391/apache2
tcp6       0      0 *:ssh                   *:*                     LISTEN     7157/sshd
tcp6       0      0 ip6-localhost:953       *:*                     LISTEN     14278/named
tcp6       0      0 *:https                 *:*                     LISTEN     16391/apache2
Ubuntu 5.10 - Breezy
Reply With Quote
  #4  
Old 13th January 2006, 11:47
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,763
Thanks: 821
Thanked 5,331 Times in 4,183 Posts
Default

This looks fine so far.

Did you have problems with sending mail over an encrypted channel or receiving mail?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 13th January 2006, 16:36
heftigrat heftigrat is offline
Member
 
Join Date: Jan 2006
Location: Chicago, IL
Posts: 62
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till
This looks fine so far.

Did you have problems with sending mail over an encrypted channel or receiving mail?
Well, I haven't even tested sending yet, just tryin to get POP3 working. I am feeling so down about this.

Thanks for your help though, any more ideas?

btw, you sure I don't have to use a special port? wasn't there a port in the 900's for SSL?

Last edited by heftigrat; 13th January 2006 at 16:45. Reason: btw question
Reply With Quote
  #6  
Old 13th January 2006, 16:50
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,763
Thanks: 821
Thanked 5,331 Times in 4,183 Posts
Default

For receiving you need a special port, thats why i ask

pop3s port: 995
imaps port: 993
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 13th January 2006, 17:31
heftigrat heftigrat is offline
Member
 
Join Date: Jan 2006
Location: Chicago, IL
Posts: 62
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till
pop3s port: 995
imaps port: 993
Yup, Thunderbird defaults to 995 for SSL. I still get a "connection timed out to <server>" error though.
Reply With Quote
  #8  
Old 13th January 2006, 19:15
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,763
Thanks: 821
Thanked 5,331 Times in 4,183 Posts
Default

If you enabled the ISPConfig firewall, you might have to open the ports first.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #9  
Old 13th January 2006, 19:19
heftigrat heftigrat is offline
Member
 
Join Date: Jan 2006
Location: Chicago, IL
Posts: 62
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Actually, I figured out the problem. I noticed under the "Client" for a site, SSL is not checked. I attempted to check it and got the following error message:
Code:
An SSL certificate does already exist for this IP.
How do I fix this?
Reply With Quote
  #10  
Old 13th January 2006, 19:26
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,763
Thanks: 821
Thanked 5,331 Times in 4,183 Posts
 
Default

You can only have one SSL certificate for each IP address. This is an apache limit, not ISPConfig limit.

Remove the SSL option from the other site with the same IP where you enabled SSL and you can enable it for this site.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Big client log files Jorem Installation/Configuration 2 13th November 2007 09:52
Client can't see entries in the recycle bin flykip General 5 1st February 2006 10:30
from http to https after installation? Mahir Installation/Configuration 25 7th December 2005 20:40
mysqlcheck has found corrupt tables m u r Installation/Configuration 1 18th August 2005 10:47
Install different webmail Client Horde jernis Installation/Configuration 2 31st July 2005 07:43


All times are GMT +2. The time now is 23:44.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.