#1  
Old 26th February 2008, 21:23
xciso xciso is offline
Member
 
Join Date: Feb 2008
Posts: 55
Thanks: 0
Thanked 1 Time in 1 Post
Default PHP dont work

Hi.
My first post at this forum!
I have installed ispconfig at my server with debian 4.0 (the perfect setup guide).
I have also installed suphp (with the suphp guide).

My problem is that i cant get php to work.
I have triend in hours now, but I cant get it work

When i make a phpinfo.php file and try it in my browser it just show <? phpinfo(); ?>

If i try with with any other php files it look like this for example:

<?php
/*
$Id: index.php,v 1.1 2003/06/11 17:37:59 hpdl Exp $

and so on.


Please help
Reply With Quote
Sponsored Links
  #2  
Old 26th February 2008, 21:43
edge edge is offline
Moderator
 
Join Date: Dec 2005
Location: The Netherlands
Posts: 2,036
Thanks: 268
Thanked 152 Times in 132 Posts
Default

Did you enable PHP for that site?
It's under ISP manager > the-site-you-created > Basis.
You will see an option "PHP Scripts", that you need to enable
__________________
Never execute code written on a Friday or a Monday.
Reply With Quote
  #3  
Old 26th February 2008, 23:38
raypettersen raypettersen is offline
Member
 
Join Date: Oct 2007
Posts: 33
Thanks: 1
Thanked 0 Times in 0 Posts
Default

I`ve also tried to make suphp work with debian etch. It seems quite impossible when following the guides at howtoforge... The closest I came was to get a error 500 (uid error). I even tried to set the minimum uid down to 1 instead of 100 (default), without any results.
Reply With Quote
  #4  
Old 27th February 2008, 02:38
xciso xciso is offline
Member
 
Join Date: Feb 2008
Posts: 55
Thanks: 0
Thanked 1 Time in 1 Post
Default

Ofcuarse I have set php-scripts on for all my sites.

Last edited by xciso; 27th February 2008 at 02:43.
Reply With Quote
  #5  
Old 27th February 2008, 08:21
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,408
Thanks: 834
Thanked 5,496 Times in 4,326 Posts
Default

Quote:
Originally Posted by raypettersen
I`ve also tried to make suphp work with debian etch. It seems quite impossible when following the guides at howtoforge... The closest I came was to get a error 500 (uid error). I even tried to set the minimum uid down to 1 instead of 100 (default), without any results.
SuPHP works fine for me with the guides from howtoforge. If you dont post exactly what you did, we will not be able to help you.

Please make a new thread for this.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #6  
Old 27th February 2008, 08:22
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,408
Thanks: 834
Thanked 5,496 Times in 4,326 Posts
Default

Quote:
Originally Posted by xciso
Ofcuarse I have set php-scripts on for all my sites.
Please post the Vhost definition for the site from the file /etc/apache2/vhosts/Vhost_ispconfig.conf
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #7  
Old 27th February 2008, 10:32
raypettersen raypettersen is offline
Member
 
Join Date: Oct 2007
Posts: 33
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Im giving it another shot today. Note that I am not using debian sarge, like in the howto`s, but debian etch. I`ll report later, how it went. This is my third attempt from a clean ISPconfig install.

About the vhost config, everything looked okay. The suphp insertion worked like it should, but it resulted in a 500 min_uid error.

One other thing, when I did the guide, I ended up with two suphp.conf files. One in /etc/, and one in /etc/suphp/.. Is that normal? What is the correct conf file?
Reply With Quote
  #8  
Old 27th February 2008, 10:37
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,408
Thanks: 834
Thanked 5,496 Times in 4,326 Posts
Default

The howtos are available for debian etch too. please have a look at the ispconfig documentation page and compare your setup with the correct howto for debian etch.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #9  
Old 27th February 2008, 11:12
raypettersen raypettersen is offline
Member
 
Join Date: Oct 2007
Posts: 33
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Did the reinstall and ended up with the same irritating 500 errorpage.

Here is my vhost file :

Quote:
<VirtualHost 10.100.120.150:80>
ServerName php.wisepublisher.com:80
ServerAdmin webmaster@wisepublisher.com
DocumentRoot /var/www/web1/web
ServerAlias wisepublisher.com
DirectoryIndex index.html index.htm index.php index.php5 index.php4 index.php3 $Alias /cgi-bin/ /var/www/web1/cgi-bin/
AddHandler cgi-script .cgi
AddHandler cgi-script .pl
ErrorLog /var/www/web1/log/error.log
AddType application/x-httpd-php .php .php3 .php4 .php5
<Directory /var/www/web1/web>
suPHP_Engine on
suPHP_UserGroup nobody web1
AddHandler x-httpd-php .php .php3 .php4 .php5
suPHP_AddHandler x-httpd-php
SetEnv php_safe_mode On
</Directory>
Alias /error/ "/var/www/web1/web/error/"
ErrorDocument 400 /error/invalidSyntax.html
ErrorDocument 401 /error/authorizationRequired.html
ErrorDocument 403 /error/forbidden.html
ErrorDocument 404 /error/fileNotFound.html
ErrorDocument 405 /error/methodNotAllowed.html
ErrorDocument 500 /error/internalServerError.html
ErrorDocument 503 /error/overloaded.html
AliasMatch ^/~([^/]+)(/(.*))? /var/www/web1/user/$1/web/$3
AliasMatch ^/users/([^/]+)(/(.*))? /var/www/web1/user/$1/web/$3
</VirtualHost>
This is the guide i followed in this case :

http://www.howtoforge.com/install-su...2.20-and-above

Here is my suphp.conf :

Quote:
[global]
;Path to logfile
logfile=/var/log/suphp.log
;Loglevel
loglevel=info
;User Apache is running as
webserver_user=www-data
;Path all scripts have to be in
docroot=/
;Path to chroot() to before executing script
;chroot=/mychroot
; Security options
allow_file_group_writeable=true
allow_file_others_writeable=false
allow_directory_group_writeable=true
allow_directory_others_writeable=false
;Check wheter script is within DOCUMENT_ROOT
check_vhost_docroot=true
;Send minor error messages to browser
errors_to_browser=false
;PATH environment variable
env_path=/bin:/usr/bin
;Umask to set, specify in octal notation
umask=0077
; Minimum UID
min_uid=100
; Minimum GID
min_gid=100

[handlers]
;Handler for php-scripts
x-httpd-php=php:/usr/bin/php5-cgi
;Handler for CGI-scripts
x-suphp-cgi=execute:!self
Reply With Quote
  #10  
Old 27th February 2008, 11:16
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,408
Thanks: 834
Thanked 5,496 Times in 4,326 Posts
 
Default

Have a look in the error log of the website for a detailed error message.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Freebsd 6.1 support misterm Installation/Configuration 10 9th April 2009 09:29
network issues now it says "401 The web site is blocked by administrator" Check General 3 26th February 2008 14:22
Slightly Confused (DNS & Server Help) JohnnyBGoode Installation/Configuration 26 14th August 2007 09:54
Apache2 Freezes celtic Server Operation 31 28th May 2007 17:18


All times are GMT +2. The time now is 13:55.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.